summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2013-02-02 20:26:03 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2013-02-02 20:26:03 +0000
commita9a9fc90b0faa95a4d0b7417fd8424902b091702 (patch)
tree47cd0b2d17580cd2798e41e5f05763b10a96c7fb /net-print/cups-filters
parentFix install doc, #455136 (diff)
downloadgentoo-2-a9a9fc90b0faa95a4d0b7417fd8424902b091702.tar.gz
gentoo-2-a9a9fc90b0faa95a4d0b7417fd8424902b091702.tar.bz2
gentoo-2-a9a9fc90b0faa95a4d0b7417fd8424902b091702.zip
Version bump
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key B6C5F7DE)
Diffstat (limited to 'net-print/cups-filters')
-rw-r--r--net-print/cups-filters/ChangeLog9
-rw-r--r--net-print/cups-filters/cups-filters-1.0.29.ebuild107
-rw-r--r--net-print/cups-filters/cups-filters-9999.ebuild31
-rw-r--r--net-print/cups-filters/files/cups-browsed.init.d17
-rw-r--r--net-print/cups-filters/files/cups-filters-1.0.29-openrc.patch41
5 files changed, 199 insertions, 6 deletions
diff --git a/net-print/cups-filters/ChangeLog b/net-print/cups-filters/ChangeLog
index 42843a9371e0..77ac86896ecd 100644
--- a/net-print/cups-filters/ChangeLog
+++ b/net-print/cups-filters/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-print/cups-filters
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/cups-filters/ChangeLog,v 1.48 2013/01/06 10:05:15 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/cups-filters/ChangeLog,v 1.49 2013/02/02 20:26:03 dilfridge Exp $
+
+*cups-filters-1.0.29 (02 Feb 2013)
+
+ 02 Feb 2013; Andreas K. Huettel <dilfridge@gentoo.org>
+ +cups-filters-1.0.29.ebuild, +files/cups-browsed.init.d,
+ +files/cups-filters-1.0.29-openrc.patch, cups-filters-9999.ebuild:
+ Version bump
06 Jan 2013; Agostino Sarubbo <ago@gentoo.org> cups-filters-1.0.25.ebuild:
Add ~sparc, wrt bug #449220
diff --git a/net-print/cups-filters/cups-filters-1.0.29.ebuild b/net-print/cups-filters/cups-filters-1.0.29.ebuild
new file mode 100644
index 000000000000..5b5be4558554
--- /dev/null
+++ b/net-print/cups-filters/cups-filters-1.0.29.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/cups-filters/cups-filters-1.0.29.ebuild,v 1.1 2013/02/02 20:26:03 dilfridge Exp $
+
+EAPI=4
+
+GENTOO_DEPEND_ON_PERL=no
+
+inherit base perl-module autotools
+
+if [[ "${PV}" == "9999" ]] ; then
+ inherit autotools bzr
+ EBZR_REPO_URI="http://bzr.linuxfoundation.org/openprinting/cups-filters"
+ KEYWORDS=""
+else
+ SRC_URI="http://www.openprinting.org/download/${PN}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
+fi
+DESCRIPTION="Cups PDF filters"
+HOMEPAGE="http://www.linuxfoundation.org/collaborate/workgroups/openprinting/pdfasstandardprintjobformat"
+
+LICENSE="MIT GPL-2"
+SLOT="0"
+IUSE="avahi jpeg perl png static-libs tiff"
+
+RDEPEND="
+ app-text/ghostscript-gpl
+ app-text/poppler[cxx,jpeg?,lcms,tiff?,xpdf-headers(+)]
+ >=app-text/qpdf-3.0.2
+ media-libs/fontconfig
+ media-libs/freetype:2
+ media-libs/lcms:2
+ >net-print/cups-1.5.9999
+ !<=net-print/cups-1.5.9999
+ sys-devel/bc
+ sys-libs/zlib
+ avahi? ( net-dns/avahi )
+ jpeg? ( virtual/jpeg )
+ perl? ( dev-lang/perl )
+ png? ( media-libs/libpng )
+ tiff? ( media-libs/tiff )
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-1.0.29-openrc.patch" )
+
+src_prepare() {
+ base_src_prepare
+ if [[ "${PV}" == "9999" ]]; then
+ eautoreconf
+ else
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ $(use_enable avahi) \
+ $(use_enable static-libs static) \
+ --with-fontdir="fonts/conf.avail" \
+ --with-pdftops=pdftops \
+ --enable-imagefilters \
+ $(use_with jpeg) \
+ $(use_with png) \
+ $(use_with tiff) \
+ --without-php
+}
+
+src_compile() {
+ default
+
+ if use perl; then
+ pushd "${S}/scripting/perl" > /dev/null
+ perl-module_src_prep
+ perl-module_src_compile
+ popd > /dev/null
+ fi
+}
+
+src_install() {
+ default
+
+ if use perl; then
+ pushd "${S}/scripting/perl" > /dev/null
+ perl-module_src_install
+ fixlocalpod
+ popd > /dev/null
+ fi
+
+ find "${ED}" -name '*.la' -exec rm -f {} +
+
+ if use avahi; then
+ newinitd "${FILESDIR}"/cups-browsed.init.d cups-browsed
+ fi;
+}
+
+pkg_postinst() {
+ perl-module_pkg_postinst
+
+ if use avahi; then
+ elog "This version of cups-filters includes cups-browsed, a daemon that autodiscovers"
+ elog "remote queues via avahi and adds them to your cups configuration. You may want"
+ elog "to add it to your default runlevel. Then again, you may not want to do that,"
+ elog "since it is completely untested, may kill kittens or get you r00ted. Your choice."
+ fi
+}
diff --git a/net-print/cups-filters/cups-filters-9999.ebuild b/net-print/cups-filters/cups-filters-9999.ebuild
index e71e6ffff5dc..8c1dd07ee9d4 100644
--- a/net-print/cups-filters/cups-filters-9999.ebuild
+++ b/net-print/cups-filters/cups-filters-9999.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/cups-filters/cups-filters-9999.ebuild,v 1.32 2012/11/06 13:59:34 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/cups-filters/cups-filters-9999.ebuild,v 1.33 2013/02/02 20:26:03 dilfridge Exp $
EAPI=4
GENTOO_DEPEND_ON_PERL=no
-inherit base perl-module
+inherit base perl-module autotools
if [[ "${PV}" == "9999" ]] ; then
inherit autotools bzr
@@ -14,14 +14,14 @@ if [[ "${PV}" == "9999" ]] ; then
KEYWORDS=""
else
SRC_URI="http://www.openprinting.org/download/${PN}/${P}.tar.xz"
- KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~x86 ~amd64-fbsd"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
fi
DESCRIPTION="Cups PDF filters"
HOMEPAGE="http://www.linuxfoundation.org/collaborate/workgroups/openprinting/pdfasstandardprintjobformat"
LICENSE="MIT GPL-2"
SLOT="0"
-IUSE="jpeg perl png static-libs tiff"
+IUSE="avahi jpeg perl png static-libs tiff"
RDEPEND="
app-text/ghostscript-gpl
@@ -34,6 +34,7 @@ RDEPEND="
!<=net-print/cups-1.5.9999
sys-devel/bc
sys-libs/zlib
+ avahi? ( net-dns/avahi )
jpeg? ( virtual/jpeg )
perl? ( dev-lang/perl )
png? ( media-libs/libpng )
@@ -41,16 +42,21 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/${PN}-1.0.29-openrc.patch" )
+
src_prepare() {
base_src_prepare
if [[ "${PV}" == "9999" ]]; then
eautoreconf
+ else
+ eautoreconf
fi
}
src_configure() {
econf \
--docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ $(use_enable avahi) \
$(use_enable static-libs static) \
--with-fontdir="fonts/conf.avail" \
--with-pdftops=pdftops \
@@ -83,4 +89,19 @@ src_install() {
fi
find "${ED}" -name '*.la' -exec rm -f {} +
+
+ if use avahi; then
+ newinitd "${FILESDIR}"/cups-browsed.init.d cups-browsed
+ fi;
+}
+
+pkg_postinst() {
+ perl-module_pkg_postinst
+
+ if use avahi; then
+ elog "This version of cups-filters includes cups-browsed, a daemon that autodiscovers"
+ elog "remote queues via avahi and adds them to your cups configuration. You may want"
+ elog "to add it to your default runlevel. Then again, you may not want to do that,"
+ elog "since it is completely untested, may kill kittens or get you r00ted. Your choice."
+ fi
}
diff --git a/net-print/cups-filters/files/cups-browsed.init.d b/net-print/cups-filters/files/cups-browsed.init.d
new file mode 100644
index 000000000000..6ebac07dee9b
--- /dev/null
+++ b/net-print/cups-filters/files/cups-browsed.init.d
@@ -0,0 +1,17 @@
+#!/sbin/runscript
+
+depend() {
+ need cups avahi-daemon
+}
+
+start() {
+ ebegin "Starting cups-browsed"
+ start-stop-daemon --start --quiet --exec /usr/sbin/cups-browsed
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping cups-browsed"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/cupsd
+ eend $?
+}
diff --git a/net-print/cups-filters/files/cups-filters-1.0.29-openrc.patch b/net-print/cups-filters/files/cups-filters-1.0.29-openrc.patch
new file mode 100644
index 000000000000..3c56c3b1e3b2
--- /dev/null
+++ b/net-print/cups-filters/files/cups-filters-1.0.29-openrc.patch
@@ -0,0 +1,41 @@
+diff -ruN cups-filters-1.0.29.orig/Makefile.am cups-filters-1.0.29/Makefile.am
+--- cups-filters-1.0.29.orig/Makefile.am 2013-01-02 19:12:39.000000000 +0100
++++ cups-filters-1.0.29/Makefile.am 2013-02-02 21:18:22.000000000 +0100
+@@ -602,7 +602,7 @@
+ # UTILS
+ # =====
+
+-EXTRA_DIST += utils/cups-browsed.in
++# EXTRA_DIST += utils/cups-browsed.in
+ sbin_PROGRAMS =
+ if ENABLE_AVAHI
+ sbin_PROGRAMS += \
+@@ -655,28 +655,9 @@
+ rm -rf *.cache *~
+
+ install-data-hook:
+-if ENABLE_AVAHI
+-if RCLINKS
+- for level in $(RCLEVELS); do \
+- $(INSTALL) -d -m 755 $(DESTDIR)$(INITDIR)/rc$${level}.d; \
+- $(LN_S) ../init.d/cups-browsed $(DESTDIR)$(INITDIR)/rc$${level}.d/S$(RCSTART)cups-browsed; \
+- $(LN_S) ../init.d/cups-browsed $(DESTDIR)$(INITDIR)/rc$${level}.d/K$(RCSTOP)cups-browsed; \
+- done; \
+- $(INSTALL) -d -m 755 $(DESTDIR)$(INITDIR)/rc0.d; \
+- $(LN_S) ../init.d/cups-browsed $(DESTDIR)$(INITDIR)/rc0.d/K$(RCSTOP)cups-browsed;
+-endif
+-endif
+ $(LN_S) pdf.utf-8.simple \
+ $(DESTDIR)$(pkgcharsetdir)/pdf.utf-8
+
+
+ uninstall-hook:
+-if ENABLE_AVAHI
+-if RCLINKS
+- if test "x$(INITDIR)" != x; then \
+- $(RM) $(DESTDIR)$(BUILDROOT)$(INITDIR)/rc?.d/[SK]??cups-browsed || :; \
+- rmdir $(DESTDIR)$(BUILDROOT)$(INITDIR)/rc?.d || :;\
+- fi
+-endif
+-endif
+ $(RM) $(DESTDIR)$(pkgcharsetdir)/pdf.utf-8