summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-07-25 22:14:53 +0000
committerMichał Górny <mgorny@gentoo.org>2013-07-25 22:14:53 +0000
commitcaee25fbb42ea873d77a341aa9c111951e4a837e (patch)
tree653b6ab8cb6c60a1fde249041d46da9bfa2a4f43 /net-print/cups/cups-1.6.9999.ebuild
parentIntroduce a live ebuild to make testing easier. (diff)
downloadgentoo-2-caee25fbb42ea873d77a341aa9c111951e4a837e.tar.gz
gentoo-2-caee25fbb42ea873d77a341aa9c111951e4a837e.tar.bz2
gentoo-2-caee25fbb42ea873d77a341aa9c111951e4a837e.zip
Migrate to python-single-r1, bug #478136.
(Portage version: 2.2.0_alpha188/cvs/Linux x86_64, signed Manifest commit with key 9627F456F9DA7643!)
Diffstat (limited to 'net-print/cups/cups-1.6.9999.ebuild')
-rw-r--r--net-print/cups/cups-1.6.9999.ebuild19
1 files changed, 9 insertions, 10 deletions
diff --git a/net-print/cups/cups-1.6.9999.ebuild b/net-print/cups/cups-1.6.9999.ebuild
index 521eafd02c4b..8e4312cc4bb3 100644
--- a/net-print/cups/cups-1.6.9999.ebuild
+++ b/net-print/cups/cups-1.6.9999.ebuild
@@ -1,12 +1,13 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/cups/cups-1.6.9999.ebuild,v 1.3 2013/07/12 20:02:55 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/cups/cups-1.6.9999.ebuild,v 1.4 2013/07/25 22:14:53 mgorny Exp $
EAPI=5
-PYTHON_DEPEND="python? 2:2.5"
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
-inherit autotools base fdo-mime gnome2-utils flag-o-matic linux-info multilib pam python user versionator java-pkg-opt-2 systemd
+inherit autotools base fdo-mime gnome2-utils flag-o-matic linux-info \
+ multilib pam python-single-r1 user versionator java-pkg-opt-2 systemd
MY_P=${P/_beta/b}
MY_PV=${PV/_beta/b}
@@ -49,6 +50,7 @@ RDEPEND="
kerberos? ( virtual/krb5 )
!lprng-compat? ( !net-print/lprng )
pam? ( virtual/pam )
+ python? ( ${PYTHON_DEPS} )
selinux? ( sec-policy/selinux-cups )
ssl? (
gnutls? (
@@ -74,7 +76,8 @@ PDEPEND="
filters? ( net-print/foomatic-filters )
"
-REQUIRED_USE="gnutls? ( ssl )"
+REQUIRED_USE="gnutls? ( ssl )
+ python? ( ${PYTHON_REQUIRED_USE} )"
# upstream includes an interactive test which is a nono for gentoo
RESTRICT="test"
@@ -95,11 +98,7 @@ pkg_setup() {
enewuser lp -1 -1 -1 lp
enewgroup lpadmin 106
- # python 3 is no-go
- if use python; then
- python_set_active_version 2
- python_pkg_setup
- fi
+ use python && python-single-r1_pkg_setup
if use kernel_linux; then
linux-info_pkg_setup
@@ -185,7 +184,7 @@ src_configure() {
$(use_with java) \
--without-perl \
--without-php \
- $(use_with python) \
+ $(use_with python python "${PYTHON}") \
$(use_with xinetd xinetd /etc/xinetd.d) \
--enable-libpaper \
--with-systemdsystemunitdir="$(systemd_get_unitdir)" \