summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-10-20 22:14:26 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-10-20 22:14:26 +0000
commit39f8810f924513b8a42f03f3c84d47f459c65abe (patch)
tree40f79ec54ada9f955b768da01b492709d6b83b77 /net-print/gtklp/gtklp-0.9k.ebuild
parentunmask new revision for x86 (diff)
downloadgentoo-2-39f8810f924513b8a42f03f3c84d47f459c65abe.tar.gz
gentoo-2-39f8810f924513b8a42f03f3c84d47f459c65abe.tar.bz2
gentoo-2-39f8810f924513b8a42f03f3c84d47f459c65abe.zip
emake->make
Diffstat (limited to 'net-print/gtklp/gtklp-0.9k.ebuild')
-rw-r--r--net-print/gtklp/gtklp-0.9k.ebuild37
1 files changed, 15 insertions, 22 deletions
diff --git a/net-print/gtklp/gtklp-0.9k.ebuild b/net-print/gtklp/gtklp-0.9k.ebuild
index eecf4190feae..b285b6082282 100644
--- a/net-print/gtklp/gtklp-0.9k.ebuild
+++ b/net-print/gtklp/gtklp-0.9k.ebuild
@@ -1,40 +1,33 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/gtklp/gtklp-0.9k.ebuild,v 1.4 2002/10/20 18:52:37 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/gtklp/gtklp-0.9k.ebuild,v 1.5 2002/10/20 22:14:26 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="A GUI for cupsd"
SRC_URI="http://www.stud.uni-hannover.de/~sirtobi/gtklp/files/${P}.src.tar.gz"
HOMEPAGE="http://www.stud.uni-hannover.de/~sirtobi/gtklp"
-KEYWORDS="x86 ppc"
+
SLOT="0"
+KEYWORDS="x86 ppc"
LICENSE="GPL-2"
-DEPEND="virtual/glibc
- =x11-libs/gtk+-1.2*
+DEPEND="=x11-libs/gtk+-1.2*
>=net-print/cups-1.1.7"
-src_unpack() {
- unpack ${P}.src.tar.gz
-}
-
src_compile() {
local myconf=""
- use nls && myconf="${myconf} --enable-nls"
- use nls || myconf="${myconf} --disable-nls"
- use ssl && myconf="${myconf} --enable-ssl"
- use ssl || myconf="${myconf} --disable-ssl"
-
- ./configure --host=${CHOST} \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man \
- ${myconf} \
- --prefix=/usr || die
- emake ||die
+ use nls \
+ && myconf="${myconf} --enable-nls" \
+ || myconf="${myconf} --disable-nls"
+ use ssl \
+ && myconf="${myconf} --enable-ssl" \
+ || myconf="${myconf} --disable-ssl"
+
+ econf ${myconf}
+ emake || make || die
}
src_install () {
- make DESTDIR=${D} install || die
- dodoc AUTHORS COPYING ChangeLog README NEWS TODO KNOWN_BUGS
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS COPYING ChangeLog README NEWS TODO KNOWN_BUGS
}
-