summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <msterret@gentoo.org>2003-09-07 00:18:12 +0000
committerMichael Sterrett <msterret@gentoo.org>2003-09-07 00:18:12 +0000
commite0a469bef839cd2d6a20678483b50e2e7f452a55 (patch)
treee003be58b7f60ff16c2013608da9b166512420ed /net-print/pnm2ppa
parentrepoman: fix leading whitespace (diff)
downloadgentoo-2-e0a469bef839cd2d6a20678483b50e2e7f452a55.tar.gz
gentoo-2-e0a469bef839cd2d6a20678483b50e2e7f452a55.tar.bz2
gentoo-2-e0a469bef839cd2d6a20678483b50e2e7f452a55.zip
repoman: trim trailing whitespace
Diffstat (limited to 'net-print/pnm2ppa')
-rw-r--r--net-print/pnm2ppa/Manifest6
-rw-r--r--net-print/pnm2ppa/pnm2ppa-1.0.91-r3.ebuild48
-rw-r--r--net-print/pnm2ppa/pnm2ppa-1.11.2.ebuild18
-rw-r--r--net-print/pnm2ppa/pnm2ppa-1.12.ebuild18
4 files changed, 45 insertions, 45 deletions
diff --git a/net-print/pnm2ppa/Manifest b/net-print/pnm2ppa/Manifest
index ecd36575cb39..92bfda2d3bb0 100644
--- a/net-print/pnm2ppa/Manifest
+++ b/net-print/pnm2ppa/Manifest
@@ -1,8 +1,8 @@
MD5 4bb3b59ae16c51c54ef86338a76c5721 ChangeLog 2661
+MD5 9953a7d3e513fe45610847b6e1a1ee2e pnm2ppa-1.0.91-r3.ebuild 5099
+MD5 877b53fdd097f687bbf9828d4e4e59db pnm2ppa-1.11.2.ebuild 2955
+MD5 aa0356a2323459c8ab516001e4767b0e pnm2ppa-1.12.ebuild 2925
MD5 26b4b081d538c195dc39bcb2ec8e6f3a metadata.xml 161
-MD5 aa7e51440168114bb182436c2e9c606f pnm2ppa-1.0.91-r3.ebuild 5152
-MD5 09a43032074c9cdfa9957ec32a3d38fe pnm2ppa-1.11.2.ebuild 2962
-MD5 8fab40cd6052e69dd613b48d9be59c70 pnm2ppa-1.12.ebuild 2932
MD5 1ca58b2f4948498a7edf92208be8f721 files/digest-pnm2ppa-1.0.91-r3 116
MD5 59bee745e2c3c4448a94e43af5b5cd58 files/digest-pnm2ppa-1.11.2 121
MD5 0a1deb7cd4d00d5222a2e71b4306dcde files/digest-pnm2ppa-1.12 117
diff --git a/net-print/pnm2ppa/pnm2ppa-1.0.91-r3.ebuild b/net-print/pnm2ppa/pnm2ppa-1.0.91-r3.ebuild
index 29b78b917f5a..11537f2ac499 100644
--- a/net-print/pnm2ppa/pnm2ppa-1.0.91-r3.ebuild
+++ b/net-print/pnm2ppa/pnm2ppa-1.0.91-r3.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/pnm2ppa/pnm2ppa-1.0.91-r3.ebuild,v 1.8 2003/02/13 15:26:31 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/pnm2ppa/pnm2ppa-1.0.91-r3.ebuild,v 1.9 2003/09/07 00:18:10 msterret Exp $
# Note: this also d/ls the hp-ppa-howto and installs it under /usr/share/doc/${P}
IUSE="ncurses gtk"
# pnm2ppa is a print filter for HP's line of Winprinters which use a proprietary
# protocol called ppa (Print Performance Architecture).
-# Like Winmodems, Winprinters don't have a microprocessor; your main CPU does
+# Like Winmodems, Winprinters don't have a microprocessor; your main CPU does
# all the hard work.
# Winprinters: Hp Deskjet 710, 712, 720, 722, 820, 1000 series.
# pnm2ppa can work on its own or via lpr or pdq.
@@ -33,13 +33,13 @@ LICENSE="GPL-2"
# executable.
DEPEND="gtk? ( x11-libs/gtk+ )
ncurses? ( sys-libs/ncurses )"
-
+
RDEPEND="${DEPEND}
app-text/enscript
dev-util/dialog"
src_unpack() {
-
+
cd ${WORKDIR}
unpack ${P}.tgz
cd ${S}
@@ -47,21 +47,21 @@ src_unpack() {
cd ${WORKDIR}
patch -p0 < ${FILESDIR}/${PF}-gentoo.diff
-
+
}
src_compile() {
-
+
export CFLAGS="-DNDEBUG ${CFLAGS}"
-
+
emake \
CFLAGS="${CFLAGS} -DLANG_EN" || die
-
-
+
+
cd ${S}/ppa_protocol
emake \
CFLAGS="${CFLAGS}" || die
-
+
cd ${S}/ppaSet-beta1
# This requires gtk, ncurses etc. on which we don't want to depend
# so we simply fail if they aren't installed
@@ -74,8 +74,8 @@ src_compile() {
BINDIR=/usr/bin \
PNM2PPA=/usr/bin/pnm2ppa \
CALIBRATE_PPA=/usr/bin/calibrate_ppa \
- CFLAGS="${CFLAGS}" gPpaSet
-
+ CFLAGS="${CFLAGS}" gPpaSet
+
use ncurses && \
make \
BASEDIR=/usr/share/pnm2ppa/ppaSet \
@@ -93,7 +93,7 @@ src_compile() {
}
src_install () {
-
+
dodir /usr/bin
dodir /etc
dodir /usr/share/man/man1
@@ -106,7 +106,7 @@ src_install () {
exeinto /usr/bin
doexe utils/Linux/detect_ppa utils/Linux/test_ppa
-
+
insinto /usr/share/pnm2ppa/lpd
doins ${S}/lpd/*
exeinto /usr/share/pnm2ppa/lpd
@@ -114,7 +114,7 @@ src_install () {
insinto /usr/share/pnm2ppa/pdq
doins ${S}/pdq/*
-
+
# Interfaces for configuration of integration with lpd
# These are not installed because we do not assume that
# lpd, ncurses, gtk, but the sources are provided. Thus,
@@ -131,7 +131,7 @@ src_install () {
doexe gs-pnm2ppa
exeinto /etc/pdq/interfaces
doexe dummy
-
+
cd ${S}/ppaSet-beta1
use gtk && \
yes "" | make \
@@ -155,13 +155,13 @@ src_install () {
PNM2PPA=${D}/usr/bin/pnm2ppa \
CALIBRATE_PPA=${D}/usr/bin/calibrate_ppa \
install
-
+
rm ${D}/etc/printcap.*
-
+
cd ${S}/docs/en
dodoc CALIBRATION*txt COLOR*txt PPA*txt RELEASE*
dodoc CREDITS INSTALL LICENSE README TODO
-
+
cd sgml
insinto /usr/share/doc/${P}
doins *.sgml
@@ -183,18 +183,18 @@ pkg_postinst() {
einfo "
Now, you *must* edit /etc/pnm2ppa.conf and choose (at least)
your printer model and papersize.
-
+
Run calibrate_ppa to calibrate color offsets.
-
+
Read the docs in /usr/share/pnm2ppa/ to configure the printer,
configure lpr substitutes, cups, pdq, networking etc.
-
+
Note that lpr and pdq drivers *have* been installed, but if your
config file management has /etc blocked (the default), they have
been installed under different filenames. Read the appropriate
Gentoo documentation for more info.
-
+
Note: lpr has been configured for default papersize letter
"
-
+
}
diff --git a/net-print/pnm2ppa/pnm2ppa-1.11.2.ebuild b/net-print/pnm2ppa/pnm2ppa-1.11.2.ebuild
index b20589e1f754..613ea5a1adc8 100644
--- a/net-print/pnm2ppa/pnm2ppa-1.11.2.ebuild
+++ b/net-print/pnm2ppa/pnm2ppa-1.11.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/net-print/pnm2ppa/pnm2ppa-1.11.2.ebuild,v 1.3 2003/07/13 20:39:09 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/pnm2ppa/pnm2ppa-1.11.2.ebuild,v 1.4 2003/09/07 00:18:10 msterret Exp $
# Note: this also d/ls the hp-ppa-howto and installs it under /usr/share/doc/${P}
@@ -21,7 +21,7 @@ LICENSE="GPL-2"
# executable.
DEPEND="gtk? ( x11-libs/gtk+ )
ncurses? ( sys-libs/ncurses )"
-
+
RDEPEND="${DEPEND}
app-text/enscript
dev-util/dialog"
@@ -36,7 +36,7 @@ src_unpack() {
src_compile() {
export CFLAGS="-DNDEBUG ${CFLAGS}"
-
+
emake CFLAGS="${CFLAGS} -DLANG_EN" || die
cd ${S}/ppa_protocol
@@ -56,7 +56,7 @@ src_install () {
exeinto /usr/bin
doexe utils/Linux/detect_ppa utils/Linux/test_ppa
-
+
insinto /usr/share/pnm2ppa/lpd
doins ${S}/lpd/*
exeinto /usr/share/pnm2ppa/lpd
@@ -64,7 +64,7 @@ src_install () {
insinto /usr/share/pnm2ppa/pdq
doins ${S}/pdq/*
-
+
# Interfaces for configuration of integration with lpd
# These are not installed because we do not assume that
# lpd, ncurses, gtk, but the sources are provided. Thus,
@@ -79,13 +79,13 @@ src_install () {
exeinto /etc/pdq/interfaces
doexe dummy
- # possibly not needed
+ # possibly not needed
#rm ${D}/etc/printcap.*
-
+
cd ${S}/docs/en
dodoc CALIBRATION*txt COLOR*txt PPA*txt RELEASE*
dodoc CREDITS INSTALL LICENSE README TODO
-
+
cd sgml
insinto /usr/share/doc/${P}
doins *.sgml
@@ -100,7 +100,7 @@ pkg_postinst() {
einfo "your printer model and papersize."
einfo ""
einfo "Run calibrate_ppa to calibrate color offsets."
- einfo ""
+ einfo ""
einfo "Read the docs in /usr/share/pnm2ppa/ to configure the printer,"
einfo "configure lpr substitutes, cups, pdq, networking etc."
einfo ""
diff --git a/net-print/pnm2ppa/pnm2ppa-1.12.ebuild b/net-print/pnm2ppa/pnm2ppa-1.12.ebuild
index 5c4794c0a5b5..b2601e1f6263 100644
--- a/net-print/pnm2ppa/pnm2ppa-1.12.ebuild
+++ b/net-print/pnm2ppa/pnm2ppa-1.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/net-print/pnm2ppa/pnm2ppa-1.12.ebuild,v 1.3 2003/07/13 20:39:09 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/pnm2ppa/pnm2ppa-1.12.ebuild,v 1.4 2003/09/07 00:18:10 msterret Exp $
# Note: this also d/ls the hp-ppa-howto and installs it under /usr/share/doc/${P}
@@ -19,7 +19,7 @@ LICENSE="GPL-2"
# executable.
DEPEND="gtk? ( x11-libs/gtk+ )
ncurses? ( sys-libs/ncurses )"
-
+
RDEPEND="${DEPEND}
app-text/enscript
dev-util/dialog"
@@ -34,7 +34,7 @@ src_unpack() {
src_compile() {
export CFLAGS="-DNDEBUG ${CFLAGS}"
-
+
emake CFLAGS="${CFLAGS} -DLANG_EN" || die
cd ${S}/ppa_protocol
@@ -54,7 +54,7 @@ src_install () {
exeinto /usr/bin
doexe utils/Linux/detect_ppa utils/Linux/test_ppa
-
+
insinto /usr/share/pnm2ppa/lpd
doins ${S}/lpd/*
exeinto /usr/share/pnm2ppa/lpd
@@ -62,7 +62,7 @@ src_install () {
insinto /usr/share/pnm2ppa/pdq
doins ${S}/pdq/*
-
+
# Interfaces for configuration of integration with lpd
# These are not installed because we do not assume that
# lpd, ncurses, gtk, but the sources are provided. Thus,
@@ -77,13 +77,13 @@ src_install () {
exeinto /etc/pdq/interfaces
doexe dummy
- # possibly not needed
+ # possibly not needed
#rm ${D}/etc/printcap.*
-
+
cd ${S}/docs/en
dodoc CALIBRATION*txt COLOR*txt PPA*txt RELEASE*
dodoc CREDITS INSTALL LICENSE README TODO
-
+
cd sgml
insinto /usr/share/doc/${P}
doins *.sgml
@@ -98,7 +98,7 @@ pkg_postinst() {
einfo "your printer model and papersize."
einfo ""
einfo "Run calibrate_ppa to calibrate color offsets."
- einfo ""
+ einfo ""
einfo "Read the docs in /usr/share/pnm2ppa/ to configure the printer,"
einfo "configure lpr substitutes, cups, pdq, networking etc."
einfo ""