summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-05-08 22:40:35 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-05-08 22:40:35 +0000
commit443e3eb1f4a945ab29132618185fe62b5a85c78e (patch)
tree7da847710ecc2e1b08eaab68ca32b24120f3a20c /net-print
parentrepoman: Trim trailing whitespace (diff)
downloadgentoo-2-443e3eb1f4a945ab29132618185fe62b5a85c78e.tar.gz
gentoo-2-443e3eb1f4a945ab29132618185fe62b5a85c78e.tar.bz2
gentoo-2-443e3eb1f4a945ab29132618185fe62b5a85c78e.zip
Remove pointless cups useflag - does not even configure w/o cups, Make cups-1.2 aware, no revbump because no installed files were changed
(Portage version: 2.1_pre10-r4)
Diffstat (limited to 'net-print')
-rw-r--r--net-print/foomatic-filters/ChangeLog7
-rw-r--r--net-print/foomatic-filters/foomatic-filters-3.0.2-r1.ebuild23
2 files changed, 22 insertions, 8 deletions
diff --git a/net-print/foomatic-filters/ChangeLog b/net-print/foomatic-filters/ChangeLog
index 3b72fe492a99..cb68a8968954 100644
--- a/net-print/foomatic-filters/ChangeLog
+++ b/net-print/foomatic-filters/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-print/foomatic-filters
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/foomatic-filters/ChangeLog,v 1.31 2006/05/05 05:25:58 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/foomatic-filters/ChangeLog,v 1.32 2006/05/08 22:40:35 genstef Exp $
+
+ 08 May 2006; Stefan Schweizer <genstef@gentoo.org>
+ foomatic-filters-3.0.2-r1.ebuild:
+ Remove pointless cups useflag - does not even configure w/o cups, Make
+ cups-1.2 aware, no revbump because no installed files were changed
*foomatic-filters-3.0.2-r1 (05 May 2006)
diff --git a/net-print/foomatic-filters/foomatic-filters-3.0.2-r1.ebuild b/net-print/foomatic-filters/foomatic-filters-3.0.2-r1.ebuild
index e53af04a2a52..464006d6e492 100644
--- a/net-print/foomatic-filters/foomatic-filters-3.0.2-r1.ebuild
+++ b/net-print/foomatic-filters/foomatic-filters-3.0.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/foomatic-filters/foomatic-filters-3.0.2-r1.ebuild,v 1.1 2006/05/05 05:25:58 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/foomatic-filters/foomatic-filters-3.0.2-r1.ebuild,v 1.2 2006/05/08 22:40:35 genstef Exp $
inherit eutils
@@ -11,10 +11,10 @@ SRC_URI="http://www.linuxprinting.org/download/foomatic/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 ~hppa ~ia64 ~mips ppc ppc64 sparc x86"
-IUSE="cups samba"
+IUSE="samba"
DEPEND="samba? ( net-fs/samba )
- cups? ( >=net-print/cups-1.1.19 )
+ >=net-print/cups-1.1.19
|| (
app-text/enscript
net-print/cups
@@ -32,12 +32,21 @@ src_unpack() {
autoconf || die "autoconf failed"
}
+src_compile() {
+ has_version =net-print/cups-1.2* && export CUPS=/usr/libexec/cups CUPS_FILTERS=/usr/libexec/cups/filter
+ econf || die "econf failed"
+ emake || die "emake failed"
+}
+
src_install() {
make DESTDIR="${D}" install || die "make install failed"
- if use cups; then
- dosym /usr/bin/foomatic-gswrapper /usr/$(get_libdir)/cups/filter/foomatic-gswrapper
- dosym /usr/bin/foomatic-rip /usr/$(get_libdir)/cups/filter/cupsomatic
- fi
dosym /usr/bin/foomatic-rip /usr/bin/lpdomatic
+
+ dosym /usr/bin/foomatic-gswrapper /usr/$(get_libdir)/cups/filter/foomatic-gswrapper
+ dosym /usr/bin/foomatic-rip /usr/$(get_libdir)/cups/filter/cupsomatic
+ if has_version =net-print/cups-1.2*; then
+ mv ${D}/usr/$(get_libdir)/cups/* ${D}/usr/libexec/cups
+ rm ${D}/usr/$(get_libdir)/cups/
+ fi
}