summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-05-08 11:27:54 +0000
committerPacho Ramos <pacho@gentoo.org>2011-05-08 11:27:54 +0000
commit9fec781ea2cd7b4dd88aa031bae18f46af06218b (patch)
treea1ce06678a5f622af48cb0cecc2ca898fa98df14 /net-print
parentFix unpacking with handbook useflag. (diff)
downloadgentoo-2-9fec781ea2cd7b4dd88aa031bae18f46af06218b.tar.gz
gentoo-2-9fec781ea2cd7b4dd88aa031bae18f46af06218b.tar.bz2
gentoo-2-9fec781ea2cd7b4dd88aa031bae18f46af06218b.zip
Revision bump to fix pkgconfig file as noted by Alexis Ballier in bug #235013.
(Portage version: 2.1.9.47/cvs/Linux x86_64)
Diffstat (limited to 'net-print')
-rw-r--r--net-print/libgnomecups/ChangeLog11
-rw-r--r--net-print/libgnomecups/files/libgnomecups-0.2.3-pkgconfig.patch10
-rw-r--r--net-print/libgnomecups/libgnomecups-0.2.3-r1.ebuild31
3 files changed, 50 insertions, 2 deletions
diff --git a/net-print/libgnomecups/ChangeLog b/net-print/libgnomecups/ChangeLog
index 03fbdc2a4141..20185f520a84 100644
--- a/net-print/libgnomecups/ChangeLog
+++ b/net-print/libgnomecups/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-print/libgnomecups
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/libgnomecups/ChangeLog,v 1.66 2010/10/08 23:03:50 eva Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/libgnomecups/ChangeLog,v 1.67 2011/05/08 11:27:54 pacho Exp $
+
+*libgnomecups-0.2.3-r1 (08 May 2011)
+
+ 08 May 2011; Pacho Ramos <pacho@gentoo.org> +libgnomecups-0.2.3-r1.ebuild,
+ +files/libgnomecups-0.2.3-pkgconfig.patch:
+ Revision bump to fix pkgconfig file as noted by Alexis Ballier in bug
+ #235013.
08 Oct 2010; Gilles Dartiguelongue <eva@gentoo.org>
-libgnomecups-0.2.2.ebuild:
diff --git a/net-print/libgnomecups/files/libgnomecups-0.2.3-pkgconfig.patch b/net-print/libgnomecups/files/libgnomecups-0.2.3-pkgconfig.patch
new file mode 100644
index 000000000000..8fe6502a6f38
--- /dev/null
+++ b/net-print/libgnomecups/files/libgnomecups-0.2.3-pkgconfig.patch
@@ -0,0 +1,10 @@
+--- libgnomecups-1.0.pc.in~ 2007-01-02 01:18:51.000000000 +0100
++++ libgnomecups-1.0.pc.in 2011-05-08 13:21:35.000000000 +0200
+@@ -7,5 +7,6 @@
+ Description: GNOME CUPS Library
+ Version: @VERSION@
+ Requires: glib-2.0 gobject-2.0
+-Libs: -L${libdir} -lgnomecups-1.0 @CUPS_LIBS@
++Libs: -L${libdir} -lgnomecups-1.0
++Libs.private: -L${libdir} -lgnomecups-1.0 @CUPS_LIBS@
+ Cflags: -I${includedir} @CUPS_CFLAGS@
diff --git a/net-print/libgnomecups/libgnomecups-0.2.3-r1.ebuild b/net-print/libgnomecups/libgnomecups-0.2.3-r1.ebuild
new file mode 100644
index 000000000000..0d137e9e718c
--- /dev/null
+++ b/net-print/libgnomecups/libgnomecups-0.2.3-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/libgnomecups/libgnomecups-0.2.3-r1.ebuild,v 1.1 2011/05/08 11:27:54 pacho Exp $
+
+EAPI="4"
+GCONF_DEBUG="yes"
+
+inherit eutils gnome2
+
+DESCRIPTION="GNOME cups library"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2:2
+ >=net-print/cups-1.3.8"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.28"
+
+DOCS="AUTHORS ChangeLog NEWS"
+
+src_prepare() {
+ epatch "${FILESDIR}"/enablenet.patch
+
+ # Fix .pc file per bug #235013
+ epatch "${FILESDIR}"/${P}-pkgconfig.patch
+}