summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2013-05-11 10:31:47 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2013-05-11 10:31:47 +0000
commitce5ab1ecda473de40bb134281fd973919744f79c (patch)
tree50e68cb5f3a24a92467396d7027cdc5b362c1883 /net-print
parentFix libdir location, per bug#468810, thanks to Anthony Basile (diff)
downloadgentoo-2-ce5ab1ecda473de40bb134281fd973919744f79c.tar.gz
gentoo-2-ce5ab1ecda473de40bb134281fd973919744f79c.tar.bz2
gentoo-2-ce5ab1ecda473de40bb134281fd973919744f79c.zip
Bugfixes in ebuild and init script and addition systemd unit file, all from systemd-love overlay thanks to lxnay
(Portage version: 2.2.0_alpha174/cvs/Linux x86_64, signed Manifest commit with key 84AD142F)
Diffstat (limited to 'net-print')
-rw-r--r--net-print/cups-filters/ChangeLog10
-rw-r--r--net-print/cups-filters/cups-filters-1.0.30-r1.ebuild107
-rw-r--r--net-print/cups-filters/cups-filters-9999-r1.ebuild8
-rw-r--r--net-print/cups-filters/files/cups-browsed.init.d7
-rw-r--r--net-print/cups-filters/files/cups-browsed.service10
5 files changed, 137 insertions, 5 deletions
diff --git a/net-print/cups-filters/ChangeLog b/net-print/cups-filters/ChangeLog
index b11a20527030..33a2a5dd5102 100644
--- a/net-print/cups-filters/ChangeLog
+++ b/net-print/cups-filters/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-print/cups-filters
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/cups-filters/ChangeLog,v 1.55 2013/04/25 09:47:38 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/cups-filters/ChangeLog,v 1.56 2013/05/11 10:31:47 dilfridge Exp $
+
+*cups-filters-1.0.30-r1 (11 May 2013)
+
+ 11 May 2013; Andreas K. Huettel <dilfridge@gentoo.org>
+ +cups-filters-1.0.30-r1.ebuild, cups-filters-9999-r1.ebuild,
+ +files/cups-browsed.service, files/cups-browsed.init.d:
+ Bugfixes in ebuild and init script and addition systemd unit file, all from
+ systemd-love overlay thanks to lxnay
25 Apr 2013; Patrick Lauer <patrick@gentoo.org> cups-filters-1.0.30.ebuild:
Apply automake fix #466412
diff --git a/net-print/cups-filters/cups-filters-1.0.30-r1.ebuild b/net-print/cups-filters/cups-filters-1.0.30-r1.ebuild
new file mode 100644
index 000000000000..8d60dce2f2c7
--- /dev/null
+++ b/net-print/cups-filters/cups-filters-1.0.30-r1.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/cups-filters/cups-filters-1.0.30-r1.ebuild,v 1.1 2013/05/11 10:31:47 dilfridge Exp $
+
+EAPI=5
+
+GENTOO_DEPEND_ON_PERL=no
+
+inherit base eutils perl-module autotools systemd
+
+if [[ "${PV}" == "9999" ]] ; then
+ inherit bzr
+ EBZR_REPO_URI="http://bzr.linuxfoundation.org/openprinting/cups-filters"
+ KEYWORDS=""
+else
+ SRC_URI="http://www.openprinting.org/download/${PN}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
+fi
+DESCRIPTION="Cups PDF filters"
+HOMEPAGE="http://www.linuxfoundation.org/collaborate/workgroups/openprinting/pdfasstandardprintjobformat"
+
+LICENSE="MIT GPL-2"
+SLOT="0"
+IUSE="jpeg perl png static-libs tiff zeroconf"
+
+RDEPEND="
+ app-text/ghostscript-gpl
+ app-text/poppler:=[cxx,jpeg?,lcms,tiff?,xpdf-headers(+)]
+ >=app-text/qpdf-3.0.2
+ media-libs/fontconfig
+ media-libs/freetype:2
+ media-libs/lcms:2
+ >net-print/cups-1.5.9999
+ !<=net-print/cups-1.5.9999
+ sys-devel/bc
+ sys-libs/zlib
+ jpeg? ( virtual/jpeg )
+ perl? ( dev-lang/perl )
+ png? ( media-libs/libpng:0= )
+ tiff? ( media-libs/tiff )
+ zeroconf? ( net-dns/avahi )
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.0.29-openrc.patch"
+ "${FILESDIR}/${PN}-1.0.30-noavahi.patch"
+)
+
+src_prepare() {
+ base_src_prepare
+ sed -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" -i configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ $(use_enable zeroconf avahi) \
+ $(use_enable static-libs static) \
+ --with-fontdir="fonts/conf.avail" \
+ --with-pdftops=pdftops \
+ --enable-imagefilters \
+ $(use_with jpeg) \
+ $(use_with png) \
+ $(use_with tiff) \
+ --with-rcdir=no \
+ --with-browseremoteprotocols=DNSSD,CUPS \
+ --without-php
+}
+
+src_compile() {
+ default
+
+ if use perl; then
+ pushd "${S}/scripting/perl" > /dev/null
+ perl-module_src_prep
+ perl-module_src_compile
+ popd > /dev/null
+ fi
+}
+
+src_install() {
+ default
+
+ if use perl; then
+ pushd "${S}/scripting/perl" > /dev/null
+ perl-module_src_install
+ fixlocalpod
+ popd > /dev/null
+ fi
+
+ prune_libtool_files --all
+
+ use zeroconf && newinitd "${FILESDIR}"/cups-browsed.init.d cups-browsed
+ use zeroconf && systemd_dounit "${FILESDIR}/cups-browsed.service"
+}
+
+pkg_postinst() {
+ perl-module_pkg_postinst
+
+ if use zeroconf; then
+ elog "This version of cups-filters includes cups-browsed, a daemon that autodiscovers"
+ elog "remote queues via avahi and adds them to your cups configuration. You may want"
+ elog "to add it to your default runlevel. Not much tested so far, though."
+ fi
+}
diff --git a/net-print/cups-filters/cups-filters-9999-r1.ebuild b/net-print/cups-filters/cups-filters-9999-r1.ebuild
index 7bdac14e5d86..1f9d5afff58b 100644
--- a/net-print/cups-filters/cups-filters-9999-r1.ebuild
+++ b/net-print/cups-filters/cups-filters-9999-r1.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/cups-filters/cups-filters-9999-r1.ebuild,v 1.4 2013/04/06 10:20:47 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/cups-filters/cups-filters-9999-r1.ebuild,v 1.5 2013/05/11 10:31:47 dilfridge Exp $
EAPI=5
GENTOO_DEPEND_ON_PERL=no
-inherit base eutils perl-module autotools
+inherit base eutils perl-module autotools systemd
if [[ "${PV}" == "9999" ]] ; then
inherit bzr
@@ -49,6 +49,7 @@ PATCHES=(
src_prepare() {
base_src_prepare
+ sed -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" -i configure.ac || die
eautoreconf
}
@@ -63,6 +64,8 @@ src_configure() {
$(use_with jpeg) \
$(use_with png) \
$(use_with tiff) \
+ --with-rcdir=no \
+ --with-browseremoteprotocols=DNSSD,CUPS \
--without-php
}
@@ -90,6 +93,7 @@ src_install() {
prune_libtool_files --all
use zeroconf && newinitd "${FILESDIR}"/cups-browsed.init.d cups-browsed
+ use zeroconf && systemd_dounit "${FILESDIR}/cups-browsed.service"
}
pkg_postinst() {
diff --git a/net-print/cups-filters/files/cups-browsed.init.d b/net-print/cups-filters/files/cups-browsed.init.d
index 57fffbce0417..785c13a25d8a 100644
--- a/net-print/cups-filters/files/cups-browsed.init.d
+++ b/net-print/cups-filters/files/cups-browsed.init.d
@@ -1,17 +1,20 @@
#!/sbin/runscript
+PIDFILE=/var/run/cups-browsed.pid
+
depend() {
need cupsd avahi-daemon
}
start() {
ebegin "Starting cups-browsed"
- start-stop-daemon --start --quiet --exec /usr/sbin/cups-browsed
+ start-stop-daemon --start --make-pidfile --pidfile "${PIDFILE}" \
+ --background --quiet --exec /usr/sbin/cups-browsed
eend $?
}
stop() {
ebegin "Stopping cups-browsed"
- start-stop-daemon --stop --quiet --exec /usr/sbin/cupsd
+ start-stop-daemon --stop --pidfile "${PIDFILE}" --quiet --exec /usr/sbin/cupsd
eend $?
}
diff --git a/net-print/cups-filters/files/cups-browsed.service b/net-print/cups-filters/files/cups-browsed.service
new file mode 100644
index 000000000000..144956c7fd2f
--- /dev/null
+++ b/net-print/cups-filters/files/cups-browsed.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=Make remote CUPS printers available locally
+After=cups.service avahi-daemon.service
+Wants=cups.service avahi-daemon.service
+
+[Service]
+ExecStart=/usr/sbin/cups-browsed
+
+[Install]
+WantedBy=multi-user.target