summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-06-29 09:43:48 +0000
committerMichał Górny <mgorny@gentoo.org>2014-06-29 09:43:48 +0000
commitdf168f279f2258aeebbfc06c5fcf4bf3412d83a1 (patch)
treeafbb0406d87bae4e4aebaff0196da96349cadf5d /net-print
parentThe latest passmenu now uses xdotool. (diff)
downloadgentoo-2-df168f279f2258aeebbfc06c5fcf4bf3412d83a1.tar.gz
gentoo-2-df168f279f2258aeebbfc06c5fcf4bf3412d83a1.tar.bz2
gentoo-2-df168f279f2258aeebbfc06c5fcf4bf3412d83a1.zip
Enable multilib support, required for gnome-base/libgnomeprint.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'net-print')
-rw-r--r--net-print/libgnomecups/ChangeLog8
-rw-r--r--net-print/libgnomecups/files/libgnomecups-0.2.3-cups-config.patch34
-rw-r--r--net-print/libgnomecups/libgnomecups-0.2.3-r4.ebuild59
3 files changed, 100 insertions, 1 deletions
diff --git a/net-print/libgnomecups/ChangeLog b/net-print/libgnomecups/ChangeLog
index e87d3bc19073..c67b5a05531c 100644
--- a/net-print/libgnomecups/ChangeLog
+++ b/net-print/libgnomecups/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-print/libgnomecups
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/libgnomecups/ChangeLog,v 1.98 2014/01/01 21:12:36 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/libgnomecups/ChangeLog,v 1.99 2014/06/29 09:43:48 mgorny Exp $
+
+*libgnomecups-0.2.3-r4 (29 Jun 2014)
+
+ 29 Jun 2014; Michał Górny <mgorny@gentoo.org>
+ +files/libgnomecups-0.2.3-cups-config.patch, +libgnomecups-0.2.3-r4.ebuild:
+ Enable multilib support, required for gnome-base/libgnomeprint.
01 Jan 2014; Pacho Ramos <pacho@gentoo.org> libgnomecups-0.2.3-r3.ebuild:
Add missing dependency on gnome-common, bug #496648 by Jan Hrabe
diff --git a/net-print/libgnomecups/files/libgnomecups-0.2.3-cups-config.patch b/net-print/libgnomecups/files/libgnomecups-0.2.3-cups-config.patch
new file mode 100644
index 000000000000..10eb75d1bc46
--- /dev/null
+++ b/net-print/libgnomecups/files/libgnomecups-0.2.3-cups-config.patch
@@ -0,0 +1,34 @@
+From 8f5e326dd89d98b2d34cf6f97583be4eb819b02b Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Sun, 29 Jun 2014 10:36:14 +0200
+Subject: [PATCH] Use AC_PATH_TOOL to find cups-config. And actually use the
+ result.
+
+---
+ configure.in | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/configure.in b/configure.in
+index 3f0ccc5..0bd367e 100644
+--- a/configure.in
++++ b/configure.in
+@@ -22,13 +22,13 @@ AC_SUBST(GLIB_REQUIRED)
+
+ PKG_CHECK_MODULES(LIBGNOMECUPS, glib-2.0 >= $GLIB_REQUIRED gobject-2.0 >= $GLIB_REQUIRED gthread-2.0 >= $GLIB_REQUIRED)
+
+-AC_PATH_PROG(CUPS_CONFIG, cups-config, no)
++AC_PATH_TOOL(CUPS_CONFIG, cups-config, no)
+ if test "$CUPS_CONFIG" = "no"; then
+ AC_MSG_ERROR([Please install cups development packages])
+ fi
+
+-CUPS_CFLAGS=`cups-config --cflags | sed 's/-O[0-9]*//' | sed 's/-m[^\t]*//g'`
+-CUPS_LIBS=`cups-config --libs`
++CUPS_CFLAGS=`$CUPS_CONFIG --cflags | sed 's/-O[0-9]*//' | sed 's/-m[^\t]*//g'`
++CUPS_LIBS=`$CUPS_CONFIG --libs`
+
+ AC_SUBST(CUPS_CFLAGS)
+ AC_SUBST(CUPS_LIBS)
+--
+2.0.0
+
diff --git a/net-print/libgnomecups/libgnomecups-0.2.3-r4.ebuild b/net-print/libgnomecups/libgnomecups-0.2.3-r4.ebuild
new file mode 100644
index 000000000000..3b151aa48fb1
--- /dev/null
+++ b/net-print/libgnomecups/libgnomecups-0.2.3-r4.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/libgnomecups/libgnomecups-0.2.3-r4.ebuild,v 1.1 2014/06/29 09:43:48 mgorny Exp $
+
+EAPI=5
+GCONF_DEBUG="yes"
+GNOME_TARBALL_SUFFIX="bz2"
+
+inherit autotools eutils gnome2 multilib-minimal
+
+DESCRIPTION="GNOME cups library"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
+ >=net-print/cups-1.7.1-r1[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.28
+ gnome-base/gnome-common
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/enablenet.patch
+
+ # Fix .pc file per bug #235013
+ epatch "${FILESDIR}"/${P}-pkgconfig.patch
+
+ # Upstream fix for g_list_find_custom() argument order
+ epatch "${FILESDIR}/${P}-g_list_find_custom.patch"
+
+ # >=glib-2.31 compat, bug #400789, https://bugzilla.gnome.org/show_bug.cgi?id=664930
+ epatch "${FILESDIR}/${P}-glib.h.patch"
+
+ # cups-1.6 compat, bug #428812
+ epatch "${FILESDIR}/${P}-cups-1.6.patch"
+
+ # so it looks for cups-config... how about using $CUPS_CONFIG then?
+ # and also use AC_PATH_TOOL to respect $CHOST
+ epatch "${FILESDIR}/${P}-cups-config.patch"
+
+ eautoreconf # To fix intltool files making LINGUAS to be honored
+ gnome2_src_prepare
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ gnome2_src_configure --disable-static
+}
+
+multilib_src_install() {
+ gnome2_src_install
+}