summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-01-30 05:56:25 +0000
committerTim Harder <radhermit@gentoo.org>2014-01-30 05:56:25 +0000
commit9f17548d83303357dc4baa3281c3dabf30e1ceab (patch)
tree01d107c99f007ecff8ed98301f9ebc0035c65807 /net-proxy/mitmproxy/mitmproxy-0.9.2.ebuild
parentVersion bump. (diff)
downloadgentoo-2-9f17548d83303357dc4baa3281c3dabf30e1ceab.tar.gz
gentoo-2-9f17548d83303357dc4baa3281c3dabf30e1ceab.tar.bz2
gentoo-2-9f17548d83303357dc4baa3281c3dabf30e1ceab.zip
Version bump (bug #483328).
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'net-proxy/mitmproxy/mitmproxy-0.9.2.ebuild')
-rw-r--r--net-proxy/mitmproxy/mitmproxy-0.9.2.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/net-proxy/mitmproxy/mitmproxy-0.9.2.ebuild b/net-proxy/mitmproxy/mitmproxy-0.9.2.ebuild
new file mode 100644
index 000000000000..5323c2140715
--- /dev/null
+++ b/net-proxy/mitmproxy/mitmproxy-0.9.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/mitmproxy/mitmproxy-0.9.2.ebuild,v 1.1 2014/01/30 05:56:25 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="An interactive, SSL-capable, man-in-the-middle HTTP proxy"
+HOMEPAGE="http://mitmproxy.org/"
+SRC_URI="http://mitmproxy.org/download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+RDEPEND="virtual/python-imaging[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ >=dev-python/lxml-2.3[${PYTHON_USEDEP}]
+ >=dev-python/netlib-${PV}[${PYTHON_USEDEP}]
+ >dev-python/pyasn1-0.1.2[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.12[${PYTHON_USEDEP}]
+ >=dev-python/urwid-1.1[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ www-servers/pathod[${PYTHON_USEDEP}]
+ )"
+
+RESTRICT="test"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.9.1-pil-import.patch )
+
+python_test() {
+ nosetests -v || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ local DOCS=( CHANGELOG CONTRIBUTORS )
+ use doc && local HTML_DOCS=( doc/. )
+ use examples && local EXAMPLES=( examples/. )
+
+ distutils-r1_python_install_all
+}