summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-08-20 17:54:21 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-08-20 17:54:21 +0000
commitf05ecbc0d619e3a99a118d298d44906802e7fe7b (patch)
treea1a797dd275be2ce1ee356c4941da086bb3c6905 /net-proxy/squidclamav
parentAdd blocker to autoresolve man page collision #341953. (diff)
downloadgentoo-2-f05ecbc0d619e3a99a118d298d44906802e7fe7b.tar.gz
gentoo-2-f05ecbc0d619e3a99a118d298d44906802e7fe7b.tar.bz2
gentoo-2-f05ecbc0d619e3a99a118d298d44906802e7fe7b.zip
Version bump.
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'net-proxy/squidclamav')
-rw-r--r--net-proxy/squidclamav/ChangeLog8
-rw-r--r--net-proxy/squidclamav/squidclamav-6.4.ebuild63
2 files changed, 70 insertions, 1 deletions
diff --git a/net-proxy/squidclamav/ChangeLog b/net-proxy/squidclamav/ChangeLog
index e67240cd8b01..4dd023d9aba2 100644
--- a/net-proxy/squidclamav/ChangeLog
+++ b/net-proxy/squidclamav/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-proxy/squidclamav
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/squidclamav/ChangeLog,v 1.15 2011/07/24 09:22:04 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/squidclamav/ChangeLog,v 1.16 2011/08/20 17:54:21 flameeyes Exp $
+
+*squidclamav-6.4 (20 Aug 2011)
+
+ 20 Aug 2011; Diego E. Pettenò <flameeyes@gentoo.org>
+ +squidclamav-6.4.ebuild:
+ Version bump.
24 Jul 2011; Markos Chandras <hwoarang@gentoo.org> squidclamav-6.1.ebuild:
Stable on amd64 wrt bug #374283
diff --git a/net-proxy/squidclamav/squidclamav-6.4.ebuild b/net-proxy/squidclamav/squidclamav-6.4.ebuild
new file mode 100644
index 000000000000..03b563f91a8c
--- /dev/null
+++ b/net-proxy/squidclamav/squidclamav-6.4.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/squidclamav/squidclamav-6.4.ebuild,v 1.1 2011/08/20 17:54:21 flameeyes Exp $
+
+EAPI=4
+
+inherit libtool autotools
+
+DESCRIPTION="HTTP Antivirus for Squid based on ClamAv and ICAP"
+HOMEPAGE="http://squidclamav.darold.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="net-proxy/c-icap"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ # version 6.3 causes maintainer-mode rebuild from tarball, and
+ # contains acinclude.m4 with libtool macros which cause trouble.
+ rm acinclude.m4 || die
+ eautoreconf
+ elibtoolize
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ find "${D}" -name '*.la' -delete || die
+
+ # delete its own documentation installed
+ rm -r "${D}"/usr/share/${PN} || die
+
+ dodoc README AUTHORS ChangeLog
+
+ # Fix configuration file to adapt to the Gentoo configuration
+ sed -i \
+ -e '/clamd_local/s:\.ctl:.sock:' \
+ "${D}"/etc/squidclamav.conf || die
+}
+
+pkg_postinst() {
+ elog "Starting from version 6, Squid Clamav is now a module for the c-icap"
+ elog "server, which is called from squid, rather than being a redirector"
+ elog "directly."
+ elog ""
+ elog "To enable the service, you should add this to your c-icap.conf file:"
+ elog ""
+ elog " Service clamav squidclamav.so"
+ elog ""
+ elog "And then this to squid.conf (for a local ICAP server):"
+ elog ""
+ elog " icap_enable on"
+ elog ""
+ elog " # not strictly needed, but useful for special access"
+ elog " icap_send_client_ip on"
+ elog " icap_send_client_username on"
+ elog ""
+ elog " icap_service clamav respmod_precache bypass=0 icap://localhost:1344/clamav"
+ elog " adaptation_access clamav allow all"
+}