summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2013-04-02 20:30:33 +0000
committerChristian Ruppert <idl0r@gentoo.org>2013-04-02 20:30:33 +0000
commitc637af2671f3fc3d6fc366d8f6d4e564aeccf3e6 (patch)
tree3fabc1bb849363f7af92744a755eb5aab7e110c1 /net-proxy
parentFix introspection issue, add python bindings support, bug #373809. Thanks to ... (diff)
downloadgentoo-2-c637af2671f3fc3d6fc366d8f6d4e564aeccf3e6.tar.gz
gentoo-2-c637af2671f3fc3d6fc366d8f6d4e564aeccf3e6.tar.bz2
gentoo-2-c637af2671f3fc3d6fc366d8f6d4e564aeccf3e6.zip
Cleanup
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key B427ABC8)
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/haproxy/ChangeLog8
-rw-r--r--net-proxy/haproxy/files/haproxy.initd-r151
-rw-r--r--net-proxy/haproxy/haproxy-1.4.21.ebuild76
-rw-r--r--net-proxy/haproxy/haproxy-1.5_beta15.ebuild107
4 files changed, 6 insertions, 236 deletions
diff --git a/net-proxy/haproxy/ChangeLog b/net-proxy/haproxy/ChangeLog
index 32683ddf2118..3aa77c51fe1c 100644
--- a/net-proxy/haproxy/ChangeLog
+++ b/net-proxy/haproxy/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-proxy/haproxy
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/ChangeLog,v 1.74 2012/12/29 03:03:45 idl0r Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/ChangeLog,v 1.75 2013/04/02 20:30:32 idl0r Exp $
+
+ 02 Apr 2013; Christian Ruppert <idl0r@gentoo.org> -haproxy-1.4.21.ebuild,
+ -haproxy-1.5_beta15.ebuild, -files/haproxy.initd-r1:
+ Cleanup
29 Dec 2012; Christian Ruppert <idl0r@gentoo.org> haproxy-1.4.21.ebuild,
haproxy-1.4.22.ebuild, haproxy-1.5_beta15.ebuild, haproxy-1.5_beta17.ebuild:
diff --git a/net-proxy/haproxy/files/haproxy.initd-r1 b/net-proxy/haproxy/files/haproxy.initd-r1
deleted file mode 100644
index 7c2b76ffa8f2..000000000000
--- a/net-proxy/haproxy/files/haproxy.initd-r1
+++ /dev/null
@@ -1,51 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/files/haproxy.initd-r1,v 1.2 2011/12/04 10:32:32 swegener Exp $
-
-extra_commands="checkconfig"
-extra_started_commands="reload"
-
-CONFFILE=/etc/${SVCNAME}.cfg
-PIDFILE=/var/run/${SVCNAME}.pid
-
-depend() {
- need net
- use dns logger
-}
-
-checkconfig() {
- if [ ! -f "${CONFFILE}" ]; then
- eerror "${CONFFILE} does not exist!"
- return 1
- fi
-
- ebegin "Checking ${CONFFILE}"
- /usr/bin/haproxy -q -c -f "${CONFFILE}"
- eend $?
-}
-
-start() {
- ebegin "Starting ${SVCNAME}"
- start-stop-daemon --pidfile "${PIDFILE}" --exec /usr/bin/haproxy \
- --start -- -D -p "${PIDFILE}" -f "${CONFFILE}"
- eend $?
-}
-
-stop() {
- ebegin "Stopping ${SVCNAME}"
-
- if [ "${RC_CMD}" = "restart" ]; then
- checkconfig || return 1
- fi
-
- start-stop-daemon --stop --pidfile "${PIDFILE}"
- eend $?
-}
-
-reload() {
- ebegin "Reloading ${SVCNAME}"
- checkconfig || { eerror "Reloading failed, please fix your ${CONFFILE} first"; return 1; }
- /usr/bin/haproxy -D -p "${PIDFILE}" -f "${CONFFILE}" -sf $(cat "${PIDFILE}")
- eend $?
-}
diff --git a/net-proxy/haproxy/haproxy-1.4.21.ebuild b/net-proxy/haproxy/haproxy-1.4.21.ebuild
deleted file mode 100644
index 9388ae8059a7..000000000000
--- a/net-proxy/haproxy/haproxy-1.4.21.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/haproxy-1.4.21.ebuild,v 1.5 2012/12/29 03:03:45 idl0r Exp $
-
-EAPI="4"
-
-inherit user versionator toolchain-funcs flag-o-matic
-
-DESCRIPTION="A TCP/HTTP reverse proxy for high availability environments"
-HOMEPAGE="http://haproxy.1wt.eu"
-SRC_URI="http://haproxy.1wt.eu/download/$(get_version_component_range 1-2)/src/${P}.tar.gz"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE="examples pcre vim-syntax"
-
-DEPEND="pcre? ( dev-libs/libpcre )"
-RDEPEND="${DEPEND}"
-
-pkg_setup() {
- enewgroup haproxy
- enewuser haproxy -1 -1 -1 haproxy
-}
-
-src_compile() {
- local args="TARGET=linux26"
-
- use pcre && args="${args} USE_PCRE=1"
-
- use kernel_linux && args="${args} USE_LINUX_SPLICE=1"
- use kernel_linux && args="${args} USE_LINUX_TPROXY=1"
-
- # For now, until the strict-aliasing breakage will be fixed
- append-cflags -fno-strict-aliasing
-
- emake CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" CC=$(tc-getCC) ${args} || die
-}
-
-src_install() {
- dobin haproxy || die
-
- newinitd "${FILESDIR}/haproxy.initd-r1" haproxy || die
-
- # Don't install useless files
- rm examples/build.cfg doc/*gpl.txt
-
- dodoc CHANGELOG ROADMAP TODO doc/{configuration,haproxy-en}.txt
- doman doc/haproxy.1
-
- if use examples;
- then
- docinto examples
- dodoc examples/*.cfg || die
- fi
-
- if use vim-syntax;
- then
- insinto /usr/share/vim/vimfiles/syntax
- doins examples/haproxy.vim || die
- fi
-}
-
-pkg_postinst() {
- if [[ ! -f "${ROOT}/etc/haproxy.cfg" ]] ; then
- ewarn "You need to create /etc/haproxy.cfg before you start the haproxy service."
- ewarn "It's best practice to not run haproxy as root, user and group haproxy was therefore created."
- ewarn "Make use of them with the \"user\" and \"group\" directives."
-
- if [[ -d "${ROOT}/usr/share/doc/${PF}" ]]; then
- einfo "Please consult the installed documentation for learning the configuration file's syntax."
- einfo "The documentation and sample configuration files are installed here:"
- einfo " ${ROOT}usr/share/doc/${PF}"
- fi
- fi
-}
diff --git a/net-proxy/haproxy/haproxy-1.5_beta15.ebuild b/net-proxy/haproxy/haproxy-1.5_beta15.ebuild
deleted file mode 100644
index 20fe9443f2c0..000000000000
--- a/net-proxy/haproxy/haproxy-1.5_beta15.ebuild
+++ /dev/null
@@ -1,107 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/haproxy-1.5_beta15.ebuild,v 1.2 2012/12/29 03:03:45 idl0r Exp $
-
-EAPI="4"
-
-inherit user versionator toolchain-funcs flag-o-matic
-
-MY_P="${PN}-${PV/_beta/-dev}"
-
-DESCRIPTION="A TCP/HTTP reverse proxy for high availability environments"
-HOMEPAGE="http://haproxy.1wt.eu"
-SRC_URI="http://haproxy.1wt.eu/download/$(get_version_component_range 1-2)/src/devel/${MY_P}.tar.gz"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="+crypt examples +pcre ssl vim-syntax +zlib"
-
-DEPEND="pcre? ( dev-libs/libpcre )
- ssl? ( dev-libs/openssl[zlib?] )
- zlib? ( sys-libs/zlib )"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-pkg_setup() {
- enewgroup haproxy
- enewuser haproxy -1 -1 -1 haproxy
-}
-
-src_compile() {
- local args="TARGET=linux2628 USE_GETADDRINFO=1"
-
- if use pcre; then
- args="${args} USE_PCRE=1"
- else
- args="${args} USE_PCRE="
- fi
-
-# if use kernel_linux; then
-# args="${args} USE_LINUX_SPLICE=1 USE_LINUX_TPROXY=1"
-# else
-# args="${args} USE_LINUX_SPLICE= USE_LINUX_TPROXY="
-# fi
-
- if use crypt; then
- args="${args} USE_LIBCRYPT=1"
- else
- args="${args} USE_LIBCRYPT="
- fi
-
- if use ssl; then
- args="${args} USE_OPENSSL=1"
- else
- args="${args} USE_OPENSSL="
- fi
-
- if use zlib; then
- args="${args} USE_ZLIB=1"
- else
- args="${args} USE_ZLIB="
- fi
-
- # For now, until the strict-aliasing breakage will be fixed
-# append-cflags -fno-strict-aliasing
-
- emake CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" CC=$(tc-getCC) ${args} || die
-}
-
-src_install() {
- dobin haproxy || die
-
- newinitd "${FILESDIR}/haproxy.initd-r2" haproxy || die
-
- # Don't install useless files
-# rm examples/build.cfg doc/*gpl.txt
-
- dodoc CHANGELOG ROADMAP TODO doc/{configuration,haproxy-en}.txt
- doman doc/haproxy.1
-
- if use examples;
- then
- docinto examples
- dodoc examples/*.cfg || die
- fi
-
- if use vim-syntax;
- then
- insinto /usr/share/vim/vimfiles/syntax
- doins examples/haproxy.vim || die
- fi
-}
-
-pkg_postinst() {
- if [[ ! -f "${ROOT}/etc/haproxy.cfg" ]] ; then
- ewarn "You need to create /etc/haproxy.cfg before you start the haproxy service."
- ewarn "It's best practice to not run haproxy as root, user and group haproxy was therefore created."
- ewarn "Make use of them with the \"user\" and \"group\" directives."
-
- if [[ -d "${ROOT}/usr/share/doc/${PF}" ]]; then
- einfo "Please consult the installed documentation for learning the configuration file's syntax."
- einfo "The documentation and sample configuration files are installed here:"
- einfo " ${ROOT}usr/share/doc/${PF}"
- fi
- fi
-}