summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2007-03-10 13:34:21 +0000
committerAlin Năstac <mrness@gentoo.org>2007-03-10 13:34:21 +0000
commitd482c9174b2bf2734809d8e9f009c06be94d1a58 (patch)
treec68f9c99cd4bb407088dd3d9492f531aeabd32fd /net-proxy
parentfix arguments to llseek() syscall, not libc call #170203 (diff)
downloadgentoo-2-d482c9174b2bf2734809d8e9f009c06be94d1a58.tar.gz
gentoo-2-d482c9174b2bf2734809d8e9f009c06be94d1a58.tar.bz2
gentoo-2-d482c9174b2bf2734809d8e9f009c06be94d1a58.zip
Remove $ROOT from src_compile (#168039). Version bump with cleaner ebuild code.
(Portage version: 2.1.2.2)
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/wwwoffle/ChangeLog10
-rw-r--r--net-proxy/wwwoffle/files/digest-wwwoffle-2.9b3
-rw-r--r--net-proxy/wwwoffle/wwwoffle-2.9-r1.ebuild54
-rw-r--r--net-proxy/wwwoffle/wwwoffle-2.9a.ebuild54
-rw-r--r--net-proxy/wwwoffle/wwwoffle-2.9b.ebuild127
5 files changed, 174 insertions, 74 deletions
diff --git a/net-proxy/wwwoffle/ChangeLog b/net-proxy/wwwoffle/ChangeLog
index 576472478957..9bc1b0b13dc2 100644
--- a/net-proxy/wwwoffle/ChangeLog
+++ b/net-proxy/wwwoffle/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-proxy/wwwoffle
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/wwwoffle/ChangeLog,v 1.24 2006/12/03 20:02:29 corsair Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/wwwoffle/ChangeLog,v 1.25 2007/03/10 13:34:21 mrness Exp $
+
+*wwwoffle-2.9b (10 Mar 2007)
+
+ 10 Mar 2007; Alin Năstac <mrness@gentoo.org> wwwoffle-2.9-r1.ebuild,
+ wwwoffle-2.9a.ebuild, +wwwoffle-2.9b.ebuild:
+ Remove $ROOT from src_compile (#168039). Version bump with cleaner ebuild code.
03 Dec 2006; Markus Rothe <corsair@gentoo.org> wwwoffle-2.9a.ebuild:
Stable on ppc64
diff --git a/net-proxy/wwwoffle/files/digest-wwwoffle-2.9b b/net-proxy/wwwoffle/files/digest-wwwoffle-2.9b
new file mode 100644
index 000000000000..9b38d9dc1cc6
--- /dev/null
+++ b/net-proxy/wwwoffle/files/digest-wwwoffle-2.9b
@@ -0,0 +1,3 @@
+MD5 492fd8e7f77cfc6103a1bd23093a1e0a wwwoffle-2.9b.tgz 1076009
+RMD160 0993246866fe9bafc505c4b10fb1c0f0ce95e5ad wwwoffle-2.9b.tgz 1076009
+SHA256 85d5650a1446c5f8d0f511345e12caa33693fffd556bee122f66531325d5fbf0 wwwoffle-2.9b.tgz 1076009
diff --git a/net-proxy/wwwoffle/wwwoffle-2.9-r1.ebuild b/net-proxy/wwwoffle/wwwoffle-2.9-r1.ebuild
index 107a10aa09a1..6685cf77192d 100644
--- a/net-proxy/wwwoffle/wwwoffle-2.9-r1.ebuild
+++ b/net-proxy/wwwoffle/wwwoffle-2.9-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/wwwoffle/wwwoffle-2.9-r1.ebuild,v 1.6 2006/08/31 17:43:55 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/wwwoffle/wwwoffle-2.9-r1.ebuild,v 1.7 2007/03/10 13:34:21 mrness Exp $
inherit eutils
@@ -37,29 +37,9 @@ src_unpack() {
}
src_compile() {
- # TODO confdir back to default /etc/wwwoffle
- # allows to change config file using web interface.
-
econf $(use_with zlib) $(use_with gnutls) \
$(use_with ipv6) || die "econf failed"
emake || die "emake failed"
-
- if [ -f "${ROOT}/etc/wwwoffle.conf" ] ; then
- einfo "Upgrading current configuration file"
- cp "${ROOT}/etc/wwwoffle.conf" conf/wwwoffle.conf
- conf/upgrade-config.pl conf/wwwoffle.conf
-
- # Hack to stop regeneration of config file
- touch conf/conf-file
-
- einfo "Changing the default user (and group) to wwwoffle"
- sed -i -e 's/\(run-[gu]id\)[ \t]*=[ \t]*[a-zA-Z0-9]*[ \t]*$/\1 = wwwoffle/g' \
- conf/wwwoffle.conf
- else
- einfo "Changing the default user (and group) to wwwoffle"
- sed -i -e 's/#\(run-[gu]id\)[ \t]*=[ \t]*[a-zA-Z0-9]*[ \t]*$/\1 = wwwoffle/g' \
- conf/wwwoffle.conf.template
- fi
}
src_install() {
@@ -71,11 +51,6 @@ src_install() {
dodir /usr/share/doc
mv "${D}/usr/doc/wwwoffle" "${D}/usr/share/doc/${PF}"
- #Updated configuration file
- #if [ -f "${ROOT}/etc/wwwoffle.conf" ]; then
- # mv "${D}/etc/wwwoffle.conf" "${D}/etc/wwwoffle.conf.updated"
- #fi
-
# install the wwwoffled init script
newinitd "${FILESDIR}/${PN}.initd" wwwoffled
newinitd "${FILESDIR}/${PN}-online.initd" wwwoffled-online
@@ -112,15 +87,22 @@ pkg_preinst() {
enewgroup wwwoffle
enewuser wwwoffle -1 -1 /var/spool/wwwoffle wwwoffle
- # TODO maybe rootjail ${ROOT}
- source /etc/init.d/functions.sh
- if [ -L "${svcdir}/started/wwwoffled" ]; then
- einfo "The wwwoffled init script is running. I'll stop it, merge the new files and
- restart the script."
- /etc/init.d/wwwoffled stop
- # Just to be sure...
- start-stop-daemon --stop --quiet --name wwwoffled
- touch "${T}/stopped"
+ # Changing the user:group to wwwoffle:woffle
+ fowners -R wwwoffle:wwwoffle /var/spool/wwwoffle /etc/wwwoffle
+ sed -i -e 's/^[# \t]\(run-[gu]id[ \t]*=[ \t]*\)[a-zA-Z0-9]*[ \t]*$/ \1wwwoffle/g' \
+ "${D}/etc/wwwoffle/wwwoffle.conf"
+
+ # Stop the service if it is started
+ if [ "${ROOT}" = "/" ] ; then
+ source /etc/init.d/functions.sh
+ if [ -L "${svcdir}/started/wwwoffled" ]; then
+ einfo "The wwwoffled init script is running. I'll stop it, merge the new files and
+ restart the script."
+ /etc/init.d/wwwoffled stop
+ # Just to be sure...
+ start-stop-daemon --stop --quiet --name wwwoffled
+ touch "${T}/stopped"
+ fi
fi
}
diff --git a/net-proxy/wwwoffle/wwwoffle-2.9a.ebuild b/net-proxy/wwwoffle/wwwoffle-2.9a.ebuild
index a9328f04ad0c..183e7cdbc8dd 100644
--- a/net-proxy/wwwoffle/wwwoffle-2.9a.ebuild
+++ b/net-proxy/wwwoffle/wwwoffle-2.9a.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/wwwoffle/wwwoffle-2.9a.ebuild,v 1.4 2006/12/03 20:02:29 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/wwwoffle/wwwoffle-2.9a.ebuild,v 1.5 2007/03/10 13:34:21 mrness Exp $
inherit eutils
@@ -35,29 +35,9 @@ src_unpack() {
}
src_compile() {
- # TODO confdir back to default /etc/wwwoffle
- # allows to change config file using web interface.
-
econf $(use_with zlib) $(use_with gnutls) \
$(use_with ipv6) || die "econf failed"
emake || die "emake failed"
-
- if [ -f "${ROOT}/etc/wwwoffle.conf" ] ; then
- einfo "Upgrading current configuration file"
- cp "${ROOT}/etc/wwwoffle.conf" conf/wwwoffle.conf
- conf/upgrade-config.pl conf/wwwoffle.conf
-
- # Hack to stop regeneration of config file
- touch conf/conf-file
-
- einfo "Changing the default user (and group) to wwwoffle"
- sed -i -e 's/\(run-[gu]id\)[ \t]*=[ \t]*[a-zA-Z0-9]*[ \t]*$/\1 = wwwoffle/g' \
- conf/wwwoffle.conf
- else
- einfo "Changing the default user (and group) to wwwoffle"
- sed -i -e 's/#\(run-[gu]id\)[ \t]*=[ \t]*[a-zA-Z0-9]*[ \t]*$/\1 = wwwoffle/g' \
- conf/wwwoffle.conf.template
- fi
}
src_install() {
@@ -69,11 +49,6 @@ src_install() {
dodir /usr/share/doc
mv "${D}/usr/doc/wwwoffle" "${D}/usr/share/doc/${PF}"
- #Updated configuration file
- #if [ -f "${ROOT}/etc/wwwoffle.conf" ]; then
- # mv "${D}/etc/wwwoffle.conf" "${D}/etc/wwwoffle.conf.updated"
- #fi
-
# install the wwwoffled init script
newinitd "${FILESDIR}/${PN}.initd" wwwoffled
newinitd "${FILESDIR}/${PN}-online.initd" wwwoffled-online
@@ -110,15 +85,22 @@ pkg_preinst() {
enewgroup wwwoffle
enewuser wwwoffle -1 -1 /var/spool/wwwoffle wwwoffle
- # TODO maybe rootjail ${ROOT}
- source /etc/init.d/functions.sh
- if [ -L "${svcdir}/started/wwwoffled" ]; then
- einfo "The wwwoffled init script is running. I'll stop it, merge the new files and
- restart the script."
- /etc/init.d/wwwoffled stop
- # Just to be sure...
- start-stop-daemon --stop --quiet --name wwwoffled
- touch "${T}/stopped"
+ # Changing the user:group to wwwoffle:woffle
+ fowners -R wwwoffle:wwwoffle /var/spool/wwwoffle /etc/wwwoffle
+ sed -i -e 's/^[# \t]\(run-[gu]id[ \t]*=[ \t]*\)[a-zA-Z0-9]*[ \t]*$/ \1wwwoffle/g' \
+ "${D}/etc/wwwoffle/wwwoffle.conf"
+
+ # Stop the service if it is started
+ if [ "${ROOT}" = "/" ] ; then
+ source /etc/init.d/functions.sh
+ if [ -L "${svcdir}/started/wwwoffled" ]; then
+ einfo "The wwwoffled init script is running. I'll stop it, merge the new files and
+ restart the script."
+ /etc/init.d/wwwoffled stop
+ # Just to be sure...
+ start-stop-daemon --stop --quiet --name wwwoffled
+ touch "${T}/stopped"
+ fi
fi
}
diff --git a/net-proxy/wwwoffle/wwwoffle-2.9b.ebuild b/net-proxy/wwwoffle/wwwoffle-2.9b.ebuild
new file mode 100644
index 000000000000..1ddcaaddf5d1
--- /dev/null
+++ b/net-proxy/wwwoffle/wwwoffle-2.9b.ebuild
@@ -0,0 +1,127 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/wwwoffle/wwwoffle-2.9b.ebuild,v 1.1 2007/03/10 13:34:21 mrness Exp $
+
+inherit eutils
+
+DESCRIPTION="wwwoffle = WWW Offline Explorer, an adv. caching proxy especially suitable for nonpermanent (e.g. dialup) Internet connections"
+SRC_URI="http://www.gedanken.demon.co.uk/download-wwwoffle/${P}.tgz"
+HOMEPAGE="http://www.gedanken.demon.co.uk/wwwoffle"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="gnutls ipv6 zlib"
+
+RDEPEND="gnutls? ( net-libs/gnutls )
+ zlib? ( sys-libs/zlib )"
+DEPEND="dev-lang/perl
+ sys-devel/flex
+ ${RDEPEND}"
+
+# Unsure whether to depend on >=www-misc/htdig-3.1.6-r4 or not
+
+src_unpack() {
+ unpack ${A}
+
+ sed -i -e 's#$(TAR) xpf #$(TAR) --no-same-owner -xpf #' \
+ "${S}/cache/Makefile.in"
+}
+
+src_compile() {
+ econf $(use_with zlib) \
+ $(use_with gnutls) \
+ $(use_with ipv6) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ # documentation fix
+ # del empty doc dirs
+ rmdir "${D}/usr/doc/${PN}"/{it,nl,ru}
+ dodir /usr/share/doc
+ mv "${D}/usr/doc/wwwoffle" "${D}/usr/share/doc/${PF}"
+
+ # install the wwwoffled init script
+ newinitd "${FILESDIR}/${PN}.initd" wwwoffled
+ newinitd "${FILESDIR}/${PN}-online.initd" wwwoffled-online
+ newconfd "${FILESDIR}/${PN}-online.confd" wwwoffled-online
+
+ keepdir /var/spool/wwwoffle/{http,outgoing,monitor,lasttime,lastout,local}
+ for number in 1 2 3 4 5 6 7 8 9; do
+ keepdir "/var/spool/wwwoffle/prevtime${number}" "/var/spool/wwwoffle/prevout${number}"
+ done
+
+ # empty dirs are removed during update
+ keepdir \
+ /var/spool/wwwoffle/search/{mnogosearch/db,htdig/tmp,htdig/db-lasttime,htdig/db,namazu/db}
+
+ touch \
+ "${D}/var/spool/wwwoffle/search/htdig/wwwoffle-htdig.log" \
+ "${D}/var/spool/wwwoffle/search/mnogosearch/wwwoffle-mnogosearch.log" \
+ "${D}/var/spool/wwwoffle/search/namazu/wwwoffle-namazu.log"
+
+ # TODO htdig indexing as part of initscripts
+
+ # robots.txt modification - /var/spool/wwwoffle/html/en
+ # - remove Disallow: /index
+ sed -i -e "s|Disallow:.*/index|#Disallow: /index|" "${D}/var/spool/wwwoffle/html/en/robots.txt"
+
+ rmdir "${D}/usr/doc"
+}
+
+pkg_preinst() {
+ # Add a wwwoffle user
+ enewgroup wwwoffle
+ enewuser wwwoffle -1 -1 /var/spool/wwwoffle wwwoffle
+
+ # Changing the user:group to wwwoffle:woffle
+ fowners -R wwwoffle:wwwoffle /var/spool/wwwoffle /etc/wwwoffle
+ sed -i -e 's/^[# \t]\(run-[gu]id[ \t]*=[ \t]*\)[a-zA-Z0-9]*[ \t]*$/ \1wwwoffle/g' \
+ "${D}/etc/wwwoffle/wwwoffle.conf"
+
+ # Stop the service if it is started
+ if [ "${ROOT}" = "/" ] ; then
+ source /etc/init.d/functions.sh
+ if [ -L "${svcdir}/started/wwwoffled" ]; then
+ einfo "The wwwoffled init script is running. I'll stop it, merge the new files and
+ restart the script."
+ /etc/init.d/wwwoffled stop
+ # Just to be sure...
+ start-stop-daemon --stop --quiet --name wwwoffled
+ touch "${T}/stopped"
+ fi
+ fi
+}
+
+pkg_postinst() {
+ # fix permissions for those upgrading
+ for number in 1 2 3 4 5 6 7 8 9;
+ do
+ [ ! -d "${ROOT}/var/spool/wwwoffle/prevtime${number}" ] && \
+ keepdir "${ROOT}/var/spool/wwwoffle/prevtime${number}"
+ [ ! -d "${ROOT}/var/spool/wwwoffle/prevout${number}" ] && \
+ keepdir "${ROOT}/var/spool/wwwoffle/prevout${number}"
+ done
+ chown -R wwwoffle:wwwoffle "${ROOT}/var/spool/wwwoffle" "${ROOT}/etc/wwwoffle"
+
+ [ -f "${T}/stopped" ] && \
+ ewarn "wwwoffled was stopped. /etc/init.d/wwwoffled start to restart AFTER etc-update"
+
+ einfo "wwwoffled should run as an ordinary user now. The run-uid and run-gid should be set"
+ einfo "to \"wwwoffle\" in your /etc/wwwoffle/wwwoffle.conf. Please uncomment this if it hasn't been already"
+
+ einfo "This is for your own security. Otherwise wwwoffle is run as root which is relay bad if"
+ einfo "there is an exploit in this program that allows remote/local users to execute arbitary"
+ einfo "commands as the root user."
+
+ if [ -f "${ROOT}/etc/wwwoffle.conf" ]; then
+ ewarn "Configuration file is /etc/wwwoffle/wwwoffle.conf now"
+ ewarn "Suggest you move ${ROOT}etc/wwwoffle.conf"
+ fi
+
+ # if htdig - run script for full database index
+ # TODO
+}