summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Jaroszyński <peper@gentoo.org>2006-11-13 14:04:13 +0000
committerPiotr Jaroszyński <peper@gentoo.org>2006-11-13 14:04:13 +0000
commit61cac0b3c7a446e69976f20d7a548dc300836359 (patch)
tree93b718035ea451ec5e6d5d564ad3318ac1048ddd /net-voip/telepathy-gabble
parent"Stable x86, bug #147570" (diff)
downloadgentoo-2-61cac0b3c7a446e69976f20d7a548dc300836359.tar.gz
gentoo-2-61cac0b3c7a446e69976f20d7a548dc300836359.tar.bz2
gentoo-2-61cac0b3c7a446e69976f20d7a548dc300836359.zip
Fix src_test().
(Portage version: 2.1.2_rc1-r6)
Diffstat (limited to 'net-voip/telepathy-gabble')
-rw-r--r--net-voip/telepathy-gabble/ChangeLog6
-rw-r--r--net-voip/telepathy-gabble/telepathy-gabble-0.4.5.ebuild12
2 files changed, 15 insertions, 3 deletions
diff --git a/net-voip/telepathy-gabble/ChangeLog b/net-voip/telepathy-gabble/ChangeLog
index 84a8578f6b51..442318dc4c6a 100644
--- a/net-voip/telepathy-gabble/ChangeLog
+++ b/net-voip/telepathy-gabble/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-voip/telepathy-gabble
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-voip/telepathy-gabble/ChangeLog,v 1.6 2006/11/13 12:01:44 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-voip/telepathy-gabble/ChangeLog,v 1.7 2006/11/13 14:04:13 peper Exp $
+
+ 13 Nov 2006; Piotr Jaroszyński <peper@gentoo.org>
+ telepathy-gabble-0.4.5.ebuild:
+ Fix src_test().
*telepathy-gabble-0.4.5 (13 Nov 2006)
diff --git a/net-voip/telepathy-gabble/telepathy-gabble-0.4.5.ebuild b/net-voip/telepathy-gabble/telepathy-gabble-0.4.5.ebuild
index 8f5958522cd7..2068e3e24cdf 100644
--- a/net-voip/telepathy-gabble/telepathy-gabble-0.4.5.ebuild
+++ b/net-voip/telepathy-gabble/telepathy-gabble-0.4.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-voip/telepathy-gabble/telepathy-gabble-0.4.5.ebuild,v 1.1 2006/11/13 12:01:44 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-voip/telepathy-gabble/telepathy-gabble-0.4.5.ebuild,v 1.2 2006/11/13 14:04:13 peper Exp $
DESCRIPTION="A Jabber/XMPP connection manager, this handles single and multi user chats and voice calls."
HOMEPAGE="http://telepathy.freedesktop.org"
@@ -16,7 +16,7 @@ DEPEND=">=dev-libs/glib-2.4
loudmouth? ( >=net-libs/loudmouth-1.1.1 )"
RDEPEND="${DEPEND}"
-src_compile(){
+src_compile() {
econf \
$(use_enable debug) \
$(use_enable debug handle-leak-debug) \
@@ -25,6 +25,14 @@ src_compile(){
emake || die "emake failed"
}
+src_test() {
+ vecho ">>> Test phase [check]: ${CATEGORY}/${PF}"
+ if ! dbus-launch emake -j1 check; then
+ hasq test $FEATURES && die "Make check failed. See above for details."
+ hasq test $FEATURES || eerror "Make check failed. See above for details."
+ fi
+}
+
src_install() {
emake install DESTDIR="${D}" || die "emake install failed"
dodoc AUTHORS README ChangeLog NEWS README