summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-07-31 11:52:57 +0000
committerPacho Ramos <pacho@gentoo.org>2010-07-31 11:52:57 +0000
commitb3bb74032b0d630460e335b202c95136abcf4a75 (patch)
tree7c470f5d74c01ee81b234f3940c952befae358b1 /net-voip/telepathy-gabble
parentAdd patches from nominations branch. So we can open stablerequest for 1.7.7-r1. (diff)
downloadgentoo-2-b3bb74032b0d630460e335b202c95136abcf4a75.tar.gz
gentoo-2-b3bb74032b0d630460e335b202c95136abcf4a75.tar.bz2
gentoo-2-b3bb74032b0d630460e335b202c95136abcf4a75.zip
Version bump with important fixes, restrict tests since most of them are broken (upstream is aware of the problem)
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'net-voip/telepathy-gabble')
-rw-r--r--net-voip/telepathy-gabble/ChangeLog9
-rw-r--r--net-voip/telepathy-gabble/telepathy-gabble-0.8.14.ebuild50
2 files changed, 58 insertions, 1 deletions
diff --git a/net-voip/telepathy-gabble/ChangeLog b/net-voip/telepathy-gabble/ChangeLog
index e67840c7f7c2..ecadd274d233 100644
--- a/net-voip/telepathy-gabble/ChangeLog
+++ b/net-voip/telepathy-gabble/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-voip/telepathy-gabble
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-voip/telepathy-gabble/ChangeLog,v 1.57 2010/07/25 15:23:33 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-voip/telepathy-gabble/ChangeLog,v 1.58 2010/07/31 11:52:57 pacho Exp $
+
+*telepathy-gabble-0.8.14 (31 Jul 2010)
+
+ 31 Jul 2010; Pacho Ramos <pacho@gentoo.org>
+ +telepathy-gabble-0.8.14.ebuild:
+ Version bump with important fixes, restrict tests since really a lot of
+ them are broken (upstream bugs #23168 and #20635).
25 Jul 2010; Tobias Klausmann <klausman@gentoo.org>
telepathy-gabble-0.8.8.ebuild:
diff --git a/net-voip/telepathy-gabble/telepathy-gabble-0.8.14.ebuild b/net-voip/telepathy-gabble/telepathy-gabble-0.8.14.ebuild
new file mode 100644
index 000000000000..08c56c231417
--- /dev/null
+++ b/net-voip/telepathy-gabble/telepathy-gabble-0.8.14.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-voip/telepathy-gabble/telepathy-gabble-0.8.14.ebuild,v 1.1 2010/07/31 11:52:57 pacho Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="A Jabber/XMPP connection manager, this handles single and multi user chats and voice calls."
+HOMEPAGE="http://telepathy.freedesktop.org"
+SRC_URI="http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug test"
+
+RDEPEND=">=dev-libs/glib-2.16
+ >=sys-apps/dbus-1.1.0
+ >=dev-libs/dbus-glib-0.78
+ >=net-libs/telepathy-glib-0.7.37
+ >=net-libs/loudmouth-1.3.2[ssl]
+ net-libs/libsoup:2.4[ssl]"
+
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ >=dev-lang/python-2.5
+ test? ( >=dev-python/twisted-0.8.2
+ >=dev-python/twisted-words-0.8.2
+ >=dev-python/dbus-python-0.83 )"
+
+# See upstream fdo bug #23168 and #20635
+RESTRICT="test"
+
+src_configure() {
+ econf \
+ --docdir=/usr/share/doc/${PF} \
+ $(use_enable debug) \
+ $(use_enable debug handle-leak-debug)
+}
+
+#src_test() {
+# unset DBUS_SESSION_BUS_ADDRESS
+# emake -j1 check || die "Make check failed. See above for details."
+#}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dodoc AUTHORS NEWS ChangeLog README || die "dodoc failed"
+}