summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2010-02-18 18:57:39 +0000
committerPeter Volkov <pva@gentoo.org>2010-02-18 18:57:39 +0000
commit75f0af78686c01a5c3bf00db3f22168749354a60 (patch)
treee4bfe30e0d1d60aacc59419cc25d1e150b374c65 /net-voip
parentAdded upstream link in patch. (diff)
downloadgentoo-2-75f0af78686c01a5c3bf00db3f22168749354a60.tar.gz
gentoo-2-75f0af78686c01a5c3bf00db3f22168749354a60.tar.bz2
gentoo-2-75f0af78686c01a5c3bf00db3f22168749354a60.zip
Version bump, fixes bug #285478.
(Portage version: 2.1.7.17/cvs/Linux x86_64)
Diffstat (limited to 'net-voip')
-rw-r--r--net-voip/linphone/ChangeLog12
-rw-r--r--net-voip/linphone/files/linphone-3.2.1-external-mediastreamer.patch125
-rw-r--r--net-voip/linphone/files/linphone-3.2.1-log-window-crash.patch12
-rw-r--r--net-voip/linphone/files/linphone-3.2.1-nls.patch16
-rw-r--r--net-voip/linphone/linphone-3.2.1.ebuild101
5 files changed, 264 insertions, 2 deletions
diff --git a/net-voip/linphone/ChangeLog b/net-voip/linphone/ChangeLog
index 46c3da1a546b..04eed175f88b 100644
--- a/net-voip/linphone/ChangeLog
+++ b/net-voip/linphone/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-voip/linphone
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-voip/linphone/ChangeLog,v 1.40 2009/08/24 09:13:15 vapier Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-voip/linphone/ChangeLog,v 1.41 2010/02/18 18:57:38 pva Exp $
+
+*linphone-3.2.1 (18 Feb 2010)
+
+ 18 Feb 2010; Peter Volkov <pva@gentoo.org> +linphone-3.2.1.ebuild,
+ +files/linphone-3.2.1-external-mediastreamer.patch,
+ +files/linphone-3.2.1-log-window-crash.patch,
+ +files/linphone-3.2.1-nls.patch:
+ Version bump, fixes bug #285478.
24 Aug 2009; Mike Frysinger <vapier@gentoo.org> linphone-3.1.2.ebuild:
Fix libtool mismatch troubles #282268 by rainer and drop pointless LINGUAS
diff --git a/net-voip/linphone/files/linphone-3.2.1-external-mediastreamer.patch b/net-voip/linphone/files/linphone-3.2.1-external-mediastreamer.patch
new file mode 100644
index 000000000000..de39bcf57740
--- /dev/null
+++ b/net-voip/linphone/files/linphone-3.2.1-external-mediastreamer.patch
@@ -0,0 +1,125 @@
+=== modified file 'configure.in'
+--- configure.in 2010-02-11 15:15:20 +0000
++++ configure.in 2010-02-11 15:15:24 +0000
+@@ -328,7 +328,26 @@
+
+ AC_SUBST(STRICT_OPTIONS)
+
+-AC_CONFIG_SUBDIRS( mediastreamer2 )
++AC_ARG_ENABLE(external-mediastreamer,
++ [ --enable-external-mediastreamer Use external mediastreamer library],
++ [case "${enableval}" in
++ yes) external_mediastreamer=true ;;
++ no) external_mediastreamer=false ;;
++ *) AC_MSG_ERROR(bad value ${enableval} for --enable-external-mediastreamer) ;;
++ esac],[external_mediastreamer=false])
++
++if test "$external_mediastreamer" = 'true'; then
++ LP_CHECK_MSTREAMER
++else
++ AC_CONFIG_SUBDIRS( mediastreamer2 )
++ MSTREAMER_CFLAGS="-I\$(top_srcdir)/mediastreamer2/include"
++ MSTREAMER_LIBS="\$(top_builddir)/mediastreamer2/src/libmediastreamer.la"
++fi
++
++AC_SUBST(MSTREAMER_CFLAGS)
++AC_SUBST(MSTREAMER_LIBS)
++
++AM_CONDITIONAL(EXTERNAL_MSTREAMER, [test "$external_mediastreamer" = 'true'])
+
+ dnl check for db2html (docbook) to generate html user manual
+ AC_CHECK_PROG(have_sgmltools,sgmltools, yes, no)
+
+=== modified file 'console/Makefile.am'
+--- console/Makefile.am 2010-02-11 15:13:22 +0000
++++ console/Makefile.am 2010-02-11 15:16:28 +0000
+@@ -9,7 +9,7 @@
+ -I$(top_srcdir)/coreapi\
+ $(ORTP_CFLAGS) \
+ -I$(top_srcdir)/exosip \
+- -I$(top_srcdir)/mediastreamer2/include
++ $(MSTREAMER_CFLAGS)
+
+
+
+@@ -22,7 +22,7 @@
+ linphonec_SOURCES = linphonec.c linphonec.h commands.c
+ linphonec_CFLAGS=$(COMMON_CFLAGS) $(CONSOLE_FLAGS)
+ linphonec_LDADD = $(top_builddir)/coreapi/liblinphone.la $(READLINE_LIBS) \
+- $(top_builddir)/mediastreamer2/src/libmediastreamer.la \
++ $(MSTREAMER_LIBS) \
+ $(ORTP_LIBS) \
+ $(SPEEX_LIBS) \
+ $(OSIP_LIBS)
+@@ -41,7 +41,7 @@
+
+ sipomatic_LDADD= $(INTLLIBS) \
+ $(top_builddir)/coreapi/liblinphone.la \
+- $(top_builddir)/mediastreamer2/src/libmediastreamer.la \
++ $(MSTREAMER_LIBS) \
+ $(ORTP_LIBS) \
+ $(SPEEX_LIBS) \
+ $(OSIP_LIBS)
+
+=== modified file 'coreapi/Makefile.am'
+--- coreapi/Makefile.am 2010-02-11 15:13:22 +0000
++++ coreapi/Makefile.am 2010-02-11 15:18:19 +0000
+@@ -7,7 +7,7 @@
+
+ INCLUDES = \
+ -I$(top_srcdir)\
+- -I$(top_srcdir)/mediastreamer2/include
++ $(MSTREAMER_CFLAGS)
+
+
+ lib_LTLIBRARIES=liblinphone.la
+@@ -33,7 +33,7 @@
+
+ liblinphone_la_LIBADD= \
+ $(EXOSIP_LIBS) \
+- $(top_builddir)/mediastreamer2/src/libmediastreamer.la \
++ $(MSTREAMER_LIBS) \
+ $(ORTP_LIBS)
+
+ if BUILD_WIN32
+
+=== modified file 'gtk-glade/Makefile.am'
+--- gtk-glade/Makefile.am 2010-02-11 15:13:22 +0000
++++ gtk-glade/Makefile.am 2010-02-11 15:16:28 +0000
+@@ -47,8 +47,8 @@
+ loginframe.c \
+ linphone.h
+
+-linphone_3_LDADD=$(top_builddir)/oRTP/src/libortp.la \
+- $(top_builddir)/mediastreamer2/src/libmediastreamer.la \
++linphone_3_LDADD=$(ORTP_LIBS) \
++ $(MSTREAMER_LIBS) \
+ $(top_builddir)/coreapi/liblinphone.la \
+ $(LIBGTK_LIBS) $(INTLLIBS) \
+ $(LIBGLADE_LIBS)
+@@ -77,7 +77,7 @@
+
+
+ AM_CFLAGS= -DIN_LINPHONE -I$(top_srcdir)/coreapi/ \
+- -I$(top_srcdir)/mediastreamer2/include/ \
++ $(MSTREAMER_CFLAGS) \
+ $(LIBGLADE_CFLAGS) $(STRICT_OPTIONS) $(LIBGTK_CFLAGS) $(IPV6_CFLAGS) \
+ $(ORTP_CFLAGS) $(OSIP_CFLAGS)
+
+
+=== added file 'm4/mstreamer.m4'
+--- m4/mstreamer.m4 1970-01-01 00:00:00 +0000
++++ m4/mstreamer.m4 2010-02-11 15:16:28 +0000
+@@ -0,0 +1,11 @@
++AC_DEFUN([LP_CHECK_MSTREAMER],[
++
++PKG_CHECK_MODULES([MSTREAMER], [mediastreamer >= 2.2.3], , [ms_failed=true])
++
++if test "$ms_failed" = "true"; then
++ AC_MSG_ERROR("External mediastreamer library not found")
++fi
++
++AC_SUBST([MSTREAMER_LIBS])
++AC_SUBST([MSTREAMER_CFLAGS])
++])
+
diff --git a/net-voip/linphone/files/linphone-3.2.1-log-window-crash.patch b/net-voip/linphone/files/linphone-3.2.1-log-window-crash.patch
new file mode 100644
index 000000000000..904a635b5187
--- /dev/null
+++ b/net-voip/linphone/files/linphone-3.2.1-log-window-crash.patch
@@ -0,0 +1,12 @@
+=== modified file 'gtk-glade/log.glade'
+--- gtk-glade/log.glade 2010-02-12 09:04:09 +0000
++++ gtk-glade/log.glade 2010-02-12 09:04:42 +0000
+@@ -13,6 +13,7 @@
+ <property name="deletable">False</property>
+ <property name="has_separator">False</property>
+ <signal name="response" handler="gtk_widget_hide"/>
++ <signal name="delete-event" handler="gtk_widget_hide"/>
+ <child internal-child="vbox">
+ <widget class="GtkVBox" id="dialog-vbox1">
+ <property name="visible">True</property>
+
diff --git a/net-voip/linphone/files/linphone-3.2.1-nls.patch b/net-voip/linphone/files/linphone-3.2.1-nls.patch
new file mode 100644
index 000000000000..ee8e5763d0be
--- /dev/null
+++ b/net-voip/linphone/files/linphone-3.2.1-nls.patch
@@ -0,0 +1,16 @@
+=== modified file 'configure.in'
+--- configure.in 2010-02-11 15:13:22 +0000
++++ configure.in 2010-02-11 15:14:08 +0000
+@@ -54,7 +54,10 @@
+ AC_SUBST(GUI_FLAGS)
+
+ dnl localization tools
+-ifdef([IT_PROG_INTLTOOL],[IT_PROG_INTLTOOL],[AC_PROG_INTLTOOL])
++AM_NLS
++if test "$USE_NLS" != "no"; then
++ ifdef([IT_PROG_INTLTOOL],[IT_PROG_INTLTOOL],[AC_PROG_INTLTOOL])
++fi
+ dnl Initialize libtool
+ AC_LIBTOOL_WIN32_DLL
+ AC_PROG_LIBTOOL
+
diff --git a/net-voip/linphone/linphone-3.2.1.ebuild b/net-voip/linphone/linphone-3.2.1.ebuild
new file mode 100644
index 000000000000..6a8977113171
--- /dev/null
+++ b/net-voip/linphone/linphone-3.2.1.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-voip/linphone/linphone-3.2.1.ebuild,v 1.1 2010/02/18 18:57:38 pva Exp $
+
+EAPI="2"
+
+inherit eutils autotools multilib
+
+DESCRIPTION="Video softphone based on the SIP protocol"
+HOMEPAGE="http://www.linphone.org/"
+SRC_URI="http://download.savannah.nongnu.org/releases/${PN}/stable/sources/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc gtk ipv6 ncurses nls video"
+
+RDEPEND=">=media-libs/mediastreamer-2.3.0[video?]
+ >=net-libs/libeXosip-3.0.2
+ >=net-libs/libosip-3.0.0
+ >=net-libs/ortp-0.16.1
+ gtk? ( dev-libs/glib:2
+ >=gnome-base/libglade-2.4.0:2.0
+ >=x11-libs/gtk+-2.4.0:2 )
+ ncurses? ( sys-libs/readline
+ sys-libs/ncurses )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( app-text/sgmltools-lite )
+ nls? ( dev-util/intltool
+ sys-devel/gettext )"
+
+IUSE_LINGUAS=" fr it de ja es pl cs nl sv pt_BR hu ru zh_CN"
+IUSE="${IUSE} ${IUSE_LINGUAS// / linguas_}"
+
+# TODO:
+# update ortp ?
+# update mediastreamer ?
+
+# TODO:
+# run-time test for ipv6 : does it need mediastreamer[ipv6] ?
+
+pkg_setup() {
+ if ! use gtk && ! use ncurses ; then
+ ewarn "gtk and ncurses are disabled."
+ ewarn "At least one of these use flags are needed to get a front-end."
+ ewarn "Only liblinphone is going to be installed."
+ fi
+
+ strip-linguas ${IUSE_LINGUAS}
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-external-mediastreamer.patch
+ epatch "${FILESDIR}"/${P}-nls.patch
+ epatch "${FILESDIR}"/${P}-log-window-crash.patch
+
+ # remove speex check, avoid bug when mediastreamer[-speex]
+ sed -i -e '/SPEEX/d' configure.in || die "patching configure.in failed"
+
+ # fix path to use lib64
+ sed -i -e "s:lib\(/liblinphone\):$(get_libdir)\1:" configure.in \
+ || die "patching configure.in failed"
+
+ # removing bundled libs dir prevent them to be reconf
+ rm -rf mediastreamer2 oRTP || die "should not die"
+ # and references in Makefile.am
+ sed -i -e "s:oRTP::" -e "s:mediastreamer2::" Makefile.am \
+ || die "patching Makefile.am failed"
+
+ # make sure to use host libtool version
+ rm -f m4/libtool.m4 m4/lt*.m4 #282268
+ eautoreconf
+}
+
+src_configure() {
+ # strict: we don't want -Werror
+ # external-ortp,external-mediastreamer: prefer external libs
+ # truespeech: seems not used, TODO: ask in ml
+ # rsvp: breaking the build (not maintained anymore) --disable = --enable
+ # alsa, artsc and portaudio are used for bundled mediastreamer
+ econf \
+ --libdir=/usr/$(get_libdir) \
+ --disable-strict \
+ --enable-external-ortp \
+ --enable-external-mediastreamer \
+ --disable-truespeech \
+ --disable-dependency-tracking \
+ $(use_enable doc manual) \
+ $(use_enable gtk gtk_ui) \
+ $(use_enable ipv6) \
+ $(use_enable ncurses console_ui) \
+ $(use_enable nls) \
+ $(use_enable video)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dosym linphone-3 /usr/bin/linphone || die
+ dodoc AUTHORS BUGS ChangeLog NEWS README README.arm TODO
+}