summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJean-Noël Rivasseau <elvanor@gentoo.org>2011-02-22 14:12:11 +0000
committerJean-Noël Rivasseau <elvanor@gentoo.org>2011-02-22 14:12:11 +0000
commit860f9079e50e5715370d5e7ca0d59969c5a3e625 (patch)
tree34a1d27a3a320927e0628e122f4b11e44941f709 /net-voip
parentfixed compilation with cmake-2.8.4, bug #356009 (diff)
downloadgentoo-2-860f9079e50e5715370d5e7ca0d59969c5a3e625.tar.gz
gentoo-2-860f9079e50e5715370d5e7ca0d59969c5a3e625.tar.bz2
gentoo-2-860f9079e50e5715370d5e7ca0d59969c5a3e625.zip
Bug #343043.
(Portage version: 2.1.9.25/cvs/Linux i686)
Diffstat (limited to 'net-voip')
-rw-r--r--net-voip/sflphone/ChangeLog8
-rw-r--r--net-voip/sflphone/files/sflphone-0.9.12-libnotify-0.7.patch34
-rw-r--r--net-voip/sflphone/sflphone-0.9.12.ebuild153
3 files changed, 194 insertions, 1 deletions
diff --git a/net-voip/sflphone/ChangeLog b/net-voip/sflphone/ChangeLog
index 3f86e0d5f4cb..9f117877c824 100644
--- a/net-voip/sflphone/ChangeLog
+++ b/net-voip/sflphone/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-voip/sflphone
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-voip/sflphone/ChangeLog,v 1.6 2011/01/30 14:07:55 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-voip/sflphone/ChangeLog,v 1.7 2011/02/22 14:12:11 elvanor Exp $
+
+*sflphone-0.9.12 (22 Feb 2011)
+
+ 22 Feb 2011; <elvanor@gentoo.org> +sflphone-0.9.12.ebuild,
+ +files/sflphone-0.9.12-libnotify-0.7.patch:
+ Version bump, bug #343043.
30 Jan 2011; Samuli Suominen <ssuominen@gentoo.org> sflphone-0.9.8.4.ebuild,
+files/sflphone-0.9.8.4-libnotify-0.7.patch:
diff --git a/net-voip/sflphone/files/sflphone-0.9.12-libnotify-0.7.patch b/net-voip/sflphone/files/sflphone-0.9.12-libnotify-0.7.patch
new file mode 100644
index 000000000000..20fa9c97da15
--- /dev/null
+++ b/net-voip/sflphone/files/sflphone-0.9.12-libnotify-0.7.patch
@@ -0,0 +1,34 @@
+--- sflphone-client-gnome/src/sflnotify.c
++++ sflphone-client-gnome/src/sflnotify.c
+@@ -31,6 +31,10 @@
+ #include "sflnotify.h"
+ #include <eel-gconf-extensions.h>
+
++#ifndef NOTIFY_CHECK_VERSION
++#define NOTIFY_CHECK_VERSION(x,y,z) 0
++#endif
++
+ GnomeNotification *_gnome_notification;
+
+ void create_new_gnome_notification (gchar *title, gchar *body, NotifyUrgency urgency, gint timeout, GnomeNotification **notif)
+@@ -44,12 +48,20 @@
+ notify_init ("SFLphone");
+
+ // Set struct fields
++#if NOTIFY_CHECK_VERSION (0, 7, 0)
++ _notif->notification = notify_notification_new (title, body, NULL);
++#else
+ _notif->notification = notify_notification_new (title, body, NULL, NULL);
++#endif
+ //_notif->icon = gdk_pixbuf_new_from_file_at_size (LOGO, 120, 120, NULL);
+ _notif->icon = gdk_pixbuf_new_from_file (LOGO_SMALL, NULL);
+ #if GTK_CHECK_VERSION(2,10,0)
++#if NOTIFY_CHECK_VERSION (0, 7, 0)
++ // notify_notification_attach_to_status_icon function was removed
++#else
+ notify_notification_attach_to_status_icon (_notif->notification , get_status_icon());
+ #endif
++#endif
+
+ notify_notification_set_urgency (_notif->notification, urgency);
+
diff --git a/net-voip/sflphone/sflphone-0.9.12.ebuild b/net-voip/sflphone/sflphone-0.9.12.ebuild
new file mode 100644
index 000000000000..f093e4e26a6d
--- /dev/null
+++ b/net-voip/sflphone/sflphone-0.9.12.ebuild
@@ -0,0 +1,153 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-voip/sflphone/sflphone-0.9.12.ebuild,v 1.1 2011/02/22 14:12:11 elvanor Exp $
+
+EAPI="2"
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="SFLphone is a robust standards-compliant enterprise softphone, for desktop and embedded systems."
+HOMEPAGE="http://www.sflphone.org/"
+SRC_URI="http://www.elvanor.net/files/gentoo/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug gnome gsm networkmanager speex"
+
+CDEPEND="dev-cpp/commoncpp2
+ dev-libs/expat
+ dev-libs/openssl
+ dev-libs/libpcre
+ dev-libs/libyaml
+ >=dev-util/astyle-1.24
+ media-libs/alsa-lib
+ media-libs/celt
+ media-libs/libsamplerate
+ media-sound/pulseaudio
+ net-libs/ccrtp
+ net-libs/iax
+ net-libs/libzrtpcpp
+ >=net-libs/pjsip-1.8.10
+ sys-apps/dbus
+ gsm? ( media-sound/gsm )
+ speex? ( media-libs/speex )
+ networkmanager? ( net-misc/networkmanager )
+ gnome? ( dev-libs/atk
+ dev-libs/check
+ dev-libs/log4c
+ gnome-base/libgnomeui
+ gnome-base/orbit
+ gnome-extra/evolution-data-server
+ media-libs/fontconfig
+ media-libs/freetype
+ media-libs/libart_lgpl
+ net-libs/libsoup
+ net-libs/webkit-gtk
+ x11-libs/cairo
+ x11-libs/libICE
+ x11-libs/libnotify
+ x11-libs/libSM )"
+
+DEPEND="${CDEPEND}
+ gnome? ( app-text/gnome-doc-utils )"
+
+RDEPEND="${CDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-libnotify-0.7.patch
+
+ if ! use gnome; then
+ ewarn
+ ewarn "No clients selected. Use USE=gnome to get the gnome client."
+ ewarn "See"
+ ewarn "https://projects.savoirfairelinux.com/repositories/browse/sflphone/tools/pysflphone"
+ ewarn "for a python command line client."
+ ewarn
+ fi
+
+ sed -i -e 's/unpad=paren/unpad-paren/' astylerc || die "sed failed."
+ cd sflphone-common
+ #remove "target" from lib-names, remove dep to shipped pjsip
+ sed -i -e 's/-$(target)//' \
+ -e '/^\t\t\t-L/ d' \
+ -e 's!-I$(src)/libs/pjproject!-I/usr/include!' \
+ globals.mak || die "sed failed."
+ #respect CXXFLAGS
+ sed -i -e 's/CXXFLAGS="-g/CXXFLAGS="-g $CXXFLAGS /' \
+ configure.ac || die "sed failed."
+ rm -r libs/pjproject
+ eautoreconf
+
+ #TODO: remove shipped dbus-c++ use system one (see #220767)
+ #TODO: remove shipped utilspp (from curlpp), use system one, see #55185
+
+ if use gnome; then
+ cd ../sflphone-client-gnome
+ #fix as-needed
+ sed -i -e "s/X11_LIBS)/X11_LIBS) -lebook-1.2 -lwebkit-1.0/" src/Makefile.am || die "sed failed."
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ cd sflphone-common
+ econf --disable-dependency-tracking \
+ $(use_with debug) \
+ $(use_with gsm) \
+ $(use_with speex) \
+ $(use_with networkmanager) || die "econf failed."
+
+ if use gnome; then
+ cd ../sflphone-client-gnome
+ econf || die "econf failed."
+ fi
+}
+
+src_compile() {
+ cd sflphone-common
+ emake || die "emake failed."
+
+ if use gnome; then
+ cd ../sflphone-client-gnome
+ emake || die "emake failed."
+ fi
+}
+
+src_install() {
+ cd sflphone-common
+ emake -j1 DESTDIR="${D}" install || die "emake install failed"
+ dodoc test/sflphonedrc-sample
+
+ if use gnome; then
+ cd ../sflphone-client-gnome
+ emake DESTDIR="${D}" install || die "emake install failed"
+ gnome2_src_install
+ fi
+}
+
+pkg_postinst() {
+ elog
+ elog "You need to restart dbus, if you want to access"
+ elog "sflphoned through dbus."
+ elog
+ elog
+ elog "If you use the command line client"
+ elog "(https://projects.savoirfairelinux.com/repositories/browse/sflphone/tools/pysflphone)"
+ elog "extract /usr/share/doc/${PF}/${PN}drc-sample to"
+ elog "~/.config/${PN}/${PN}drc for example config."
+ elog
+ elog
+ elog "For calls out of your browser have a look in sflphone-callto"
+ elog "and sflphone-handler. You should consider to install"
+ elog "the \"Telify\" Firefox addon. See"
+ elog "https://projects.savoirfairelinux.com/repositories/browse/sflphone/tools"
+ elog
+ if use gnome; then
+ elog
+ elog "sflphone-client-gnome: To manage your contacts you need"
+ elog "mail-client/evolution or access to an evolution-data-server"
+ elog "connected backend."
+ elog
+ fi
+}