summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-06-18 12:22:46 +0000
committerPacho Ramos <pacho@gentoo.org>2010-06-18 12:22:46 +0000
commitca81e6c6d09f64dbb3d013dcaca18dfdf15751f6 (patch)
tree7d94cd43ecfe921ab124f32a3fb777150e38ff81 /net-wireless/gnome-bluetooth
parentVersion bump wrt #305109 by "hitachi". (diff)
downloadgentoo-2-ca81e6c6d09f64dbb3d013dcaca18dfdf15751f6.tar.gz
gentoo-2-ca81e6c6d09f64dbb3d013dcaca18dfdf15751f6.tar.bz2
gentoo-2-ca81e6c6d09f64dbb3d013dcaca18dfdf15751f6.zip
Version bump
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'net-wireless/gnome-bluetooth')
-rw-r--r--net-wireless/gnome-bluetooth/ChangeLog10
-rw-r--r--net-wireless/gnome-bluetooth/files/gnome-bluetooth-2.30.0-add-pin.patch23
-rw-r--r--net-wireless/gnome-bluetooth/files/gnome-bluetooth-2.30.0-mounted-failure.patch34
-rw-r--r--net-wireless/gnome-bluetooth/gnome-bluetooth-2.30.0.ebuild60
-rw-r--r--net-wireless/gnome-bluetooth/metadata.xml3
5 files changed, 129 insertions, 1 deletions
diff --git a/net-wireless/gnome-bluetooth/ChangeLog b/net-wireless/gnome-bluetooth/ChangeLog
index b2bee591e510..003d17413086 100644
--- a/net-wireless/gnome-bluetooth/ChangeLog
+++ b/net-wireless/gnome-bluetooth/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-wireless/gnome-bluetooth
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/gnome-bluetooth/ChangeLog,v 1.74 2010/06/11 11:54:13 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/gnome-bluetooth/ChangeLog,v 1.75 2010/06/18 12:22:46 pacho Exp $
+
+*gnome-bluetooth-2.30.0 (18 Jun 2010)
+
+ 18 Jun 2010; Pacho Ramos <pacho@gentoo.org>
+ +gnome-bluetooth-2.30.0.ebuild,
+ +files/gnome-bluetooth-2.30.0-add-pin.patch,
+ +files/gnome-bluetooth-2.30.0-mounted-failure.patch:
+ Version bump for Gnome 2.30
11 Jun 2010; Pacho Ramos <pacho@gentoo.org> -gnome-bluetooth-0.9.1.ebuild,
-gnome-bluetooth-0.11.0.ebuild, gnome-bluetooth-0.12.0.ebuild,
diff --git a/net-wireless/gnome-bluetooth/files/gnome-bluetooth-2.30.0-add-pin.patch b/net-wireless/gnome-bluetooth/files/gnome-bluetooth-2.30.0-add-pin.patch
new file mode 100644
index 000000000000..dc55eb65fe2d
--- /dev/null
+++ b/net-wireless/gnome-bluetooth/files/gnome-bluetooth-2.30.0-add-pin.patch
@@ -0,0 +1,23 @@
+From fff176c2b14516bc572576199490a0f526999b24 Mon Sep 17 00:00:00 2001
+From: Bastien Nocera <hadess@hadess.net>
+Date: Sun, 02 May 2010 17:45:21 +0000
+Subject: Add pin code for BT-GPS8 JENTRO
+
+https://bugzilla.gnome.org/show_bug.cgi?id=617371
+---
+diff --git a/wizard/pin-code-database.xml b/wizard/pin-code-database.xml
+index 8f9e9a3..8a73d65 100644
+--- a/wizard/pin-code-database.xml
++++ b/wizard/pin-code-database.xml
+@@ -65,6 +65,9 @@
+ <device oui="00:19:1D:" name="Nintendo RVL-CNT-01" pin="NULL"/>
+ <device oui="00:1F:C5:" name="Nintendo RVL-CNT-01" pin="NULL"/>
+
++ <!-- BT-GPS8 JENTRO, GPS mouse -->
++ <device oui="00:0D:B5:" name="BT-GPS8 JENTRO" pin="0000"/>
++
+ <!-- GPS devices -->
+ <device oui="00:0D:B5:" name="TomTom Wireless GPS MkII" pin="0000"/>
+ <device oui="00:0D:B5:" name="GPS-GW-005" pin="0000"/>
+--
+cgit v0.8.3.1
diff --git a/net-wireless/gnome-bluetooth/files/gnome-bluetooth-2.30.0-mounted-failure.patch b/net-wireless/gnome-bluetooth/files/gnome-bluetooth-2.30.0-mounted-failure.patch
new file mode 100644
index 000000000000..90e5da5dff76
--- /dev/null
+++ b/net-wireless/gnome-bluetooth/files/gnome-bluetooth-2.30.0-mounted-failure.patch
@@ -0,0 +1,34 @@
+From 49c9ab7ddd8c20ad1722d20185a0fc3e71ce2d20 Mon Sep 17 00:00:00 2001
+From: Bastien Nocera <hadess@hadess.net>
+Date: Wed, 26 May 2010 14:24:15 +0000
+Subject: Don't fail to browse the device if already mounted
+
+We don't need to have an error if the device is already mounted,
+just show it already!
+---
+diff --git a/applet/main.c b/applet/main.c
+index 5655a75..dd517c8 100644
+--- a/applet/main.c
++++ b/applet/main.c
+@@ -114,9 +114,16 @@ mount_finish_cb (GObject *source_object,
+
+ if (g_file_mount_enclosing_volume_finish (G_FILE (source_object),
+ res, &error) == FALSE) {
+- g_printerr ("Failed to mount OBEX volume: %s", error->message);
+- g_error_free (error);
+- return;
++ /* Ignore "already mounted" error */
++ if (error->domain == G_IO_ERROR &&
++ error->code == G_IO_ERROR_ALREADY_MOUNTED) {
++ g_error_free (error);
++ error = NULL;
++ } else {
++ g_printerr ("Failed to mount OBEX volume: %s", error->message);
++ g_error_free (error);
++ return;
++ }
+ }
+
+ uri = g_file_get_uri (G_FILE (source_object));
+--
+cgit v0.8.3.1
diff --git a/net-wireless/gnome-bluetooth/gnome-bluetooth-2.30.0.ebuild b/net-wireless/gnome-bluetooth/gnome-bluetooth-2.30.0.ebuild
new file mode 100644
index 000000000000..1d1f0d8fcf6c
--- /dev/null
+++ b/net-wireless/gnome-bluetooth/gnome-bluetooth-2.30.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/gnome-bluetooth/gnome-bluetooth-2.30.0.ebuild,v 1.1 2010/06/18 12:22:46 pacho Exp $
+
+EAPI="2"
+
+inherit gnome2 eutils
+
+DESCRIPTION="Fork of bluez-gnome focused on integration with GNOME"
+HOMEPAGE="http://live.gnome.org/GnomeBluetooth"
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="2"
+IUSE="doc nautilus"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+COMMON_DEPEND=">=dev-libs/glib-2.19.1
+ >=x11-libs/gtk+-2.19.1
+ >=x11-libs/libnotify-0.4.3
+ >=gnome-base/gconf-2.6
+ >=dev-libs/dbus-glib-0.74
+ dev-libs/libunique
+ nautilus? ( >=gnome-extra/nautilus-sendto-2.28.0.1[-bluetooth] )"
+RDEPEND="${COMMON_DEPEND}
+ >=net-wireless/bluez-4.34
+ app-mobilephone/obexd"
+DEPEND="${COMMON_DEPEND}
+ !!net-wireless/bluez-gnome
+ app-text/gnome-doc-utils
+ app-text/scrollkeeper
+ dev-libs/libxml2
+ dev-util/intltool
+ dev-util/pkgconfig
+ sys-devel/gettext
+ x11-libs/libX11
+ x11-libs/libXi
+ x11-proto/xproto
+ gnome-base/gnome-common
+ dev-util/gtk-doc-am
+ doc? ( >=dev-util/gtk-doc-1.9 )"
+
+DOCS="AUTHORS README NEWS ChangeLog"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ $(use_enable nautilus nautilus-sendto)
+ --disable-moblin
+ --disable-desktop-update
+ --disable-icon-update
+ --disable-introspection"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Add pin code for BT-GPS8 JENTRO
+ epatch "${FILESDIR}/${P}-add-pin.patch"
+
+ # Don't fail to browse the device if already mounted
+ epatch "${FILESDIR}/${P}-mounted-failure.patch"
+}
diff --git a/net-wireless/gnome-bluetooth/metadata.xml b/net-wireless/gnome-bluetooth/metadata.xml
index 005e4261aa01..2e75dd9e50f5 100644
--- a/net-wireless/gnome-bluetooth/metadata.xml
+++ b/net-wireless/gnome-bluetooth/metadata.xml
@@ -4,4 +4,7 @@
<herd>mobile</herd>
<herd>pda</herd>
<herd>gnome</herd>
+<use>
+ <flag name='nautilus'>Build nautilus-sendto plugin</flag>
+</use>
</pkgmetadata>