summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2012-12-27 04:53:40 +0000
committerRick Farina <zerochaos@gentoo.org>2012-12-27 04:53:40 +0000
commit38fdda1da306c16c97b53782279eb7c9b03ab83c (patch)
treee1a0335620fbb3c47dd21da296a615e3e1b07922 /net-wireless/uhd
parentDrop sparc and amd64-fbsd keywords, needs at-spi2-atk to be keyworded. (diff)
downloadgentoo-2-38fdda1da306c16c97b53782279eb7c9b03ab83c.tar.gz
gentoo-2-38fdda1da306c16c97b53782279eb7c9b03ab83c.tar.bz2
gentoo-2-38fdda1da306c16c97b53782279eb7c9b03ab83c.zip
version bump to 3.5.0
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key DD11F94A)
Diffstat (limited to 'net-wireless/uhd')
-rw-r--r--net-wireless/uhd/ChangeLog7
-rw-r--r--net-wireless/uhd/uhd-3.5.0.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/net-wireless/uhd/ChangeLog b/net-wireless/uhd/ChangeLog
index 4d7c57a1213c..b377d8344c7d 100644
--- a/net-wireless/uhd/ChangeLog
+++ b/net-wireless/uhd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-wireless/uhd
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/uhd/ChangeLog,v 1.5 2012/10/18 17:33:05 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/uhd/ChangeLog,v 1.6 2012/12/27 04:53:40 zerochaos Exp $
+
+*uhd-3.5.0 (27 Dec 2012)
+
+ 27 Dec 2012; Rick Farina <zerochaos@gentoo.org> +uhd-3.5.0.ebuild:
+ version bump to 3.5.0
*uhd-3.4.3-r2 (18 Oct 2012)
diff --git a/net-wireless/uhd/uhd-3.5.0.ebuild b/net-wireless/uhd/uhd-3.5.0.ebuild
new file mode 100644
index 000000000000..7fe08313ad70
--- /dev/null
+++ b/net-wireless/uhd/uhd-3.5.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/uhd/uhd-3.5.0.ebuild,v 1.1 2012/12/27 04:53:40 zerochaos Exp $
+
+EAPI=4
+PYTHON_DEPEND="2:2.6"
+inherit versionator python cmake-utils
+
+DESCRIPTION="Universal Software Radio Peripheral (USRP) Hardware Driver"
+HOMEPAGE="http://code.ettus.com/redmine/ettus/projects/uhd/wiki"
+
+image_version=uhd-images_00$(get_version_component_range 1).00$(get_version_component_range 2).000-release
+SRC_URI="https://github.com/EttusResearch/UHD-Mirror/tarball/release_00$(get_version_component_range 1)_00$(get_version_component_range 2)_00$(get_version_component_range 3) -> EttusResearch-UHD-Mirror-$(get_version_component_range 1).$(get_version_component_range 2).$(get_version_component_range 3).tar.gz \
+ http://files.ettus.com/binaries/maint_images/archive/${image_version}.tar.gz"
+#https://github.com/EttusResearch/UHD-Mirror/tags
+#http://files.ettus.com/binaries/master_images/archive
+KEYWORDS="~amd64 ~x86"
+S="${WORKDIR}"/EttusResearch-UHD-Mirror-6ef9f96/host
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+RDEPEND="virtual/libusb:1
+ dev-libs/boost"
+DEPEND="${RDEPEND}
+ dev-python/cheetah"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ #this may not be needed in 3.4.3 and above, please verify
+ sed -i 's#SET(PKG_LIB_DIR ${PKG_DATA_DIR})#SET(PKG_LIB_DIR ${LIBRARY_DIR}/uhd)#g' CMakeLists.txt
+}
+
+src_install() {
+ cmake-utils_src_install
+ insinto /lib/udev/rules.d/
+ doins "${S}"/utils/uhd-usrp.rules
+ insinto /usr/share/${PN}
+ doins -r "${WORKDIR}"/"${image_version}"/share/uhd/images
+}