summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2012-10-09 21:08:50 +0000
committerRick Farina <zerochaos@gentoo.org>2012-10-09 21:08:50 +0000
commitf63b1692f64e5b4309c5d6476ca31a4faab49418 (patch)
treee0d5ebdadc03e21f1c2b55cfc0bee670fbff1fbf /net-wireless/uhd
parentUpdate to reflect app-emulation/qemu-kvm -> app-emulation/qemu move. (diff)
downloadgentoo-2-f63b1692f64e5b4309c5d6476ca31a4faab49418.tar.gz
gentoo-2-f63b1692f64e5b4309c5d6476ca31a4faab49418.tar.bz2
gentoo-2-f63b1692f64e5b4309c5d6476ca31a4faab49418.zip
so it seems uhd wasn't being properly installed at all, thanks to mossman for telling me and making me fix this silly little bug
(Portage version: 2.1.11.24/cvs/Linux x86_64)
Diffstat (limited to 'net-wireless/uhd')
-rw-r--r--net-wireless/uhd/ChangeLog8
-rw-r--r--net-wireless/uhd/uhd-3.4.3-r1.ebuild38
2 files changed, 45 insertions, 1 deletions
diff --git a/net-wireless/uhd/ChangeLog b/net-wireless/uhd/ChangeLog
index aafee6a6d9a8..666dd820557d 100644
--- a/net-wireless/uhd/ChangeLog
+++ b/net-wireless/uhd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-wireless/uhd
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/uhd/ChangeLog,v 1.3 2012/09/10 03:33:34 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/uhd/ChangeLog,v 1.4 2012/10/09 21:08:50 zerochaos Exp $
+
+*uhd-3.4.3-r1 (09 Oct 2012)
+
+ 09 Oct 2012; Rick Farina <zerochaos@gentoo.org> +uhd-3.4.3-r1.ebuild:
+ so it seems uhd wasn't being properly installed at all, thanks to mossman for
+ telling me and making me fix this silly little bug
10 Sep 2012; Rick Farina <zerochaos@gentoo.org> uhd-3.4.3.ebuild:
radhermit points out that commits are free and I'm being lame by not saving
diff --git a/net-wireless/uhd/uhd-3.4.3-r1.ebuild b/net-wireless/uhd/uhd-3.4.3-r1.ebuild
new file mode 100644
index 000000000000..696c1b0168fa
--- /dev/null
+++ b/net-wireless/uhd/uhd-3.4.3-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/uhd/uhd-3.4.3-r1.ebuild,v 1.1 2012/10/09 21:08:50 zerochaos Exp $
+
+EAPI=4
+PYTHON_DEPEND="2:2.6"
+inherit versionator python cmake-utils
+
+DESCRIPTION="Universal Software Radio Peripheral (USRP) Hardware Driver"
+HOMEPAGE="http://code.ettus.com/redmine/ettus/projects/uhd/wiki"
+
+SRC_URI="https://github.com/EttusResearch/UHD-Mirror/tarball/release_00$(get_version_component_range 1)_00$(get_version_component_range 2)_00$(get_version_component_range 3) -> EttusResearch-UHD-Mirror-$(get_version_component_range 1).$(get_version_component_range 2).$(get_version_component_range 3).tar.gz \
+ http://files.ettus.com/binaries/maint_images/archive/uhd-images_00$(get_version_component_range 1).00$(get_version_component_range 2).002-12-geb083300.tar.gz"
+#https://github.com/EttusResearch/UHD-Mirror/tags
+#http://files.ettus.com/binaries/master_images/archive
+KEYWORDS="~amd64 ~x86"
+S="${WORKDIR}"/EttusResearch-UHD-Mirror-6047010/host
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+RDEPEND="virtual/libusb:1
+ dev-libs/boost"
+DEPEND="${RDEPEND}
+ dev-python/cheetah"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_install() {
+ cmake-utils_src_install
+ insinto /lib/udev/rules.d/
+ doins "${S}"/utils/uhd-usrp.rules
+ insinto /usr/share/${PN}
+ doins -r "${WORKDIR}"/uhd-images_00$(get_version_component_range 1).00$(get_version_component_range 2).002-12-geb083300/share/uhd/images
+}