summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBjarke Istrup Pedersen <gurligebis@gentoo.org>2009-02-26 22:03:01 +0000
committerBjarke Istrup Pedersen <gurligebis@gentoo.org>2009-02-26 22:03:01 +0000
commit2071af2878ec19b5fc6e61c423816aac8fdc6c2d (patch)
treee743412ceef1b46f23e305f7c8bb4628787428e4 /net-wireless
parentversion bump; clean old; fixes bug #260183 (diff)
downloadgentoo-2-2071af2878ec19b5fc6e61c423816aac8fdc6c2d.tar.gz
gentoo-2-2071af2878ec19b5fc6e61c423816aac8fdc6c2d.tar.bz2
gentoo-2-2071af2878ec19b5fc6e61c423816aac8fdc6c2d.zip
Adding support for 802.11n and removing stable flags from 0.6.7, since
it is still from the development branch. (Portage version: 2.2_rc23/cvs/Linux i686)
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/hostapd/ChangeLog7
-rw-r--r--net-wireless/hostapd/hostapd-0.6.7.ebuild5
-rw-r--r--net-wireless/hostapd/hostapd-0.6.8.ebuild3
3 files changed, 11 insertions, 4 deletions
diff --git a/net-wireless/hostapd/ChangeLog b/net-wireless/hostapd/ChangeLog
index bbfdeb0dca16..25d65d42ed6a 100644
--- a/net-wireless/hostapd/ChangeLog
+++ b/net-wireless/hostapd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-wireless/hostapd
# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/ChangeLog,v 1.92 2009/02/25 21:50:01 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/ChangeLog,v 1.93 2009/02/26 22:03:01 gurligebis Exp $
+
+ 27 Feb 2009; Bjarke Istrup Pedersen <gurligebis@gentoo.org>
+ hostapd-0.6.7.ebuild, hostapd-0.6.8.ebuild:
+ Adding support for 802.11n and removing stable flags from 0.6.7, since it
+ is still from the development branch.
25 Feb 2009; Markus Meier <maekke@gentoo.org> hostapd-0.6.7.ebuild:
amd64/x86 stable, bug #259285
diff --git a/net-wireless/hostapd/hostapd-0.6.7.ebuild b/net-wireless/hostapd/hostapd-0.6.7.ebuild
index 3e7f621e8466..fcfa076c51bf 100644
--- a/net-wireless/hostapd/hostapd-0.6.7.ebuild
+++ b/net-wireless/hostapd/hostapd-0.6.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/hostapd-0.6.7.ebuild,v 1.2 2009/02/25 21:50:01 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/hostapd-0.6.7.ebuild,v 1.3 2009/02/26 22:03:01 gurligebis Exp $
inherit toolchain-funcs linux-info
@@ -10,7 +10,7 @@ SRC_URI="http://hostap.epitest.fi/releases/${P}.tar.gz"
LICENSE="|| ( GPL-2 BSD )"
SLOT="0"
-KEYWORDS="amd64 ~ppc x86"
+KEYWORDS="~amd64 ~ppc ~x86"
IUSE="ipv6 logwatch madwifi ssl wps"
DEPEND="ssl? ( dev-libs/openssl )
@@ -94,6 +94,7 @@ generate_config() {
echo "CONFIG_IAPP=y" >> ${CONFIG}
echo "CONFIG_IEEE80211R=y" >> ${CONFIG}
echo "CONFIG_IEEE80211W=y" >> ${CONFIG}
+ echo "CONFIG_IEEE80211N=y" >> ${CONFIG}
echo "CONFIG_PEERKEY=y" >> ${CONFIG}
echo "CONFIG_RSN_PREAUTH=y" >> ${CONFIG}
diff --git a/net-wireless/hostapd/hostapd-0.6.8.ebuild b/net-wireless/hostapd/hostapd-0.6.8.ebuild
index 264be4ffbe22..4b96f0c97892 100644
--- a/net-wireless/hostapd/hostapd-0.6.8.ebuild
+++ b/net-wireless/hostapd/hostapd-0.6.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/hostapd-0.6.8.ebuild,v 1.1 2009/02/16 21:58:11 gurligebis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/hostapd-0.6.8.ebuild,v 1.2 2009/02/26 22:03:01 gurligebis Exp $
inherit toolchain-funcs linux-info
@@ -43,6 +43,7 @@ generate_config() {
if use wps; then
# Enable Wi-Fi Protected Setup
echo "CONFIG_WPS=y" >> ${CONFIG}
+ echo "CONFIG_WPS_UPNP=y" >> ${CONFIG}
einfo "Enabling Wi-Fi Protected Setup support"
fi