summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-01-29 23:05:12 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-01-29 23:05:12 +0000
commit22dde114ef34055f8a31f39463c22ffd32980071 (patch)
tree4bed537824730434efe84a6b1f140da1761f3087 /net-wireless
parentNew and spiffy version of the old eclass. (diff)
downloadgentoo-2-22dde114ef34055f8a31f39463c22ffd32980071.tar.gz
gentoo-2-22dde114ef34055f8a31f39463c22ffd32980071.tar.bz2
gentoo-2-22dde114ef34055f8a31f39463c22ffd32980071.zip
Fix parallel make, bug #235991. Fix effectless sed. Remove old revisions.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/libbtctl/ChangeLog11
-rw-r--r--net-wireless/libbtctl/files/libbtctl-0.10.0-parallel-make.patch57
-rw-r--r--net-wireless/libbtctl/files/libbtctl-0.6.0-aclocal_openobex.patch67
-rw-r--r--net-wireless/libbtctl/files/libbtctl-0.6.0-libdir.patch11
-rw-r--r--net-wireless/libbtctl/libbtctl-0.10.0.ebuild17
-rw-r--r--net-wireless/libbtctl/libbtctl-0.6.0-r1.ebuild53
-rw-r--r--net-wireless/libbtctl/libbtctl-0.8.1.ebuild54
-rw-r--r--net-wireless/libbtctl/libbtctl-0.8.2.ebuild54
8 files changed, 76 insertions, 248 deletions
diff --git a/net-wireless/libbtctl/ChangeLog b/net-wireless/libbtctl/ChangeLog
index 9c8011ad789a..c6688a258968 100644
--- a/net-wireless/libbtctl/ChangeLog
+++ b/net-wireless/libbtctl/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-wireless/libbtctl
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/libbtctl/ChangeLog,v 1.43 2008/04/17 19:31:54 jer Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/libbtctl/ChangeLog,v 1.44 2009/01/29 23:05:11 eva Exp $
+
+ 30 Jan 2009; Gilles Dartiguelongue <eva@gentoo.org>
+ -files/libbtctl-0.6.0-aclocal_openobex.patch,
+ -files/libbtctl-0.6.0-libdir.patch,
+ +files/libbtctl-0.10.0-parallel-make.patch, -libbtctl-0.6.0-r1.ebuild,
+ -libbtctl-0.8.1.ebuild, -libbtctl-0.8.2.ebuild, libbtctl-0.10.0.ebuild:
+ Fix parallel make, bug #235991. Fix effectless sed. Remove old revisions.
17 Apr 2008; Jeroen Roovers <jer@gentoo.org> libbtctl-0.10.0.ebuild:
Marked ~hppa too.
diff --git a/net-wireless/libbtctl/files/libbtctl-0.10.0-parallel-make.patch b/net-wireless/libbtctl/files/libbtctl-0.10.0-parallel-make.patch
new file mode 100644
index 000000000000..bcdc70e976be
--- /dev/null
+++ b/net-wireless/libbtctl/files/libbtctl-0.10.0-parallel-make.patch
@@ -0,0 +1,57 @@
+Index: libbtctl-0.10.0/src/Makefile.am
+===================================================================
+--- libbtctl-0.10.0.orig/src/Makefile.am
++++ libbtctl-0.10.0/src/Makefile.am
+@@ -37,27 +37,27 @@ obex_server_source_test_LDADD = \
+ libbtctl.la \
+ $(BTCTL_LIBS) $(BLUETOOTH_LIBS) $(OPENOBEX_LIBS)
+
+-btctl_async_test_LDFLAGS= \
++btctl_async_test_LDADD = \
+ libbtctl.la $(BTCTL_LIBS) \
+ $(BLUETOOTH_LIBS) $(OPENOBEX_LIBS)
+
+-btobexclient_test_LDFLAGS= \
++btobexclient_test_LDADD = \
+ libbtctl.la $(BTCTL_LIBS) \
+ $(BLUETOOTH_LIBS) $(OPENOBEX_LIBS)
+
+-btobex_test_LDFLAGS= \
++btobex_test_LDADD = \
+ libbtctl.la $(BTCTL_LIBS) \
+ $(BLUETOOTH_LIBS) $(OPENOBEX_LIBS)
+
+-btctl_discovery_test_LDFLAGS= \
++btctl_discovery_test_LDADD = \
+ libbtctl.la $(BTCTL_LIBS) \
+ $(BLUETOOTH_LIBS) $(OPENOBEX_LIBS)
+
+-btlist_LDFLAGS = \
++btlist_LDADD = \
+ libbtctl.la $(BTCTL_LIBS) \
+ $(BLUETOOTH_LIBS) $(OPENOBEX_LIBS)
+
+-btsignal_watch_LDFLAGS = \
++btsignal_watch_LDADD = \
+ libbtctl.la $(BTCTL_LIBS) \
+ $(BLUETOOTH_LIBS) $(OPENOBEX_LIBS)
+
+@@ -80,7 +80,8 @@ pkginclude_HEADERS = \
+ btobex-client.h btctl-types.h
+
+ libbtctl_la_LDFLAGS = \
+- -version-info $(BTCTL_LT_VERSION) \
++ -version-info $(BTCTL_LT_VERSION)
++libbtctl_la_LIBADD = \
+ $(BTCTL_LIBS) $(BLUETOOTH_LIBS) $(OPENOBEX_LIBS)
+
+
+@@ -123,6 +124,7 @@ btctl-py.c: btctl.defs btctl.override
+
+ btctl_la_SOURCES = btctl-py.c btctl-pymodule.c
+ btctl_la_LIBADD = libbtctl.la
+-btctl_la_LDFLAGS = $(BTCTLPY_LIBS) -module -avoid-version
++btctl_la_LDFLAGS = -module -avoid-version
++btctl_la_LIBADD = $(BTCTLPY_LIBS)
+ endif
+
diff --git a/net-wireless/libbtctl/files/libbtctl-0.6.0-aclocal_openobex.patch b/net-wireless/libbtctl/files/libbtctl-0.6.0-aclocal_openobex.patch
deleted file mode 100644
index 28d2094288d8..000000000000
--- a/net-wireless/libbtctl/files/libbtctl-0.6.0-aclocal_openobex.patch
+++ /dev/null
@@ -1,67 +0,0 @@
-diff -Nru libbtctl-0.6.0.orig/aclocal.m4 libbtctl-0.6.0/aclocal.m4
---- libbtctl-0.6.0.orig/aclocal.m4 2005-11-22 00:02:42.000000000 +0200
-+++ libbtctl-0.6.0/aclocal.m4 2006-04-22 12:13:21.922401250 +0300
-@@ -8268,63 +8268,3 @@
- ifelse([$4], , AC_MSG_ERROR([Library requirements ($2) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.]), [$4])
- fi
- ])
--
--
--
--dnl Check for openobex library
--dnl Written by Pontus Fuchs 2000-08-18
--dnl Version checking fixed by Christian W. Zuckschwerdt 2002-10-17
--
--AC_DEFUN([AM_PATH_OPENOBEX], [
-- AC_PATH_PROG(OPENOBEX_CONFIG, openobex-config, no)
--
-- if test "$OPENOBEX_CONFIG" = "no" ; then
-- AC_MSG_ERROR(openobex-config not found. Pehaps openobex is not installed.)
-- fi
--
-- min_obex_version=ifelse([$1], ,0.9.6,$1)
-- AC_MSG_CHECKING(for openobex - version >= $min_obex_version)
--
-- OPENOBEX_CFLAGS=`$OPENOBEX_CONFIG --cflags`
-- OPENOBEX_LIBS=`$OPENOBEX_CONFIG --libs`
--
-- obex_config_version=`$OPENOBEX_CONFIG --version`
--
-- obex_config_major_version=`$OPENOBEX_CONFIG --version | \
-- sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\1/'`
-- obex_config_minor_version=`$OPENOBEX_CONFIG --version | \
-- sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\2/'`
-- obex_config_micro_version=`$OPENOBEX_CONFIG --version | \
-- sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\3/'`
--
-- obex_req_major_version=`echo $min_obex_version | \
-- sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\1/'`
-- obex_req_minor_version=`echo $min_obex_version | \
-- sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\2/'`
-- obex_req_micro_version=`echo $min_obex_version | \
-- sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\3/'`
--
--
-- if test $obex_req_major_version -lt $obex_config_major_version ; then
-- obex_config_version_ok="yes"
-- fi
-- if test $obex_req_major_version -eq $obex_config_major_version ; then
-- if test $obex_req_minor_version -lt $obex_config_minor_version ; then
-- obex_config_version_ok="yes"
-- fi
-- if test $obex_req_minor_version -eq $obex_config_minor_version ; then
-- if test $obex_req_micro_version -le $obex_config_micro_version ; then
-- obex_config_version_ok="yes"
-- fi
-- fi
-- fi
--
-- if test "$obex_config_version_ok" != "yes" ; then
-- AC_MSG_ERROR(Installed openobex library too old ($obex_config_version))
-- fi
--
-- AC_SUBST(OPENOBEX_CFLAGS)
-- AC_SUBST(OPENOBEX_LIBS)
-- AC_MSG_RESULT(yes)
--])
--
diff --git a/net-wireless/libbtctl/files/libbtctl-0.6.0-libdir.patch b/net-wireless/libbtctl/files/libbtctl-0.6.0-libdir.patch
deleted file mode 100644
index 7a8eb85d8e2c..000000000000
--- a/net-wireless/libbtctl/files/libbtctl-0.6.0-libdir.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/Makefile.am 2005-08-16 21:18:14.000000000 +0200
-+++ src/Makefile.am 2006-08-29 14:45:51.000000000 +0200
-@@ -16,7 +16,7 @@
-
- lib_LTLIBRARIES = libbtctl.la
- if HAVE_PYTHON
--pydir = $(PYTHON_PREFIX)/lib/python$(PYTHON_VERSION)/site-packages/
-+pydir = $(PYTHON_PREFIX)/@@GENTOO_LIBDIR@@/python$(PYTHON_VERSION)/site-packages/
- py_LTLIBRARIES = btctl.la
- else
- pydir =
diff --git a/net-wireless/libbtctl/libbtctl-0.10.0.ebuild b/net-wireless/libbtctl/libbtctl-0.10.0.ebuild
index ebea93e045c0..d37caad41360 100644
--- a/net-wireless/libbtctl/libbtctl-0.10.0.ebuild
+++ b/net-wireless/libbtctl/libbtctl-0.10.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/libbtctl/libbtctl-0.10.0.ebuild,v 1.2 2008/04/17 19:31:54 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/libbtctl/libbtctl-0.10.0.ebuild,v 1.3 2009/01/29 23:05:11 eva Exp $
-inherit gnome2 multilib mono autotools
+inherit autotools gnome2 multilib mono
DESCRIPTION="A GObject wrapper for Bluetooth functionality"
HOMEPAGE="http://live.gnome.org/GnomeBluetooth"
@@ -30,7 +30,6 @@ DEPEND="${RDEPEND}
dev-util/pkgconfig
doc? ( dev-util/gtk-doc )"
-MAKEOPTS="${MAKEOPTS} -j1"
DOCS="README NEWS ChangeLog AUTHORS COPYING"
src_unpack() {
@@ -39,8 +38,11 @@ src_unpack() {
# Fix multilib
sed -e "s:\/lib\/:\/$(get_libdir)\/:" -i src/Makefile.am
+ # Fix parallel make, bug #235991
+ epatch "${FILESDIR}/${P}-parallel-make.patch"
+
# Fix tests (needed with eautoreconf)
- intltoolize --force
+ intltoolize --force --copy --automake || die "intltoolize failed"
eautoreconf
}
@@ -49,7 +51,8 @@ pkg_setup() {
}
src_compile() {
- sed -i -e 's/libext="a/& la/' libtool
+ gnome2_src_configure
- gnome2_src_compile
+ sed -e 's/libext="a/& la/' -i libtool || die "sed failed"
+ emake || die "compile failure"
}
diff --git a/net-wireless/libbtctl/libbtctl-0.6.0-r1.ebuild b/net-wireless/libbtctl/libbtctl-0.6.0-r1.ebuild
deleted file mode 100644
index 982a8a73d2a8..000000000000
--- a/net-wireless/libbtctl/libbtctl-0.6.0-r1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/libbtctl/libbtctl-0.6.0-r1.ebuild,v 1.6 2007/08/01 00:00:23 angelos Exp $
-
-inherit gnome2 eutils autotools multilib mono
-
-DESCRIPTION="A GObject wrapper for Bluetooth functionality"
-HOMEPAGE="http://usefulinc.com/software/gnome-bluetooth/"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc sparc x86"
-IUSE="mono doc"
-
-RDEPEND=">=dev-libs/glib-2
- >=net-wireless/bluez-utils-2.7
- >=net-wireless/bluez-libs-2.7
- >=dev-libs/openobex-1
- >=dev-lang/python-2.3
- >=dev-python/pygtk-2.0
- !sparc? (
- mono? (
- >=dev-lang/mono-0.96
- =dev-dotnet/gtk-sharp-1.0*
- )
- )"
-
-DEPEND="${RDEPEND}
- dev-util/intltool
- dev-util/pkgconfig
- doc? ( dev-util/gtk-doc )"
-
-MAKEOPTS="${MAKEOPTS} -j1"
-DOCS="README NEWS ChangeLog AUTHORS COPYING"
-USE_DESTDIR="yes"
-
-src_unpack() {
- unpack ${A}
-
- cd "${S}"
- epatch "${FILESDIR}/${P}-libdir.patch"
- epatch "${FILESDIR}/${P}-aclocal_openobex.patch"
-
- sed -e "s:@@GENTOO_LIBDIR@@:$(get_libdir):" -i src/Makefile.am
- eautoreconf
-}
-
-src_compile() {
- use sparc || G2CONF=$(use_enable mono)
- gnome2_src_configure
- sed -i -e 's/libext="a/& la/' libtool
- emake || die "make failed"
-}
diff --git a/net-wireless/libbtctl/libbtctl-0.8.1.ebuild b/net-wireless/libbtctl/libbtctl-0.8.1.ebuild
deleted file mode 100644
index 036ac2c35536..000000000000
--- a/net-wireless/libbtctl/libbtctl-0.8.1.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/libbtctl/libbtctl-0.8.1.ebuild,v 1.3 2006/11/05 21:30:38 peper Exp $
-
-WANT_AUTOMAKE="latest"
-WANT_AUTOCONF="latest"
-
-inherit gnome2 multilib mono autotools
-
-DESCRIPTION="A GObject wrapper for Bluetooth functionality"
-HOMEPAGE="http://live.gnome.org/GnomeBluetooth"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="mono doc"
-
-RDEPEND=">=dev-libs/glib-2
- >=net-wireless/bluez-utils-2.25
- >=net-wireless/bluez-libs-2.25
- >=dev-libs/openobex-1.2
- >=dev-lang/python-2.3
- >=dev-python/pygtk-2.0
- !sparc? (
- mono? (
- >=dev-lang/mono-0.96
- =dev-dotnet/gtk-sharp-1.0*
- )
- )"
-
-DEPEND="${RDEPEND}
- dev-util/intltool
- dev-util/pkgconfig
- doc? ( dev-util/gtk-doc )"
-
-MAKEOPTS="${MAKEOPTS} -j1"
-DOCS="README NEWS ChangeLog AUTHORS COPYING"
-USE_DESTDIR="yes"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # Fix multilib
- sed -e "s:\/lib\/:\/$(get_libdir)\/:" -i src/Makefile.am
- eautoreconf
-}
-
-src_compile() {
- use sparc || G2CONF=$(use_enable mono)
- gnome2_src_configure
- sed -i -e 's/libext="a/& la/' libtool
- emake || die "make failed"
-}
diff --git a/net-wireless/libbtctl/libbtctl-0.8.2.ebuild b/net-wireless/libbtctl/libbtctl-0.8.2.ebuild
deleted file mode 100644
index e6305f182a26..000000000000
--- a/net-wireless/libbtctl/libbtctl-0.8.2.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/libbtctl/libbtctl-0.8.2.ebuild,v 1.1 2007/04/24 03:47:33 seemant Exp $
-
-WANT_AUTOMAKE="latest"
-WANT_AUTOCONF="latest"
-
-inherit gnome2 multilib mono autotools
-
-DESCRIPTION="A GObject wrapper for Bluetooth functionality"
-HOMEPAGE="http://live.gnome.org/GnomeBluetooth"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="mono doc"
-
-RDEPEND=">=dev-libs/glib-2
- >=net-wireless/bluez-utils-2.25
- >=net-wireless/bluez-libs-2.25
- >=dev-libs/openobex-1.2
- >=dev-lang/python-2.3
- >=dev-python/pygtk-2.0
- !sparc? (
- mono? (
- >=dev-lang/mono-0.96
- =dev-dotnet/gtk-sharp-1.0*
- )
- )"
-
-DEPEND="${RDEPEND}
- dev-util/intltool
- dev-util/pkgconfig
- doc? ( dev-util/gtk-doc )"
-
-MAKEOPTS="${MAKEOPTS} -j1"
-DOCS="README NEWS ChangeLog AUTHORS COPYING"
-USE_DESTDIR="yes"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # Fix multilib
- sed -e "s:\/lib\/:\/$(get_libdir)\/:" -i src/Makefile.am
- eautoreconf
-}
-
-src_compile() {
- use sparc || G2CONF=$(use_enable mono)
- gnome2_src_configure
- sed -i -e 's/libext="a/& la/' libtool
- emake || die "make failed"
-}