summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2006-11-10 14:39:30 +0000
committerRoy Marples <uberlord@gentoo.org>2006-11-10 14:39:30 +0000
commitdb867f3e39f8c4c263cb2528b405139cafbbe2a2 (patch)
tree0fa05a3798549a98e437b8160fce1856eb84571d /net-wireless
parentStable on x86, bug #152916. (diff)
downloadgentoo-2-db867f3e39f8c4c263cb2528b405139cafbbe2a2.tar.gz
gentoo-2-db867f3e39f8c4c263cb2528b405139cafbbe2a2.tar.bz2
gentoo-2-db867f3e39f8c4c263cb2528b405139cafbbe2a2.zip
Added a patch to display the 'PF_UNIX: Address in use' only when an error
occurs that we cannot resolve. (Portage version: 2.1.2_rc1-r5)
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/wpa_supplicant/ChangeLog8
-rw-r--r--net-wireless/wpa_supplicant/files/wpa_supplicant-0.5.5-inuse-warning.patch18
-rw-r--r--net-wireless/wpa_supplicant/wpa_supplicant-0.5.5.ebuild5
3 files changed, 29 insertions, 2 deletions
diff --git a/net-wireless/wpa_supplicant/ChangeLog b/net-wireless/wpa_supplicant/ChangeLog
index 1f1521a87b61..2235b694bbe0 100644
--- a/net-wireless/wpa_supplicant/ChangeLog
+++ b/net-wireless/wpa_supplicant/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-wireless/wpa_supplicant
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/ChangeLog,v 1.82 2006/11/07 10:36:54 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/ChangeLog,v 1.83 2006/11/10 14:39:30 uberlord Exp $
+
+ 10 Nov 2006; Roy Marples <uberlord@gentoo.org>
+ +files/wpa_supplicant-0.5.5-inuse-warning.patch,
+ wpa_supplicant-0.5.5.ebuild:
+ Added a patch to display the 'PF_UNIX: Address in use' only when an error
+ occurs that we cannot resolve.
07 Nov 2006; Roy Marples <uberlord@gentoo.org>
wpa_supplicant-0.5.5.ebuild:
diff --git a/net-wireless/wpa_supplicant/files/wpa_supplicant-0.5.5-inuse-warning.patch b/net-wireless/wpa_supplicant/files/wpa_supplicant-0.5.5-inuse-warning.patch
new file mode 100644
index 000000000000..cf25a6a04494
--- /dev/null
+++ b/net-wireless/wpa_supplicant/files/wpa_supplicant-0.5.5-inuse-warning.patch
@@ -0,0 +1,18 @@
+--- ctrl_iface_unix.c 2006-11-10 14:14:21.686328744 +0000
++++ ctrl_iface_unix.c 2006-11-10 14:15:11.000000000 +0000
+@@ -321,7 +321,6 @@
+ goto fail;
+ strncpy(addr.sun_path, fname, sizeof(addr.sun_path));
+ if (bind(priv->sock, (struct sockaddr *) &addr, sizeof(addr)) < 0) {
+- perror("bind(PF_UNIX)");
+ if (connect(priv->sock, (struct sockaddr *) &addr,
+ sizeof(addr)) < 0) {
+ wpa_printf(MSG_DEBUG, "ctrl_iface exists, but does not"
+@@ -342,6 +341,7 @@
+ wpa_printf(MSG_DEBUG, "Successfully replaced leftover "
+ "ctrl_iface socket '%s'", fname);
+ } else {
++ perror("bind(PF_UNIX)");
+ wpa_printf(MSG_INFO, "ctrl_iface exists and seems to "
+ "be in use - cannot override it");
+ wpa_printf(MSG_INFO, "Delete '%s' manually if it is "
diff --git a/net-wireless/wpa_supplicant/wpa_supplicant-0.5.5.ebuild b/net-wireless/wpa_supplicant/wpa_supplicant-0.5.5.ebuild
index 62d842e9b549..f3d63e7b65b7 100644
--- a/net-wireless/wpa_supplicant/wpa_supplicant-0.5.5.ebuild
+++ b/net-wireless/wpa_supplicant/wpa_supplicant-0.5.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/wpa_supplicant-0.5.5.ebuild,v 1.11 2006/11/07 10:36:54 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/wpa_supplicant-0.5.5.ebuild,v 1.12 2006/11/10 14:39:30 uberlord Exp $
inherit eutils toolchain-funcs
@@ -53,6 +53,9 @@ src_unpack() {
# Change the default driver to wext for Linux systems.
epatch "${FILESDIR}/${P}-default_driver.patch"
+ # Move the PF_UNIX: Address in use warning to where it's needed
+ epatch "${FILESDIR}/${P}-inuse-warning.patch"
+
# net/bpf.h needed for net-libs/libpcap on Gentoo FreeBSD
sed -i \
-e "s:\(#include <pcap\.h>\):#include <net/bpf.h>\n\1:" \