summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-10-17 04:27:08 +0000
committerMike Frysinger <vapier@gentoo.org>2003-10-17 04:27:08 +0000
commite9acfd2cf7c916cbdb7eb02191ddb7c9878c05c8 (patch)
tree3c9503b659ee2bbb32df66f661685689caaabacd /net-www/dillo
parentoops, make all arches require db < 2 (diff)
downloadgentoo-2-e9acfd2cf7c916cbdb7eb02191ddb7c9878c05c8.tar.gz
gentoo-2-e9acfd2cf7c916cbdb7eb02191ddb7c9878c05c8.tar.bz2
gentoo-2-e9acfd2cf7c916cbdb7eb02191ddb7c9878c05c8.zip
touchups
Diffstat (limited to 'net-www/dillo')
-rw-r--r--net-www/dillo/dillo-0.7.3-r1.ebuild30
-rw-r--r--net-www/dillo/dillo-0.7.3-r2.ebuild36
2 files changed, 25 insertions, 41 deletions
diff --git a/net-www/dillo/dillo-0.7.3-r1.ebuild b/net-www/dillo/dillo-0.7.3-r1.ebuild
index b699fc71a1b4..8f1b3a57a1e9 100644
--- a/net-www/dillo/dillo-0.7.3-r1.ebuild
+++ b/net-www/dillo/dillo-0.7.3-r1.ebuild
@@ -1,24 +1,21 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/dillo/dillo-0.7.3-r1.ebuild,v 1.4 2003/10/17 04:24:59 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/dillo/dillo-0.7.3-r1.ebuild,v 1.5 2003/10/17 04:27:08 vapier Exp $
inherit flag-o-matic
-IUSE="ipv6 kde gnome mozilla"
-
-S=${WORKDIR}/${P}
S2=${WORKDIR}/dillo-gentoo-extras-patch3
DESCRIPTION="Lean GTK+-based web browser"
-HOMEPAGE="http://dillo.auriga.wearlab.de/"
+HOMEPAGE="http://www.dillo.org/"
SRC_URI="http://www.dillo.org/download/${P}.tar.bz2
mirror://gentoo/dillo-gentoo-extras-patch3.tar.bz2"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86 ppc sparc alpha ~mips ~hppa"
+IUSE="ipv6 kde gnome mozilla"
-replace-flags "-O2 -mcpu=k6" "-O2 -mcpu=pentium"
DEPEND="=x11-libs/gtk+-1.2*
>=media-libs/jpeg-6b
@@ -31,36 +28,31 @@ src_unpack() {
if [ "${DILLO_ICONSET}" = "kde" ]
then
- ebegin "Using Konqueror style icon set"
+ einfo "Using Konqueror style icon set"
cp ${S2}/pixmaps.konq.h ${S}/src/pixmaps.h
- eend 0
elif [ "${DILLO_ICONSET}" = "gnome" ]
then
- ebegin "Using Ximian style icon set"
+ einfo "Using Ximian style icon set"
cp ${S2}/pixmaps.ximian.h ${S}/src/pixmaps.h
- eend 0
elif [ "${DILLO_ICONSET}" = "mozilla" ]
then
- ebegin "Using Netscape style icon set"
+ einfo "Using Netscape style icon set"
cp ${S2}/pixmaps.netscape.h ${S}/src/pixmaps.h
- eend 0
elif [ "${DILLO_ICONSET}" = "bold" ]
then
- ebegin "Using bold style icon set"
+ einfo "Using bold style icon set"
cp ${S2}/pixmaps.bold.h ${S}/src/pixmaps.h
- eend 0
elif [ "${DILLO_ICONSET}" = "trans" ]
then
- ebegin "Using transparent style icon set"
+ einfo "Using transparent style icon set"
cp ${S2}/pixmaps.trans.h ${S}/src/pixmaps.h
- eend 0
else
- ebegin "Using default Dillo icon set"
- eend 0
+ einfo "Using default Dillo icon set"
fi
}
src_compile() {
+ replace-flags "-O2 -mcpu=k6" "-O2 -mcpu=pentium"
econf `use_enable ipv6` || die
emake || make || die
}
diff --git a/net-www/dillo/dillo-0.7.3-r2.ebuild b/net-www/dillo/dillo-0.7.3-r2.ebuild
index bfcc6ee42b9f..b088e653b8cf 100644
--- a/net-www/dillo/dillo-0.7.3-r2.ebuild
+++ b/net-www/dillo/dillo-0.7.3-r2.ebuild
@@ -1,28 +1,24 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/dillo/dillo-0.7.3-r2.ebuild,v 1.1 2003/10/12 12:54:51 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/dillo/dillo-0.7.3-r2.ebuild,v 1.2 2003/10/17 04:27:08 vapier Exp $
inherit flag-o-matic
-# Note that truetype, ssl and nls IUSE flags will take effect
-# only if you enable cjk IUSE flag.
-IUSE="ipv6 kde gnome mozilla truetype ssl cjk nls"
-
-S=${WORKDIR}/${P}
S2=${WORKDIR}/dillo-gentoo-extras-patch3
I18N_P=${P}-i18n-misc-20031012
DESCRIPTION="Lean GTK+-based web browser"
-HOMEPAGE="http://dillo.auriga.wearlab.de/"
+HOMEPAGE="http://www.dillo.org/"
SRC_URI="http://www.dillo.org/download/${P}.tar.bz2
mirror://gentoo/dillo-gentoo-extras-patch3.tar.bz2
cjk? ( http://teki.jpn.ph/pc/software/${I18N_P}.diff.bz2 )"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa"
-
-replace-flags "-O2 -mcpu=k6" "-O2 -mcpu=pentium"
+# Note that truetype, ssl and nls IUSE flags will take effect
+# only if you enable cjk IUSE flag.
+IUSE="ipv6 kde gnome mozilla truetype ssl cjk nls"
DEPEND="=x11-libs/gtk+-1.2*
>=media-libs/jpeg-6b
@@ -37,36 +33,32 @@ src_unpack() {
if [ "${DILLO_ICONSET}" = "kde" ]
then
- ebegin "Using Konqueror style icon set"
+ einfo "Using Konqueror style icon set"
cp ${S2}/pixmaps.konq.h ${S}/src/pixmaps.h
- eend 0
elif [ "${DILLO_ICONSET}" = "gnome" ]
then
- ebegin "Using Ximian style icon set"
+ einfo "Using Ximian style icon set"
cp ${S2}/pixmaps.ximian.h ${S}/src/pixmaps.h
- eend 0
elif [ "${DILLO_ICONSET}" = "mozilla" ]
then
- ebegin "Using Netscape style icon set"
+ einfo "Using Netscape style icon set"
cp ${S2}/pixmaps.netscape.h ${S}/src/pixmaps.h
- eend 0
elif [ "${DILLO_ICONSET}" = "bold" ]
then
- ebegin "Using bold style icon set"
+ einfo "Using bold style icon set"
cp ${S2}/pixmaps.bold.h ${S}/src/pixmaps.h
- eend 0
elif [ "${DILLO_ICONSET}" = "trans" ]
then
- ebegin "Using transparent style icon set"
+ einfo "Using transparent style icon set"
cp ${S2}/pixmaps.trans.h ${S}/src/pixmaps.h
- eend 0
else
- ebegin "Using default Dillo icon set"
- eend 0
+ einfo "Using default Dillo icon set"
fi
}
src_compile() {
+ replace-flags "-O2 -mcpu=k6" "-O2 -mcpu=pentium"
+
local myconf
if [ -n "`use cjk`" ] ; then