summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2007-03-04 19:06:42 +0000
committerStefan Schweizer <genstef@gentoo.org>2007-03-04 19:06:42 +0000
commit439cf50946d2ab2fc5bd7a2e4439b01761ed94a8 (patch)
treef7e80946b85153be40855ffeec3ab06aedca690f /net-www/gnash
parentUpdate KDE_DERIVATION_MAP. (diff)
downloadgentoo-2-439cf50946d2ab2fc5bd7a2e4439b01761ed94a8.tar.gz
gentoo-2-439cf50946d2ab2fc5bd7a2e4439b01761ed94a8.tar.bz2
gentoo-2-439cf50946d2ab2fc5bd7a2e4439b01761ed94a8.zip
Add --disable-gnash thanks to g-ranquet <ranquet@imerir.com> in bug 169336
(Portage version: 2.1.2-r12)
Diffstat (limited to 'net-www/gnash')
-rw-r--r--net-www/gnash/ChangeLog5
-rw-r--r--net-www/gnash/files/digest-gnash-0.7.23
-rw-r--r--net-www/gnash/gnash-0.7.2.ebuild25
3 files changed, 23 insertions, 10 deletions
diff --git a/net-www/gnash/ChangeLog b/net-www/gnash/ChangeLog
index 0ad0c05ca214..5d7ce8bedc50 100644
--- a/net-www/gnash/ChangeLog
+++ b/net-www/gnash/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-www/gnash
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/gnash/ChangeLog,v 1.36 2007/02/23 12:38:46 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/gnash/ChangeLog,v 1.37 2007/03/04 19:06:42 genstef Exp $
+
+ 04 Mar 2007; <genstef@gentoo.org> ChangeLog:
+ Add --disable-gnash thanks to g-ranquet <ranquet@imerir.com> in bug 169336
23 Feb 2007; <genstef@gentoo.org> gnash-0.7.2_p20099999.ebuild:
Improve qt3 detection thanks to Sarath Menon <sarathmenon@gmail.com> in bug
diff --git a/net-www/gnash/files/digest-gnash-0.7.2 b/net-www/gnash/files/digest-gnash-0.7.2
index 449beee42c3f..e69de29bb2d1 100644
--- a/net-www/gnash/files/digest-gnash-0.7.2
+++ b/net-www/gnash/files/digest-gnash-0.7.2
@@ -1,3 +0,0 @@
-MD5 ccef0f45be01a4c2992b46c2363a514f gnash-0.7.2.tar.bz2 1599810
-RMD160 0f5904b6c13ffb3b2b4a5f723d9fdacb0a8a6198 gnash-0.7.2.tar.bz2 1599810
-SHA256 12dccb4bc69488f516e0283e988412ba7db5dfad32744425f97d641392a2e98b gnash-0.7.2.tar.bz2 1599810
diff --git a/net-www/gnash/gnash-0.7.2.ebuild b/net-www/gnash/gnash-0.7.2.ebuild
index ec0619b3109f..8ae9995c523b 100644
--- a/net-www/gnash/gnash-0.7.2.ebuild
+++ b/net-www/gnash/gnash-0.7.2.ebuild
@@ -1,17 +1,23 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/gnash/gnash-0.7.2.ebuild,v 1.6 2007/02/05 13:24:47 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/gnash/gnash-0.7.2.ebuild,v 1.7 2007/03/04 19:06:42 genstef Exp $
-inherit nsplugins kde-functions
+WANT_AUTOCONF=latest
+inherit nsplugins autotools cvs kde-functions qt3 multilib
set-kdedir
DESCRIPTION="Gnash is a GNU Flash movie player that supports many SWF v7 features"
HOMEPAGE="http://www.gnu.org/software/gnash"
-SRC_URI="mirror://gnu/${PN}/${PV}/${P}.tar.bz2"
+#SRC_URI="mirror://gnu/${PN}/${PV}/${P}.tar.bz2"
+ECVS_SERVER="cvs.sv.gnu.org:/sources/${PN}"
+ECVS_MODULE="${PN}"
+[ "${PV/0.7.2_p}" != "20099999" ] && ECVS_CO_OPTS="-D ${PV/0.7.2_p}"
+ECVS_UP_OPTS="-dP ${ECVS_CO_OPTS}"
+S=${WORKDIR}/${PN}
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~ppc -sparc ~x86 ~x86-fbsd"
+KEYWORDS=""
IUSE="agg gstreamer ffmpeg kde nsplugin xml video_cards_i810"
#dmalloc, broken see bug 142939
#dmalloc? ( dev-libs/dmalloc )
@@ -61,6 +67,7 @@ pkg_setup() {
}
src_compile() {
+ ./autogen.sh
local myconf
use nsplugin && myconf="${myconf} --with-plugindir=/opt/netscape/plugins"
@@ -90,14 +97,20 @@ src_compile() {
myconf="${myconf} --with-mp3-decoder=ffmpeg"
fi
+ if use kde; then
+ myconf="${myconf} --enable-klash --with-qt-incl=${QTDIR}/include
+ --with-qt-lib=${QTDIR}/$(get_libdir)"
+ else
+ myconf="${myconf} --disable-klash"
+ fi
+
econf \
$(use_enable nsplugin plugin) \
$(use_enable xml) \
$(use_enable video_cards_i810 i810-lod-bias) \
--without-gcc-arch \
- $(use_enable kde klash) \
${myconf} || die "econf failed"
- emake || die "emake failed"
+ emake -j1 || die "emake failed"
}
src_install() {