summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2007-11-21 09:41:17 +0000
committerStefan Schweizer <genstef@gentoo.org>2007-11-21 09:41:17 +0000
commit932d3e219ba415f44b23258ac31c1091134c6756 (patch)
tree2195f1e4c1f7518abdf7314854f447c860db4754 /net-www/gnash
parentadded hppa (diff)
downloadgentoo-2-932d3e219ba415f44b23258ac31c1091134c6756.tar.gz
gentoo-2-932d3e219ba415f44b23258ac31c1091134c6756.tar.bz2
gentoo-2-932d3e219ba415f44b23258ac31c1091134c6756.zip
change cvs ebuild to a stub to point to the cvs ebuild overlay made by Harley Peters <harley@thepetersclan.com> in bug 187444
(Portage version: 2.1.3.18)
Diffstat (limited to 'net-www/gnash')
-rw-r--r--net-www/gnash/ChangeLog6
-rw-r--r--net-www/gnash/gnash-9999.ebuild140
2 files changed, 12 insertions, 134 deletions
diff --git a/net-www/gnash/ChangeLog b/net-www/gnash/ChangeLog
index 53e38bbc9db3..4008ac8aa75d 100644
--- a/net-www/gnash/ChangeLog
+++ b/net-www/gnash/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-www/gnash
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/gnash/ChangeLog,v 1.51 2007/11/21 09:19:53 uid895 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/gnash/ChangeLog,v 1.52 2007/11/21 09:41:17 genstef Exp $
+
+ 21 Nov 2007; Stefan Schweizer <genstef@gentoo.org> gnash-9999.ebuild:
+ change cvs ebuild to a stub to point to the cvs ebuild overlay made by
+ Harley Peters <harley@thepetersclan.com> in bug 187444
*gnash-0.8.1 (21 Nov 2007)
diff --git a/net-www/gnash/gnash-9999.ebuild b/net-www/gnash/gnash-9999.ebuild
index fca3f4021a80..68593831e786 100644
--- a/net-www/gnash/gnash-9999.ebuild
+++ b/net-www/gnash/gnash-9999.ebuild
@@ -1,145 +1,19 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/gnash/gnash-9999.ebuild,v 1.5 2007/08/30 07:52:00 genstef Exp $
-
-WANT_AUTOCONF=latest
-inherit nsplugins autotools cvs kde-functions qt3 multilib
-set-kdedir
+# $Header: /var/cvsroot/gentoo-x86/net-www/gnash/gnash-9999.ebuild,v 1.6 2007/11/21 09:41:17 genstef Exp $
DESCRIPTION="Gnash is a GNU Flash movie player that supports many SWF v7 features"
HOMEPAGE="http://www.gnu.org/software/gnash"
-ECVS_SERVER="cvs.sv.gnu.org:/sources/${PN}"
-ECVS_MODULE="${PN}"
-S="${WORKDIR}/${PN}"
+SRC_URI=""
-LICENSE="GPL-2"
+LICENSE="GPL-3"
SLOT="0"
KEYWORDS=""
-IUSE="agg gstreamer ffmpeg kde mad nsplugin xml video_cards_i810"
-#dmalloc, broken see bug 142939
-#dmalloc? ( dev-libs/dmalloc )
-# $(use_enable dmalloc) \
+IUSE=""
-RDEPEND="
- xml? ( dev-libs/libxml2 )
- sys-libs/zlib
- media-libs/jpeg
- media-libs/libogg
- media-libs/libpng
- net-misc/curl
- mad? ( media-libs/libmad )
- ffmpeg? ( media-video/ffmpeg )
- gstreamer? ( media-libs/gstreamer
- || (
- media-plugins/gst-plugins-ffmpeg
- media-plugins/gst-plugins-mad
- media-plugins/gst-plugins-lame
- )
- )
- !gstreamer? ( media-libs/libsdl )
- dev-libs/boost
- x11-libs/libX11
- x11-libs/libXi
- x11-libs/libXmu
- x11-libs/libXt
- x11-proto/xproto
- dev-libs/atk
- dev-libs/glib
- >x11-libs/gtk+-2
- x11-libs/pango
- !agg? ( virtual/opengl x11-libs/gtkglext )
- kde? ( kde-base/kdelibs )
- agg? ( x11-libs/agg )"
- #cairo? ( x11-libs/cairo )
-DEPEND="${RDEPEND} dev-util/pkgconfig"
+RDEPEND=""
+DEPEND=""
pkg_setup() {
- if use agg && use kde; then
- eerror "Building klash with the agg based renderer is not supported"
- eerror "Please USE -kde or -agg"
- die "kde and agg not supported at the same time"
- fi
-
- if has_version '<dev-libs/boost-1.34' && ! built_with_use dev-libs/boost threads; then
- eerror "dev-libst/boost has to be built with the 'threads' USE flag"
- die "dev-libs/boost not built with threads"
- fi
-
- if use mad && ( use !ffmpeg && use !gstreamer ) && ( use nsplugin || use xml ); then
- eerror "Building Gnash using the mad media handler is incompatible with the nsplugin or xml USE flags"
- die "nsplugin and xml not supported with mad media handler"
- fi
-
- if use !mad && use !ffmpeg && use !gstreamer; then
- eerror "You are trying to build Gnash without choosing a media handler"
- eerror "Please enable one of the following ffmpeg,gstreamer or mad(mp3 audio only)"
- die "No media handler selected !"
- fi
-}
-
-src_unpack() {
- cvs_src_unpack
- cd ${S}
- ./autogen.sh
-}
-
-src_compile() {
- local myconf
-
- use nsplugin && myconf="${myconf} --with-plugindir=/opt/netscape/plugins"
-
- #--enable-renderer=engine Specify rendering engine:
- # OpenGL (default)
- # Cairo (experimental)
- #cairo: does not work for plugins yet, offers flash for non-accelerated gfx?
- #if use cairo; then
- # myconf="${myconf} --enable-renderer=cairo"
- #fi
- if use agg; then
- myconf="${myconf} --enable-renderer=agg"
- fi
- #--enable-gui=flavor Specify gui flavor:
- # GTK
- # SDL -> has no controls, we do not USE it
- #$(use_enable gtk glext) with USE=-gtk, fails to detect gtkglext, bug 135010
- #--enable-media=gst||ffmpeg||mad
- if use mad && use !ffmpeg && use !gstreamer; then
- myconf="${myconf} --enable-media=mad"
- fi
-
- if use gstreamer && use !ffmpeg; then
- myconf="${myconf} --enable-media=gst"
- fi
-
- if use ffmpeg; then
- myconf="${myconf} --enable-media=ffmpeg"
- fi
-
- if use kde; then
- myconf="${myconf} --enable-klash --with-qt-incl=${QTDIR}/include
- --with-qt-lib=${QTDIR}/$(get_libdir)"
- else
- myconf="${myconf} --disable-klash"
- fi
-
- econf \
- $(use_enable nsplugin plugin) \
- $(use_enable xml) \
- $(use_enable video_cards_i810 i810-lod-bias) \
- --without-gcc-arch --disable-debugger \
- ${myconf} || die "econf failed"
- emake -j1 || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- use nsplugin && inst_plugin /opt/netscape/plugins/libgnashplugin.so \
- || rm -rf "${D}/opt"
- dodoc AUTHORS ChangeLog NEWS README
-}
-
-pkg_postinst() {
- ewarn "ALPHA"
- ewarn "gnash is still in heavy development"
- ewarn "please report gnash bugs upstream to the gnash devs"
+ die "Please get the current cvs ebuild from layman -a gnash-cvs"
}