summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDean Bailey <alron@gentoo.org>2003-04-08 23:09:08 +0000
committerDean Bailey <alron@gentoo.org>2003-04-08 23:09:08 +0000
commit244cb49c5d938e9d62574f25e2b1d251ec9cf0ac (patch)
tree73bb10f9bfa6e882bf9df8324bfeab8147f38c58 /net-www/horde-kronolith
parentelaborate on changelog (diff)
downloadgentoo-2-244cb49c5d938e9d62574f25e2b1d251ec9cf0ac.tar.gz
gentoo-2-244cb49c5d938e9d62574f25e2b1d251ec9cf0ac.tar.bz2
gentoo-2-244cb49c5d938e9d62574f25e2b1d251ec9cf0ac.zip
fixed issue when updating kronolith.
Diffstat (limited to 'net-www/horde-kronolith')
-rw-r--r--net-www/horde-kronolith/ChangeLog6
-rw-r--r--net-www/horde-kronolith/files/digest-horde-kronolith-1.0-r11
-rw-r--r--net-www/horde-kronolith/horde-kronolith-1.0-r1.ebuild67
3 files changed, 73 insertions, 1 deletions
diff --git a/net-www/horde-kronolith/ChangeLog b/net-www/horde-kronolith/ChangeLog
index 460c41ee253e..a77e3500aea6 100644
--- a/net-www/horde-kronolith/ChangeLog
+++ b/net-www/horde-kronolith/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-www/horde-kronolith
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/horde-kronolith/ChangeLog,v 1.2 2003/02/12 08:48:10 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/horde-kronolith/ChangeLog,v 1.3 2003/04/08 23:09:08 alron Exp $
+
+*horde-kronolith-1.0-r1 (08 Apr 2003)
+ 08 Apr 2003; Dean Bailey <alron@gentoo.org> horde-kronolith-1.0-r1 :
+ Fixed problem that cropped up when updating kronolith.
*horde-kronolith-1.0 (03 Feb 2003)
03 Feb 2003; Dean Bailey <alron@gentoo.org> horde-kronolith-1.0 :
diff --git a/net-www/horde-kronolith/files/digest-horde-kronolith-1.0-r1 b/net-www/horde-kronolith/files/digest-horde-kronolith-1.0-r1
new file mode 100644
index 000000000000..963254cbe2fd
--- /dev/null
+++ b/net-www/horde-kronolith/files/digest-horde-kronolith-1.0-r1
@@ -0,0 +1 @@
+MD5 ae94df3b0a44d7349b36e30997b3dfb4 kronolith-1.0.tar.gz 270604
diff --git a/net-www/horde-kronolith/horde-kronolith-1.0-r1.ebuild b/net-www/horde-kronolith/horde-kronolith-1.0-r1.ebuild
new file mode 100644
index 000000000000..b7ba34374770
--- /dev/null
+++ b/net-www/horde-kronolith/horde-kronolith-1.0-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/horde-kronolith/horde-kronolith-1.0-r1.ebuild,v 1.1 2003/04/08 23:09:08 alron Exp $
+
+DESCRIPTION="Kronolith ${PV} is the Horde calendar application"
+HOMEPAGE="http://www.horde.org"
+P=kronolith-1.0
+SRC_URI="ftp://ftp.horde.org/pub/kronolith/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="1"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+DEPEND=""
+RDEPEND=">=net-www/horde-2.2.1"
+IUSE=""
+
+find_http_root() {
+ export HTTPD_ROOT=`grep apache /etc/passwd | cut -d: -f6`/htdocs
+ if [ -z "${HTTPD_ROOT}" ]; then
+ eerror "HTTPD_ROOT is null! Using defaults."
+ eerror "You probably want to check /etc/passwd"
+ HTTPD_ROOT="/home/httpd/htdocs"
+ fi
+
+ export REGISTRY=${HTTPD_ROOT}/horde/config/registry.php
+ [ -f ${REGISTRY} ] || REGISTRY=${HTTPD_ROOT}/horde/config/registry.php.dist
+}
+
+pkg_setup() {
+ GREPSQL=`grep sql /var/db/pkg/dev-php/mod_php*/USE`
+ GREPLDAP=`grep ldap /var/db/pkg/dev-php/mod_php*/USE`
+ if [ "${GREPSQL}" != "" ] || [ "${GREPLDAP}" != "" ] ; then
+ return 0
+ else
+ eerror "Missing SQL or LDAP support in mod_php !"
+ die "aborting..."
+ fi
+ find_http_root
+ [ -f ${REGISTRY} ] || die "${REGISTRY} not found"
+}
+
+src_compile() {
+ echo "Nothing to compile"
+}
+
+src_install () {
+
+ # detecting apache usergroup
+ GID=`grep apache /etc/group |cut -d: -f3`
+ if [ -z "${GID}" ]; then
+ einfo "Using default GID of 81 for Apache"
+ GID=81
+ fi
+
+ find_http_root
+ dodir ${HTTPD_ROOT}/horde/kronolith
+ cp -r . ${D}/${HTTPD_ROOT}/horde/kronolith
+
+ # protecting files
+ chown -R apache.${GID} ${D}/${HTTPD_ROOT}/horde/kronolith
+ find ${D}/${HTTPD_ROOT}/horde/kronolith/ -type f -exec chmod 0640 {} \;
+ find ${D}/${HTTPD_ROOT}/horde/kronolith/ -type d -exec chmod 0750 {} \;
+}
+
+pkg_postinst() {
+ find_http_root
+ einfo "Please read ${HTTPD_ROOT}/horde/kronolith/docs/INSTALL !"
+}