summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-07-16 04:54:34 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-07-16 04:54:34 +0000
commit96d961306c383ae7f9e882b0647b661f344af7dc (patch)
treea200da9dd462d56c9cae5b7f54f451c5e22d338a /net-www/links
parentadded keywords (diff)
downloadgentoo-2-96d961306c383ae7f9e882b0647b661f344af7dc.tar.gz
gentoo-2-96d961306c383ae7f9e882b0647b661f344af7dc.tar.bz2
gentoo-2-96d961306c383ae7f9e882b0647b661f344af7dc.zip
ppc tagging
Diffstat (limited to 'net-www/links')
-rw-r--r--net-www/links/links-0.96-r1.ebuild31
-rw-r--r--net-www/links/links-2.1_pre2-r1.ebuild6
2 files changed, 19 insertions, 18 deletions
diff --git a/net-www/links/links-0.96-r1.ebuild b/net-www/links/links-0.96-r1.ebuild
index 899b2220c5ad..31be3953c54e 100644
--- a/net-www/links/links-0.96-r1.ebuild
+++ b/net-www/links/links-0.96-r1.ebuild
@@ -1,36 +1,37 @@
# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/net-www/links/links-0.96-r1.ebuild,v 1.3 2002/07/10 00:18:15 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/links/links-0.96-r1.ebuild,v 1.4 2002/07/16 04:54:33 seemant Exp $
S=${WORKDIR}/${P}
SRC_URI="http://artax.karlin.mff.cuni.cz/~mikulas/links/download/${P}.tar.gz"
HOMEPAGE="http://artax.karlin.mff.cuni.cz/~mikulas/links"
DESCRIPTION="A console-based web browser"
-DEPEND="virtual/glibc >=sys-libs/ncurses-5.1 gpm? ( >=sys-libs/gpm-1.19.3 ) ssl? ( >=dev-libs/openssl-0.9.6 )"
+DEPEND=">=sys-libs/ncurses-5.1
+ gpm? ( >=sys-libs/gpm-1.19.3 )
+ ssl? ( >=dev-libs/openssl-0.9.6 )"
SLOT="0"
LICENSE="GPL"
-KEYWORDS="*"
+KEYWORDS="x86 ppc"
src_compile() {
local myconf
- if [ "`use ssl` " ]
- then
- myconf="--enable-ssl"
- else
- myconf="--disable-ssl"
- fi
- ./configure --prefix=/usr --infodir=/usr/share/info --mandir=/usr/share/man ${myconf} || die
- # links doesn't respect a --without-gpm option; the only way to fix it is to edit the
+ use ssl \
+ && myconf="--enable-ssl" \
+ || myconf="--disable-ssl"
+
+ econf ${myconf} || die
+
+ # links doesn't respect a --without-gpm option;
+ # the only way to fix it is to edit the
# 'config.h' file afterwads. Luckily for us, sed exists. ;)
- if [ "`use gpm`" ]
- then
+ use gpm && ( \
echo "Leaving LibGPM enabled."
- else
+ ) || ( \
echo "Disabling LibGPM."
cat config.h | sed 's/.*LIBGPM 1/#undef HAVE_LIBGPM/g' > tmp~
mv tmp~ config.h
- fi
+ )
emake || die
}
diff --git a/net-www/links/links-2.1_pre2-r1.ebuild b/net-www/links/links-2.1_pre2-r1.ebuild
index c84bc82deb9b..b6c4441e08f3 100644
--- a/net-www/links/links-2.1_pre2-r1.ebuild
+++ b/net-www/links/links-2.1_pre2-r1.ebuild
@@ -1,10 +1,9 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/links/links-2.1_pre2-r1.ebuild,v 1.1 2002/07/12 01:14:25 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/links/links-2.1_pre2-r1.ebuild,v 1.2 2002/07/16 04:54:33 seemant Exp $
DESCRIPTION="links is a fast lightweight text tand graphic web-browser"
HOMEPAGE="http://atrey.karlin.mff.cuni.cz/~clock/twibright/links/"
-LICENSE="GPL-2"
# To handle pre-version ...
MYP="${P/_/}"
@@ -12,7 +11,8 @@ S="${WORKDIR}/${MYP}"
SRC_URI="${HOMEPAGE}/download/${MYP}.tar.bz2
http://www.ibiblio.org/gentoo/distfiles/links-2.1_pre2-patch.tar.bz2"
SLOT="2"
-KEYWORDS="x86"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc"
DEPEND="virtual/glibc
ssl? ( >=dev-libs/openssl-0.9.6c )