summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChuck Short <zul@gentoo.org>2004-05-27 00:49:17 +0000
committerChuck Short <zul@gentoo.org>2004-05-27 00:49:17 +0000
commit1ff8d13bdb6881f49b43cd128c4306b15d04a01e (patch)
tree141af7eb12ce870b1870938e1704e7cf8d2fea73 /net-www/mod_ldap_userdir/mod_ldap_userdir-1.1.1.ebuild
parent3.3 alpha1 - hardmasked (Manifest recommit) (diff)
downloadgentoo-2-1ff8d13bdb6881f49b43cd128c4306b15d04a01e.tar.gz
gentoo-2-1ff8d13bdb6881f49b43cd128c4306b15d04a01e.tar.bz2
gentoo-2-1ff8d13bdb6881f49b43cd128c4306b15d04a01e.zip
Initial ebuild.
Diffstat (limited to 'net-www/mod_ldap_userdir/mod_ldap_userdir-1.1.1.ebuild')
-rw-r--r--net-www/mod_ldap_userdir/mod_ldap_userdir-1.1.1.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/net-www/mod_ldap_userdir/mod_ldap_userdir-1.1.1.ebuild b/net-www/mod_ldap_userdir/mod_ldap_userdir-1.1.1.ebuild
new file mode 100644
index 000000000000..00d2e1e3166b
--- /dev/null
+++ b/net-www/mod_ldap_userdir/mod_ldap_userdir-1.1.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_ldap_userdir/mod_ldap_userdir-1.1.1.ebuild,v 1.1 2004/05/27 00:49:17 zul Exp $
+IUSE="apache2"
+
+DESCRIPTION="Apache module that enables ~/public_html from an LDAP directory."
+HOMEPAGE="http://horde.net/~jwm/software/mod_ldap_userdir/"
+KEYWORDS="x86"
+
+S=${WORKDIR}/${P}
+SRC_URI="http://horde.net/~jwm/software/mod_ldap_userdir/${P}.tar.gz"
+
+DEPEND="=net-www/apache-1*
+ apache2? ( =net-www/apache-2* )
+ ssl? ( dev-libs/openssl )
+ net-nds/openldap"
+
+LICENSE="GPL-1"
+SLOT="0"
+
+src_compile() {
+ local myconf
+ if use apache2; then
+ myconf="${myconf} --with-apxs2=/usr/sbin/apxs2"
+ else
+ myconf="${myconf} --with-apxs=/usr/sbin/apxs"
+ fi
+
+ use ssl && myconf="${myconf} -with-tls"
+
+ myconf="${myconf} --with-activate"
+ ./configure ${myconf} || die "Configure failed"
+ make clean
+ make || die "Make failed"
+}
+
+src_install() {
+ if use apache2; then
+ exeinto /usr/lib/apache2-extramodules
+ doexe mod_ldap_userdir.so
+ else
+ exeinto /usr/lib/apache-extramodules
+ doexe mod_ldap_userdir.so
+ fi
+ dodoc DIRECTIVES README user-ldif posixAccount-objectclass
+}
+
+pkg_postinst() {
+ if use apache2; then
+ einfo "Adjust /etc/apache2/conf/modules.d/47_mod_ldap_userdir.conf to match your setup and"
+ einfo "add '-D LDAPuserdir' to your APACHE2_OPTS in /etc/conf.d/apache2"
+ einfo "To configure the package run \"ebuild /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config\""
+ fi
+}
+
+pkg_config() {
+ /usr/sbin/apacheaddmod \
+ ${ROOT}/etc/apache/conf/apache.conf \
+ extramodules/mod_ldap_userdir.so mod_ldap_userdir.c ldap_userdir_module \
+ define=LDAPuserdir addconf=conf/addon-modules/47_mod_ldap_userdir.conf
+}