summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Stewart <vericgar@gentoo.org>2005-10-03 03:51:46 +0000
committerMichael Stewart <vericgar@gentoo.org>2005-10-03 03:51:46 +0000
commit7e8b7d269fee311c5937a31f03606f5e60caac6c (patch)
tree27a5e70f70416e5030edc9c93cb035b686714661 /net-www/mod_pcgi2
parentstable on x86. (diff)
downloadgentoo-2-7e8b7d269fee311c5937a31f03606f5e60caac6c.tar.gz
gentoo-2-7e8b7d269fee311c5937a31f03606f5e60caac6c.tar.bz2
gentoo-2-7e8b7d269fee311c5937a31f03606f5e60caac6c.zip
Add ugly hack so that this package makes it into the cache. See bug 107467
(Portage version: 2.0.52-r1)
Diffstat (limited to 'net-www/mod_pcgi2')
-rw-r--r--net-www/mod_pcgi2/mod_pcgi2-2.0.1.ebuild10
-rw-r--r--net-www/mod_pcgi2/mod_pcgi2-2.0.2.ebuild4
2 files changed, 11 insertions, 3 deletions
diff --git a/net-www/mod_pcgi2/mod_pcgi2-2.0.1.ebuild b/net-www/mod_pcgi2/mod_pcgi2-2.0.1.ebuild
index d68cb5e5b55d..17c4ab67b889 100644
--- a/net-www/mod_pcgi2/mod_pcgi2-2.0.1.ebuild
+++ b/net-www/mod_pcgi2/mod_pcgi2-2.0.1.ebuild
@@ -1,10 +1,18 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_pcgi2/mod_pcgi2-2.0.1.ebuild,v 1.13 2005/07/10 19:52:28 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_pcgi2/mod_pcgi2-2.0.1.ebuild,v 1.14 2005/10/03 03:51:46 vericgar Exp $
inherit eutils
detectapache() {
+ # DO NOT REPLICATE THIS IN ANY OTHER PACKAGE WITHOUT PORTAGE DEVS PERMISSION
+ # IT IS BROKEN AND A TEMPORARY MEASURE!
+ # YOU'VE BEEN WARNED.
+ if [[ ${EBUILD_PHASE/depend} != ${EBUILD_PHASE} ]]; then
+ APACHEVER=1
+ return
+ fi
+
local domsg=
[ -n "$1" ] && domsg=1
HAVE_APACHE1=
diff --git a/net-www/mod_pcgi2/mod_pcgi2-2.0.2.ebuild b/net-www/mod_pcgi2/mod_pcgi2-2.0.2.ebuild
index a8953f71fc68..ae66a605ae30 100644
--- a/net-www/mod_pcgi2/mod_pcgi2-2.0.2.ebuild
+++ b/net-www/mod_pcgi2/mod_pcgi2-2.0.2.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_pcgi2/mod_pcgi2-2.0.2.ebuild,v 1.3 2005/02/25 12:27:33 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_pcgi2/mod_pcgi2-2.0.2.ebuild,v 1.4 2005/10/03 03:51:46 vericgar Exp $
inherit eutils apache-module
DESCRIPTION="An Apache module to talk to Zope Corporation's PCGI"
-HOMEPAGE="http://www.zope.org/Members/phd/${PN}/"
+HOMEPAGE="http://www.zope.org/Members/phd/mod_pcgi2/"
SRC_URI="http://zope.org/Members/phd/${PN}/${PN}/${P}-src.tar.gz"
LICENSE="GPL-2"