summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-10-10 19:38:50 +0000
committerMike Frysinger <vapier@gentoo.org>2002-10-10 19:38:50 +0000
commita50fdc2e5fc923bec46d1b01fa8c83b8ab4ca1dc (patch)
tree3726507a654ac01f366b206f7aeb147fc8e4f62b /net-www/mod_ssl
parentUpdated ChangeLog. (diff)
downloadgentoo-2-a50fdc2e5fc923bec46d1b01fa8c83b8ab4ca1dc.tar.gz
gentoo-2-a50fdc2e5fc923bec46d1b01fa8c83b8ab4ca1dc.tar.bz2
gentoo-2-a50fdc2e5fc923bec46d1b01fa8c83b8ab4ca1dc.zip
Version bump #8978
Diffstat (limited to 'net-www/mod_ssl')
-rw-r--r--net-www/mod_ssl/ChangeLog7
-rw-r--r--net-www/mod_ssl/files/digest-mod_ssl-2.8.111
-rw-r--r--net-www/mod_ssl/mod_ssl-2.8.11.ebuild75
3 files changed, 82 insertions, 1 deletions
diff --git a/net-www/mod_ssl/ChangeLog b/net-www/mod_ssl/ChangeLog
index cb3b0ec503b6..b5c8d609af56 100644
--- a/net-www/mod_ssl/ChangeLog
+++ b/net-www/mod_ssl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-www/mod_ssl
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_ssl/ChangeLog,v 1.6 2002/08/14 11:01:28 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_ssl/ChangeLog,v 1.7 2002/10/10 19:38:50 vapier Exp $
+
+*mod_ssl-2.8.11.ebuild (14 July 2002)
+
+ 10 Oct 2002; Mike Frysinger <vapier@gentoo.org> mod_ssl-2.8.11.ebuild :
+ Version bump #8978
*mod_ssl-2.8.8-r1.ebuild (14 July 2002)
diff --git a/net-www/mod_ssl/files/digest-mod_ssl-2.8.11 b/net-www/mod_ssl/files/digest-mod_ssl-2.8.11
new file mode 100644
index 000000000000..d887223babe3
--- /dev/null
+++ b/net-www/mod_ssl/files/digest-mod_ssl-2.8.11
@@ -0,0 +1 @@
+MD5 f84bd971aa8db28f31ad6bab2e7acc2c mod_ssl-2.8.11-1.3.27.tar.gz 753416
diff --git a/net-www/mod_ssl/mod_ssl-2.8.11.ebuild b/net-www/mod_ssl/mod_ssl-2.8.11.ebuild
new file mode 100644
index 000000000000..348eeb4e701f
--- /dev/null
+++ b/net-www/mod_ssl/mod_ssl-2.8.11.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_ssl/mod_ssl-2.8.11.ebuild,v 1.1 2002/10/10 19:38:50 vapier Exp $
+
+MY_P=${P}-1.3.27
+
+DESCRIPTION="An SSL module for the Apache Web server"
+HOMEPAGE="http://www.modssl.org"
+KEYWORDS="x86 ppc sparc sparc64"
+
+S=${WORKDIR}/${MY_P}
+SRC_URI="http://www.modssl.org/source/${MY_P}.tar.gz"
+
+DEPEND="virtual/glibc =net-www/apache-1.3.27* >=dev-libs/openssl-0.9.6c"
+LICENSE="as-is"
+SLOT="0"
+
+src_unpack() {
+ unpack ${A} ; cd ${S}
+ # proper path to openssl
+ cp pkg.contrib/cca.sh pkg.contrib/cca.sh.orig
+ sed -e 's%^\(openssl=\).*%\1"/usr/bin/openssl"%' \
+ pkg.contrib/cca.sh.orig > pkg.contrib/cca.sh
+}
+
+src_compile() {
+ SSL_BASE=SYSTEM \
+ ./configure \
+ --with-apxs=/usr/sbin/apxs || die "bad ./configure"
+ make || die "compile problem"
+}
+
+src_install() {
+ exeinto /usr/lib/apache-extramodules
+ doexe pkg.sslmod/libssl.so
+
+ exeinto /usr/lib/ssl/mod_ssl
+ doexe pkg.contrib/*.sh ${FILESDIR}/gentestcrt.sh
+
+ dodoc ANNOUNCE CHANGES CREDITS LICENSE NEWS README*
+ mkdir -p ${D}/usr/share/doc/${PF}/html
+ cp -a pkg.ssldoc/* ${D}/usr/share/doc/${PF}/html
+
+ insinto /etc/apache/conf/vhosts
+ doins ${FILESDIR}/ssl.default-vhost.conf
+
+ insinto /etc/apache/conf/addon-modules
+ doins ${FILESDIR}/mod_ssl.conf
+}
+
+pkg_postinst() {
+ install -d -o root -g root -m0755 ${ROOT}/etc/apache/conf/ssl
+
+ einfo
+ einfo "Execute \"ebuild /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config\""
+ einfo "to have your apache.conf auto-updated for use with this module."
+ einfo "You should then edit your /etc/conf.d/apache file to suit."
+ einfo
+
+ cd ${ROOT}/etc/apache/conf/ssl
+ einfo "Generating self-signed test certificate in /etc/apache/conf/ssl..."
+ einfo "(Ignore any message from the yes command below)"
+ yes "" | ${ROOT}/usr/lib/ssl/mod_ssl/gentestcrt.sh >/dev/null 2>&1
+ einfo
+}
+
+pkg_config() {
+ ${ROOT}/usr/sbin/apacheaddmod \
+ ${ROOT}/etc/apache/conf/apache.conf \
+ extramodules/libssl.so mod_ssl.c ssl_module \
+ define=SSL addconf=conf/addon-modules/mod_ssl.conf
+
+ echo "Include conf/vhosts/ssl.default-vhost.conf" \
+ >> ${ROOT}/etc/apache/conf/apache.conf
+}