summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2003-11-21 21:31:24 +0000
committerAron Griffis <agriffis@gentoo.org>2003-11-21 21:31:24 +0000
commit3db160eb95f6ec1d830491a8b1be35a1137540ba (patch)
tree61b8681539bf3a10b2070b205c77ebee4bfd013e /net-www/mozilla-firebird
parentglx fix for xfree86 opengl #34009 (diff)
downloadgentoo-2-3db160eb95f6ec1d830491a8b1be35a1137540ba.tar.gz
gentoo-2-3db160eb95f6ec1d830491a8b1be35a1137540ba.tar.bz2
gentoo-2-3db160eb95f6ec1d830491a8b1be35a1137540ba.zip
Change architecture-specific stuff again, trying to clean it up
Diffstat (limited to 'net-www/mozilla-firebird')
-rw-r--r--net-www/mozilla-firebird/ChangeLog5
-rw-r--r--net-www/mozilla-firebird/Manifest10
-rw-r--r--net-www/mozilla-firebird/mozilla-firebird-0.7.ebuild60
3 files changed, 47 insertions, 28 deletions
diff --git a/net-www/mozilla-firebird/ChangeLog b/net-www/mozilla-firebird/ChangeLog
index 560a366404fe..68bbcd07aefd 100644
--- a/net-www/mozilla-firebird/ChangeLog
+++ b/net-www/mozilla-firebird/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-www/mozilla-firebird
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-firebird/ChangeLog,v 1.25 2003/11/18 01:15:56 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-firebird/ChangeLog,v 1.26 2003/11/21 21:31:20 agriffis Exp $
+
+ 21 Nov 2003; Aron Griffis <agriffis@gentoo.org> mozilla-firebird-0.7.ebuild:
+ Change architecture-specific stuff again, trying to clean it up
18 Nov 2003; Luca Barbato <lu_zero@gentoo.org> mozilla-firebird-0.7.ebuild:
Filtered another problematic flag
diff --git a/net-www/mozilla-firebird/Manifest b/net-www/mozilla-firebird/Manifest
index 8fe29c1548fe..4ecb6bc0a053 100644
--- a/net-www/mozilla-firebird/Manifest
+++ b/net-www/mozilla-firebird/Manifest
@@ -1,11 +1,11 @@
-MD5 30a26215a49f196247f61dbfe39ad004 ChangeLog 4259
+MD5 3d409a97f09d0ad060436fe417a0103c ChangeLog 4406
+MD5 00db8e42f2df963b2d4e778aaa97b3ea mozilla-firebird-0.7.ebuild 7595
MD5 ce23390351fe8020387d93ee29e09a3d metadata.xml 160
-MD5 ac196a385be977b279e643cfbebab064 mozilla-firebird-0.6.1.ebuild 6881
-MD5 5029903a15f95e55cb2af4d3eb8f998d mozilla-firebird-0.7.ebuild 7095
MD5 2501d008f329dab622fdc45ce9377a65 mozilla-firebird-0.6-r7.ebuild 6759
+MD5 ac196a385be977b279e643cfbebab064 mozilla-firebird-0.6.1.ebuild 6881
MD5 6e4352482ed149b3b9aca78d83de1124 files/MozillaFirebird 753
+MD5 78b9eef353e1aff29cef379e4de6b9fa files/digest-mozilla-firebird-0.6-r7 81
+MD5 d6389059d144d92d25b21b5cb3727cb0 files/digest-mozilla-firebird-0.7 80
MD5 23d1fbd03cc6dd346a4e4ce8f2d88ebf files/mozilla-1.3-alpha-stubs.patch 4646
MD5 f0e9adeb0454377ce019e8969e644efb files/mozilla-firebird-amd64.patch 35052
MD5 49802181a2284102bb2ed6daab129bb5 files/digest-mozilla-firebird-0.6.1 83
-MD5 d6389059d144d92d25b21b5cb3727cb0 files/digest-mozilla-firebird-0.7 80
-MD5 78b9eef353e1aff29cef379e4de6b9fa files/digest-mozilla-firebird-0.6-r7 81
diff --git a/net-www/mozilla-firebird/mozilla-firebird-0.7.ebuild b/net-www/mozilla-firebird/mozilla-firebird-0.7.ebuild
index a95e109dc60a..8f8f606f22c3 100644
--- a/net-www/mozilla-firebird/mozilla-firebird-0.7.ebuild
+++ b/net-www/mozilla-firebird/mozilla-firebird-0.7.ebuild
@@ -1,19 +1,9 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-firebird/mozilla-firebird-0.7.ebuild,v 1.8 2003/11/18 01:15:56 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-firebird/mozilla-firebird-0.7.ebuild,v 1.9 2003/11/21 21:31:20 agriffis Exp $
inherit makeedit flag-o-matic gcc nsplugins eutils
-# Added to get MozillaFirebird to compile on sparc.
-replace-sparc64-flags
-if [ "`use ppc`" -a "$(gcc-major-version)" -eq "3" -a "$(gcc-minor-version)" -eq "3" ]
-then
-
-append-flags -fno-strict-aliasing
-
-fi
-
-
S=${WORKDIR}/mozilla
DESCRIPTION="The Mozilla Firebird Web Browser"
@@ -63,6 +53,7 @@ src_unpack() {
}
src_compile() {
+ local enable_optimize=''
local myconf="--disable-composer \
--with-x \
--with-system-jpeg \
@@ -99,16 +90,6 @@ src_compile() {
--disable-toolkit-xlib \
--enable-extensions=default,-inspector,-irc,-venkman,-content-packs,-help"
- # On amd64 we statically set 'safe' CFLAGS. Use those only.
- # using the standard -O2 will cause segfaults on startup for amd64
- if [ "${ARCH}" = "amd64" ]
- then
- myconf="${myconf} --enable-optimize=-O"
- else
- myconf="${myconf} --enable-optimize=-O2"
- fi
-
-
if [ -n "`use gtk2`" ] ; then
myconf="${myconf} --enable-toolkit-gtk2 \
--enable-default-toolkit=gtk2 \
@@ -159,6 +140,41 @@ src_compile() {
myconf="${myconf} --enable-ipv6"
fi
+ # Per-architecture flags
+ case "${ARCH}" in
+ alpha|amd64|ia64)
+ # 64-bit needs -fPIC
+ append-flags -fPIC
+ ;;
+ sparc)
+ # Added to get MozillaFirebird to compile on sparc
+ replace-sparc64-flags
+ ;;
+ ppc)
+ # Fix to avoid gcc-3.3.x miscompilation issues.
+ if [ "$(gcc-major-version).$(gcc-minor-version)" = "3.3" ]; then
+ append-flags -fno-strict-aliasing
+ fi
+ ;;
+ esac
+
+ # 32-bit vs. 64-bit optimization
+ case "${ARCH}" in
+ alpha|amd64|ia64)
+ # Allow -O0 or -O1: Anything more than this causes
+ # segfaults on startup on 64-bit (bug 33767)
+ enable_optimize=$(echo "$CFLAGS" | sed 's/.*\(-O[01]\?\).*/\1/p')
+ enable_optimize=${enable_optimize:--O1}
+ filter-flags -O -O?
+ ;;
+ *)
+ # -O2 and below allowed on 32-bit
+ enable_optimize=$(echo "$CFLAGS" | sed 's/.*\(-O[012]\?\).*/\1/p')
+ enable_optimize=${enable_optimize:--O2}
+ filter-flags -O -O?
+ ;;
+ esac
+
# Crashes on start when compiled with -fomit-frame-pointer
filter-flags -fomit-frame-pointer -mpowerpc-gfxopt
filter-flags -ffast-math
@@ -178,7 +194,7 @@ src_compile() {
fi
fi
- econf ${myconf} || die
+ econf --enable-optimize="${enable_optimize}" ${myconf} || die
edit_makefiles
emake MOZ_PHOENIX=1 || die