summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-06-09 23:58:56 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-06-09 23:58:56 +0000
commit1ae34d496ec338334f4403358ce3ec002feceeda (patch)
tree5d9f6aa1e76e7191b457a01659fa3ddf837b9d90 /net-www/mplayerplug-in
parentversion bump (diff)
downloadgentoo-2-1ae34d496ec338334f4403358ce3ec002feceeda.tar.gz
gentoo-2-1ae34d496ec338334f4403358ce3ec002feceeda.tar.bz2
gentoo-2-1ae34d496ec338334f4403358ce3ec002feceeda.zip
version bump
Diffstat (limited to 'net-www/mplayerplug-in')
-rw-r--r--net-www/mplayerplug-in/ChangeLog8
-rw-r--r--net-www/mplayerplug-in/Manifest4
-rw-r--r--net-www/mplayerplug-in/files/digest-mplayerplug-in-0.802
-rw-r--r--net-www/mplayerplug-in/mplayerplug-in-0.80.ebuild53
4 files changed, 64 insertions, 3 deletions
diff --git a/net-www/mplayerplug-in/ChangeLog b/net-www/mplayerplug-in/ChangeLog
index f865a5ab7727..c96c83f72a44 100644
--- a/net-www/mplayerplug-in/ChangeLog
+++ b/net-www/mplayerplug-in/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-www/mplayerplug-in
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mplayerplug-in/ChangeLog,v 1.5 2003/06/05 05:11:28 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mplayerplug-in/ChangeLog,v 1.6 2003/06/09 23:58:53 seemant Exp $
+
+*mplayerplug-in-0.80 (09 Jun 2003)
+
+ 09 Jun 2003; Seemant Kulleen <seemant@gentoo.org>
+ mplayerplug-in-0.80.ebuild:
+ version bump thanks to Theofilos Intzoglou <oscar10@yifan.net> in bug #22121
04 Jun 2003; Seemant Kulleen <seemant@gentoo.org>
mplayerplug-in-0.40.ebuild, mplayerplug-in-0.60.ebuild,
diff --git a/net-www/mplayerplug-in/Manifest b/net-www/mplayerplug-in/Manifest
index a29ccff6c7e7..20c31eb48d86 100644
--- a/net-www/mplayerplug-in/Manifest
+++ b/net-www/mplayerplug-in/Manifest
@@ -1,5 +1,5 @@
-MD5 59d5dd02f9d461625d423bee4c24a622 mplayerplug-in-0.80.ebuild 1288
+MD5 783b9d5c8f1fdc347cd3fe9f91ad30e3 mplayerplug-in-0.80.ebuild 1289
MD5 28b7dbf1e2066a7ceddb1a00251c1799 mplayerplug-in-0.71.ebuild 1296
-MD5 f0b49b9e14719c32f5e9f12555ffabe5 ChangeLog 1084
+MD5 c1ab9e796431f6d11c7002108e3702d7 ChangeLog 1282
MD5 fc695a5198414c46fde959e5747ba75f files/digest-mplayerplug-in-0.71 126
MD5 f67d7196e95ae6840ddd5117dd249afb files/digest-mplayerplug-in-0.80 125
diff --git a/net-www/mplayerplug-in/files/digest-mplayerplug-in-0.80 b/net-www/mplayerplug-in/files/digest-mplayerplug-in-0.80
new file mode 100644
index 000000000000..be18fb57bfa6
--- /dev/null
+++ b/net-www/mplayerplug-in/files/digest-mplayerplug-in-0.80
@@ -0,0 +1,2 @@
+MD5 2ee4b6572758566d7079a7a06903a5fb mplayerplug-in-0.80.tar.gz 38414
+MD5 88ffb4b41928f5b063800bab46be1545 mini.tar.bz2 5775
diff --git a/net-www/mplayerplug-in/mplayerplug-in-0.80.ebuild b/net-www/mplayerplug-in/mplayerplug-in-0.80.ebuild
new file mode 100644
index 000000000000..e8d39cfa6185
--- /dev/null
+++ b/net-www/mplayerplug-in/mplayerplug-in-0.80.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-www/mplayerplug-in/mplayerplug-in-0.80.ebuild,v 1.1 2003/06/09 23:58:53 seemant Exp $
+
+IUSE=""
+
+inherit nsplugins
+
+S="${WORKDIR}/mplayerplug-in"
+HOMEPAGE="http://mplayerplug-in.sourceforge.net/"
+DESCRIPTION="mplayer plug-in for Mozilla"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
+ mirror://sourceforge/${PN}/mini.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+
+DEPEND=">=media-video/mplayer-0.90_rc4"
+
+src_compile() {
+ [ -z "${CC}" ] && CC="gcc"
+ emake CC="${CC}" OPTIMIZER="${CFLAGS}" || die
+}
+
+src_install() {
+ exeinto /opt/netscape/plugins
+ doexe mplayerplug-in.so
+
+ inst_plugin /opt/netscape/plugins/mplayerplug-in.so
+
+ insinto /usr/share/mplayer/Skin/mini
+ doins ${WORKDIR}/mini/*
+
+ dodir /etc
+ # For some reason this does not work yet for mplayer options, and
+ # setting 'vo' cause it for 'mozilla file:///space/movies/foo.avi'
+ # at least to not work...
+ cat > ${D}/etc/mplayerplug-in.conf <<END
+# Should it handle embedded movies ?
+noembed=0
+
+# Set to 'mini' if you want the seek bar
+use-gui=no
+
+# Normal mplayer style config options
+#vo=x11
+fs=no
+zoom=yes
+END
+
+ dodoc TODO ChangeLog INSTALL README
+}