summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2007-07-19 16:48:16 +0000
committerJim Ramsay <lack@gentoo.org>2007-07-19 16:48:16 +0000
commit23d1d168f096eb3a10caa5ddba0e13873412c591 (patch)
tree55b8fcd6d749a24b1f4a5ecd536f2c4ce32be949 /net-www/netscape-flash
parentVersion bump. (diff)
downloadgentoo-2-23d1d168f096eb3a10caa5ddba0e13873412c591.tar.gz
gentoo-2-23d1d168f096eb3a10caa5ddba0e13873412c591.tar.bz2
gentoo-2-23d1d168f096eb3a10caa5ddba0e13873412c591.zip
Adding rpm-based ebuild since the RPM is the only versioned download available at this time. See bug 185141 for more details
(Portage version: 2.1.3_rc8)
Diffstat (limited to 'net-www/netscape-flash')
-rw-r--r--net-www/netscape-flash/ChangeLog9
-rw-r--r--net-www/netscape-flash/files/digest-netscape-flash-9.0.48.0-r13
-rw-r--r--net-www/netscape-flash/metadata.xml6
-rw-r--r--net-www/netscape-flash/netscape-flash-9.0.48.0-r1.ebuild46
4 files changed, 62 insertions, 2 deletions
diff --git a/net-www/netscape-flash/ChangeLog b/net-www/netscape-flash/ChangeLog
index f942493c2098..19d523fb367a 100644
--- a/net-www/netscape-flash/ChangeLog
+++ b/net-www/netscape-flash/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-www/netscape-flash
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/netscape-flash/ChangeLog,v 1.55 2007/07/14 17:03:28 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/netscape-flash/ChangeLog,v 1.56 2007/07/19 16:48:16 lack Exp $
+
+*netscape-flash-9.0.48.0-r1 (19 Jul 2007)
+
+ 19 Jul 2007; Jim Ramsay <lack@gentoo.org> metadata.xml,
+ +netscape-flash-9.0.48.0-r1.ebuild:
+ Adding rpm-based ebuild since the RPM is the only versioned download
+ available at this time. See bug 185141 for more details
14 Jul 2007; <tester@gentoo.org> netscape-flash-9.0.48.0.ebuild:
Remove file that no longer exists
diff --git a/net-www/netscape-flash/files/digest-netscape-flash-9.0.48.0-r1 b/net-www/netscape-flash/files/digest-netscape-flash-9.0.48.0-r1
new file mode 100644
index 000000000000..fbee6895f40d
--- /dev/null
+++ b/net-www/netscape-flash/files/digest-netscape-flash-9.0.48.0-r1
@@ -0,0 +1,3 @@
+MD5 0d3a1a07c87f5533ee1c8e6993b00c43 flash-plugin-9.0.48.0-release.i386.rpm 2606152
+RMD160 cc0eb48fab725d9f7b2e5974a6e253295b09a8bd flash-plugin-9.0.48.0-release.i386.rpm 2606152
+SHA256 e80f4a3926d3b8fc4a5b48d5f45fc9c070e953e137c1a047b31f29404338088f flash-plugin-9.0.48.0-release.i386.rpm 2606152
diff --git a/net-www/netscape-flash/metadata.xml b/net-www/netscape-flash/metadata.xml
index 20ce219711a2..24f1e9f83097 100644
--- a/net-www/netscape-flash/metadata.xml
+++ b/net-www/netscape-flash/metadata.xml
@@ -1,5 +1,9 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>no-herd</herd>
+ <herd>desktop-misc</herd>
+ <maintainer>
+ <email>lack@gentoo.org</email>
+ <name>Jim Ramsay</name>
+ </maintainer>
</pkgmetadata>
diff --git a/net-www/netscape-flash/netscape-flash-9.0.48.0-r1.ebuild b/net-www/netscape-flash/netscape-flash-9.0.48.0-r1.ebuild
new file mode 100644
index 000000000000..b0dc53fc2f6b
--- /dev/null
+++ b/net-www/netscape-flash/netscape-flash-9.0.48.0-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/netscape-flash/netscape-flash-9.0.48.0-r1.ebuild,v 1.1 2007/07/19 16:48:16 lack Exp $
+
+inherit nsplugins rpm
+
+DESCRIPTION="Adobe Flash Player"
+SRC_URI="http://fpdownload.macromedia.com/get/flashplayer/current/flash-plugin-${PV}-release.i386.rpm"
+HOMEPAGE="http://www.adobe.com/"
+IUSE=""
+SLOT="0"
+
+KEYWORDS="-* amd64 x86"
+LICENSE="AdobeFlash-9.0.31.0"
+RESTRICT="strip mirror"
+
+S=${WORKDIR}
+
+DEPEND="amd64? ( app-emulation/emul-linux-x86-baselibs
+ app-emulation/emul-linux-x86-gtklibs
+ app-emulation/emul-linux-x86-soundlibs
+ app-emulation/emul-linux-x86-xlibs )
+ x86? ( x11-libs/libXext
+ x11-libs/libX11
+ x11-libs/libXt
+ =x11-libs/gtk+-2*
+ media-libs/freetype
+ media-libs/fontconfig )"
+
+pkg_setup() {
+ # This is a binary x86 package => ABI=x86
+ # Please keep this in future versions
+ # Danny van Dyk <kugelfang@gentoo.org> 2005/03/26
+ has_multilib_profile && ABI="x86"
+}
+
+src_install() {
+ cd ${S}/usr/lib/flash-plugin
+ exeinto /opt/netscape/plugins
+ doexe libflashplayer.so
+ inst_plugin /opt/netscape/plugins/libflashplayer.so
+
+ dodoc README
+ cd ${S}/usr/share/doc/flash-plugin-${PV}/
+ dodoc readme.txt
+}