summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2009-02-26 14:00:56 +0000
committerJim Ramsay <lack@gentoo.org>2009-02-26 14:00:56 +0000
commit2b7219a2730c0950984dd72236137cfe589e277a (patch)
treeafd8bfa23dfe621edc11f1fdcc93fa4ecb8e0c18 /net-www/netscape-flash
parentInitial commit (diff)
downloadgentoo-2-2b7219a2730c0950984dd72236137cfe589e277a.tar.gz
gentoo-2-2b7219a2730c0950984dd72236137cfe589e277a.tar.bz2
gentoo-2-2b7219a2730c0950984dd72236137cfe589e277a.zip
Added new '32-bit' local USE flag which specifies whether amd64-multilib platforms get both 32- and 64-bit plugins, or just the 64-bit one.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'net-www/netscape-flash')
-rw-r--r--net-www/netscape-flash/ChangeLog7
-rw-r--r--net-www/netscape-flash/metadata.xml4
-rw-r--r--net-www/netscape-flash/netscape-flash-10.0.22.87.ebuild14
3 files changed, 18 insertions, 7 deletions
diff --git a/net-www/netscape-flash/ChangeLog b/net-www/netscape-flash/ChangeLog
index 2095a5543e8f..ed2f58fd8931 100644
--- a/net-www/netscape-flash/ChangeLog
+++ b/net-www/netscape-flash/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-www/netscape-flash
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/netscape-flash/ChangeLog,v 1.89 2009/02/25 19:41:34 lack Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/netscape-flash/ChangeLog,v 1.90 2009/02/26 14:00:56 lack Exp $
+
+ 26 Feb 2009; Jim Ramsay <lack@gentoo.org> metadata.xml,
+ netscape-flash-10.0.22.87.ebuild:
+ Added new '32-bit' local USE flag which specifies whether amd64-multilib
+ platforms get both 32- and 64-bit plugins, or just the 64-bit one.
*netscape-flash-9.0.159.0 (25 Feb 2009)
diff --git a/net-www/netscape-flash/metadata.xml b/net-www/netscape-flash/metadata.xml
index 24f1e9f83097..8be16fe08e9e 100644
--- a/net-www/netscape-flash/metadata.xml
+++ b/net-www/netscape-flash/metadata.xml
@@ -6,4 +6,8 @@
<email>lack@gentoo.org</email>
<name>Jim Ramsay</name>
</maintainer>
+ <use>
+ <flag name='32bit'>For amd64-multilib, installs the 32-bit plugin
+ alongside the native 64-bit plugin</flag>
+ </use>
</pkgmetadata>
diff --git a/net-www/netscape-flash/netscape-flash-10.0.22.87.ebuild b/net-www/netscape-flash/netscape-flash-10.0.22.87.ebuild
index c91019b5cad3..bed879ba6485 100644
--- a/net-www/netscape-flash/netscape-flash-10.0.22.87.ebuild
+++ b/net-www/netscape-flash/netscape-flash-10.0.22.87.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/netscape-flash/netscape-flash-10.0.22.87.ebuild,v 1.1 2009/02/25 19:32:09 lack Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/netscape-flash/netscape-flash-10.0.22.87.ebuild,v 1.2 2009/02/26 14:00:56 lack Exp $
EAPI=1
inherit nsplugins rpm multilib
@@ -11,10 +11,12 @@ MY_64B_URI="http://download.macromedia.com/pub/labs/flashplayer10/libflashplayer
DESCRIPTION="Adobe Flash Player"
SRC_URI="x86? ( ${MY_32B_URI} )
amd64? ( ${MY_64B_URI}
- multilib? ( ${MY_32B_URI} mirror://gentoo/flash-libcompat-0.2.tar.bz2 )
+ multilib? ( 32bit? (
+ ${MY_32B_URI} mirror://gentoo/flash-libcompat-0.2.tar.bz2
+ ) )
)"
HOMEPAGE="http://www.adobe.com/"
-IUSE="multilib"
+IUSE="multilib +32bit"
SLOT="0"
KEYWORDS="-* ~amd64 ~x86"
@@ -30,12 +32,12 @@ RDEPEND="x11-libs/gtk+:2
>=sys-libs/glibc-2.4
|| ( media-fonts/freefont-ttf media-fonts/corefonts )
amd64? (
- multilib? (
+ multilib? ( 32bit? (
app-emulation/emul-linux-x86-baselibs
app-emulation/emul-linux-x86-gtklibs
app-emulation/emul-linux-x86-soundlibs
app-emulation/emul-linux-x86-xlibs
- )
+ ) )
)
"
@@ -59,7 +61,7 @@ src_install() {
# 64b tarball has no readme file.
use x86 && dodoc "${S}/usr/share/doc/flash-plugin-${PV}/readme.txt"
- if use amd64 && has_multilib_profile; then
+ if use amd64 && has_multilib_profile && use 32bit; then
oldabi="${ABI}"
ABI="x86"