summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2008-05-15 14:35:11 +0000
committerJim Ramsay <lack@gentoo.org>2008-05-15 14:35:11 +0000
commit57851ca506a6e080dfe8c776359dd3c56b59bac1 (patch)
treee1f2a659faf626e4e7feb8f667521010155a0fba /net-www/netscape-flash
parentNew beta version of FlashPlayer-10 is released (Bug #222231) (diff)
downloadgentoo-2-57851ca506a6e080dfe8c776359dd3c56b59bac1.tar.gz
gentoo-2-57851ca506a6e080dfe8c776359dd3c56b59bac1.tar.bz2
gentoo-2-57851ca506a6e080dfe8c776359dd3c56b59bac1.zip
New beta version of FlashPlayer-10 is released (Bug #222231)
(Portage version: 2.1.4.1)
Diffstat (limited to 'net-www/netscape-flash')
-rw-r--r--net-www/netscape-flash/ChangeLog8
-rw-r--r--net-www/netscape-flash/netscape-flash-10_beta20080515.ebuild50
2 files changed, 57 insertions, 1 deletions
diff --git a/net-www/netscape-flash/ChangeLog b/net-www/netscape-flash/ChangeLog
index 4854110cd221..47e4f057f122 100644
--- a/net-www/netscape-flash/ChangeLog
+++ b/net-www/netscape-flash/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-www/netscape-flash
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/netscape-flash/ChangeLog,v 1.66 2008/04/17 01:08:17 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/netscape-flash/ChangeLog,v 1.67 2008/05/15 14:35:11 lack Exp $
+
+*netscape-flash-10_beta20080515 (15 May 2008)
+
+ 15 May 2008; Jim Ramsay <lack@gentoo.org>
+ +netscape-flash-10_beta20080515.ebuild:
+ New beta version of FlashPlayer-10 is released (Bug #222231)
17 Apr 2008; Markus Meier <maekke@gentoo.org>
netscape-flash-9.0.124.0.ebuild:
diff --git a/net-www/netscape-flash/netscape-flash-10_beta20080515.ebuild b/net-www/netscape-flash/netscape-flash-10_beta20080515.ebuild
new file mode 100644
index 000000000000..1ab3e0d60e80
--- /dev/null
+++ b/net-www/netscape-flash/netscape-flash-10_beta20080515.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/netscape-flash/netscape-flash-10_beta20080515.ebuild,v 1.1 2008/05/15 14:35:11 lack Exp $
+
+inherit nsplugins versionator
+
+MV=$(get_major_version)
+
+# Excellent, Adobe uses that unsortable though surprisingly popular date
+# convention "MMDDYY", so build that out of a proper "YYYYMMDD" beta version
+# component:
+BETA=$(get_version_component_range 2)
+BETA=${BETA#beta}
+BV=${BETA:4:2}${BETA:6:2}${BETA:2:2}
+
+DESCRIPTION="Adobe Flash Player"
+SRC_URI="http://download.macromedia.com/pub/labs/flashplayer${MV}/flashplayer${MV}_install_linux_${BV}.tar.gz"
+HOMEPAGE="http://www.adobe.com/"
+IUSE=""
+SLOT="0"
+
+KEYWORDS="-* ~amd64 ~x86"
+LICENSE="AdobeFlash-9.0.31.0"
+RESTRICT="strip mirror"
+
+S="${WORKDIR}/install_flash_player_${MV}_linux"
+
+DEPEND="amd64? ( app-emulation/emul-linux-x86-baselibs
+ app-emulation/emul-linux-x86-gtklibs
+ app-emulation/emul-linux-x86-soundlibs
+ app-emulation/emul-linux-x86-xlibs )
+ x86? ( x11-libs/libXext
+ x11-libs/libX11
+ x11-libs/libXt
+ =x11-libs/gtk+-2*
+ media-libs/freetype
+ media-libs/fontconfig )"
+
+pkg_setup() {
+ # This is a binary x86 package => ABI=x86
+ # Please keep this in future versions
+ # Danny van Dyk <kugelfang@gentoo.org> 2005/03/26
+ has_multilib_profile && ABI="x86"
+}
+
+src_install() {
+ exeinto /opt/netscape/plugins
+ doexe libflashplayer.so
+ inst_plugin /opt/netscape/plugins/libflashplayer.so
+}