summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-04-26 22:35:10 +0000
committerAron Griffis <agriffis@gentoo.org>2004-04-26 22:35:10 +0000
commit04f26ae461677d2661539ce274c7e730692ec6c7 (patch)
tree038801b9c2d7c003b2c242c456876e4a9bc054e2 /net-www
parent2.8 stable on mips, ~mips keyword added to 2.8-r1 (Manifest recommit) (diff)
downloadgentoo-2-04f26ae461677d2661539ce274c7e730692ec6c7.tar.gz
gentoo-2-04f26ae461677d2661539ce274c7e730692ec6c7.tar.bz2
gentoo-2-04f26ae461677d2661539ce274c7e730692ec6c7.zip
- Fix bug 21667 (replacing -march=pentium4 in mozilla ebuilds outdated) by checking for gcc >= 3.2.3 - Fix bug 48878 (mozilla-1.7_rc1 pkg-config files say 1.7b) by overwriting milestone.txt in src_unpack
Diffstat (limited to 'net-www')
-rw-r--r--net-www/mozilla/ChangeLog8
-rw-r--r--net-www/mozilla/mozilla-1.7_rc1.ebuild14
2 files changed, 17 insertions, 5 deletions
diff --git a/net-www/mozilla/ChangeLog b/net-www/mozilla/ChangeLog
index 6f460a3a0400..a2e77fece34a 100644
--- a/net-www/mozilla/ChangeLog
+++ b/net-www/mozilla/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-www/mozilla
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/ChangeLog,v 1.163 2004/04/26 18:30:32 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/ChangeLog,v 1.164 2004/04/26 22:35:10 agriffis Exp $
+
+ 26 Apr 2004; Aron Griffis <agriffis@gentoo.org> mozilla-1.7_rc1.ebuild:
+ - Fix bug 21667 (replacing -march=pentium4 in mozilla ebuilds
+ outdated) by checking for gcc >= 3.2.3
+ - Fix bug 48878 (mozilla-1.7_rc1 pkg-config files say 1.7b) by
+ overwriting milestone.txt in src_unpack
26 Apr 2004; Aron Griffis <agriffis@gentoo.org>
+files/mozilla-1.6-gcc-3.4.patch, mozilla-1.6-r1.ebuild:
diff --git a/net-www/mozilla/mozilla-1.7_rc1.ebuild b/net-www/mozilla/mozilla-1.7_rc1.ebuild
index 272c8a899a67..c71da49bb41e 100644
--- a/net-www/mozilla/mozilla-1.7_rc1.ebuild
+++ b/net-www/mozilla/mozilla-1.7_rc1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/mozilla-1.7_rc1.ebuild,v 1.4 2004/04/26 15:33:49 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/mozilla-1.7_rc1.ebuild,v 1.5 2004/04/26 22:35:10 agriffis Exp $
IUSE="java crypt ipv6 gtk2 ssl ldap gnome debug xinerama"
# Internal USE flags that I do not really want to advertise ...
@@ -145,6 +145,11 @@ src_unpack() {
# <azarah@gentoo.org> (23 Feb 2003)
epatch ${FILESDIR}/1.3/${PN}-1.3-fix-RAW-target.patch
+ # Fix incorrect version in milestone.txt (1.7rc1 claims 1.7b)
+ einfo "Updating milestone.txt to ${MY_PV}"
+ sed -i -ne '/^#/p' config/milestone.txt # maintain comments
+ echo "${MY_PV}" >> config/milestone.txt # add version line
+
WANT_AUTOCONF_2_1=1 autoconf &> /dev/null
# Unpack the enigmail plugin
@@ -269,9 +274,10 @@ src_compile() {
fi
if [[ $(gcc-major-version) -eq 3 ]]; then
- # Currently gcc-3.2 or older do not work well if we specify "-march"
- # and other optimizations for pentium4.
- if [[ $(gcc-minor-version) -lt 3 ]]; then
+ # gcc-3 prior to 3.2.3 doesn't work well for pentium4
+ if [[ $(gcc-minor-version) -lt 2 ||
+ ( $(gcc-minor-version) -eq 2 && $(gcc-micro-version) -lt 3 ) ]]
+ then
replace-flags -march=pentium4 -march=pentium3
filter-flags -msse2
fi