summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenat Lumpau <rl03@gentoo.org>2007-05-29 00:21:00 +0000
committerRenat Lumpau <rl03@gentoo.org>2007-05-29 00:21:00 +0000
commit373081ac7e2873b0e7d0cced841b6506b66279dc (patch)
treee928f46db18dd8005398bb5cb03c5a67723ac035 /net-www
parentRemoving removed packages from package.mask. (diff)
downloadgentoo-2-373081ac7e2873b0e7d0cced841b6506b66279dc.tar.gz
gentoo-2-373081ac7e2873b0e7d0cced841b6506b66279dc.tar.bz2
gentoo-2-373081ac7e2873b0e7d0cced841b6506b66279dc.zip
Add geoip support per bug #103663.
(Portage version: 2.1.2.8)
Diffstat (limited to 'net-www')
-rw-r--r--net-www/awstats/ChangeLog5
-rw-r--r--net-www/awstats/awstats-6.6.ebuild23
2 files changed, 19 insertions, 9 deletions
diff --git a/net-www/awstats/ChangeLog b/net-www/awstats/ChangeLog
index fbd7b0fa1c30..cfcaa1cc008d 100644
--- a/net-www/awstats/ChangeLog
+++ b/net-www/awstats/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-www/awstats
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/awstats/ChangeLog,v 1.44 2007/03/19 02:09:38 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/awstats/ChangeLog,v 1.45 2007/05/29 00:21:00 rl03 Exp $
+
+ 29 May 2007; Renat Lumpau <rl03@gentoo.org> awstats-6.6.ebuild:
+ Add geoip support per bug #103663.
19 Mar 2007; Bryan Østergaard <kloeri@gentoo.org> metadata.xml:
Remove ka0ttic from metadata.xml due to retirement.
diff --git a/net-www/awstats/awstats-6.6.ebuild b/net-www/awstats/awstats-6.6.ebuild
index 28a2622608cb..484e93802602 100644
--- a/net-www/awstats/awstats-6.6.ebuild
+++ b/net-www/awstats/awstats-6.6.ebuild
@@ -1,17 +1,16 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/awstats/awstats-6.6.ebuild,v 1.11 2007/01/03 19:20:34 rl03 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/awstats/awstats-6.6.ebuild,v 1.12 2007/05/29 00:21:00 rl03 Exp $
inherit eutils webapp versionator depend.apache
DESCRIPTION="AWStats is short for Advanced Web Statistics."
HOMEPAGE="http://awstats.sourceforge.net/"
-#SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-SRC_URI="http://awstats.sourceforge.net/files/${P}.tar.gz"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86 ~x86-fbsd"
-IUSE=""
+IUSE="geoip"
RESTRICT="mirror"
@@ -21,9 +20,8 @@ WEBAPP_MANUAL_SLOT="yes"
RDEPEND=">=dev-lang/perl-5.6.1
>=media-libs/libpng-1.2
virtual/perl-Time-Local
- dev-perl/URI"
-DEPEND="${RDEPEND}
- >=sys-apps/sed-4"
+ dev-perl/URI
+ geoip? ( dev-perl/Geo-IP )"
want_apache
@@ -46,7 +44,7 @@ src_unpack() {
done
# set the logpath
- if use apache || use apache2; then
+ if use apache2; then
logpath="apache${USE_APACHE2}/access_log"
else
logpath="awstats_log"
@@ -129,5 +127,14 @@ pkg_postinst() {
elog
ewarn "Copy the /etc/awstats/awstats.model.conf to"
ewarn "/etc/awstats/awstats.<yourdomain>.conf and edit it."
+
+ if use geoip ; then
+ einfo
+ einfo "Add the following line to /etc/awstats/awstats.<yourdomain>.conf"
+ einfo "to enable GeoIP plugin:"
+ einfo "LoadPlugin=\"geoip GEOIP_STANDARD /usr/share/GeoIP/GeoIP.dat\" "
+ einfo
+ fi
+
webapp_pkg_postinst
}