summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-06-05 17:10:10 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-06-05 17:10:10 +0000
commit3bdd3fa6d83a11bff71b330c10854526b31bb207 (patch)
tree221d1ada145a76db5282a8f6f964911b05a182f5 /net-www
parentadded texinfo (diff)
downloadgentoo-2-3bdd3fa6d83a11bff71b330c10854526b31bb207.tar.gz
gentoo-2-3bdd3fa6d83a11bff71b330c10854526b31bb207.tar.bz2
gentoo-2-3bdd3fa6d83a11bff71b330c10854526b31bb207.zip
fixing dependency bugs
Diffstat (limited to 'net-www')
-rw-r--r--net-www/galeon/ChangeLog8
-rw-r--r--net-www/galeon/files/digest-galeon-1.2.3-r11
-rw-r--r--net-www/galeon/galeon-1.2.3-r1.ebuild91
3 files changed, 99 insertions, 1 deletions
diff --git a/net-www/galeon/ChangeLog b/net-www/galeon/ChangeLog
index 8d4c04e667b1..65744edd06ff 100644
--- a/net-www/galeon/ChangeLog
+++ b/net-www/galeon/ChangeLog
@@ -1,7 +1,13 @@
# ChangeLog for net-www/galeon
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-www/galeon/ChangeLog,v 1.12 2002/05/26 08:45:24 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/galeon/ChangeLog,v 1.13 2002/06/05 17:10:10 spider Exp $
+
+
+*galeon-1.2.3-r1 (05 Jun 2002)
+ 05 Jun 2002; Spider <spider@gentoo.org> galeon-1.2.3-r1.ebuild :
+ New release that fixes the dependency bugs on gnome
+
*galeon-1.2.3 (26 May 2002)
26 May 2002; Ryan Phillips <rphillips@gentoo.org>
diff --git a/net-www/galeon/files/digest-galeon-1.2.3-r1 b/net-www/galeon/files/digest-galeon-1.2.3-r1
new file mode 100644
index 000000000000..221ad2154450
--- /dev/null
+++ b/net-www/galeon/files/digest-galeon-1.2.3-r1
@@ -0,0 +1 @@
+MD5 19f9888e0493e6ca5da4752d3dfb5137 galeon-1.2.3.tar.gz 3936664
diff --git a/net-www/galeon/galeon-1.2.3-r1.ebuild b/net-www/galeon/galeon-1.2.3-r1.ebuild
new file mode 100644
index 000000000000..cbad2d51e374
--- /dev/null
+++ b/net-www/galeon/galeon-1.2.3-r1.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Martin Schlemmer <azarah@gentoo.org>
+# /space/gentoo/cvsroot/gentoo-x86/net-www/galeon/galeon-1.2.3.ebuild,v 1.2 2002/05/27 17:27:39 drobbins Exp
+S=${WORKDIR}/${P}
+DESCRIPTION="A small web-browser for gnome that uses mozillas render engine"
+SRC_URI="http://download.sourceforge.net/${PN}/${P}.tar.gz
+ mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://galeon.sourceforge.net"
+
+DEPEND="~net-www/mozilla-1.0_rc3
+ >=gnome-base/gnome-libs-1.4.1.4
+ ( >=gnome-base/libglade-0.17
+ <gnome-base/libglade-1.99.0 )
+ ( >=gnome-base/gnome-vfs-1.0
+ <gnome-base/gnome-vfs-1.9.0 )
+ ( >=gnome-base/gconf-1.0
+ <gnome-base/gconf-1.1.0 )
+ >=gnome-base/oaf-0.6.7
+ >=dev-libs/libxml-1.8.16
+ >=media-libs/gdk-pixbuf-0.16.0-r1
+ nls? ( sys-devel/gettext
+ >=dev-util/intltool-0.11 )"
+
+ # bonobo? ( >=gnome-base/bonobo-1.0.19-r1 )
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ # These patches break on this version of galeon.
+ # Are they needed for gcc3/3.1 support?
+ #patch -p1 < ${FILESDIR}/galeon-1.2.0-gcc3.patch || die
+ #patch -p1 < ${FILESDIR}/galeon-1.2.1-gcc3.1.patch || die
+}
+
+src_compile() {
+
+ local myconf
+
+ use nls || myconf="${myconf} --disable-nls"
+ # use bonobo && myconf="${myconf} --enable-gnome-file-selector"
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ --with-mozilla-libs=${MOZILLA_FIVE_HOME} \
+ --with-mozilla-includes=${MOZILLA_FIVE_HOME}/include \
+ --without-debug --disable-werror \
+ --disable-applet \
+ --disable-install-schemas \
+ --enable-nautilus-view=auto \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+
+ # galeon-config-tool was rewritten for 1.2.0 and causes sandbox
+ # violations if gconfd is shut down... The schemas seem to install
+ # fine without it (at least it seems like it... *sigh*)
+ #gconftool --shutdown
+
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ sysconfdir=${D}/etc \
+ localstatedir=${D}/var/lib \
+ install || die
+
+ dodoc AUTHORS ChangeLog COPYING* FAQ NEWS README TODO THANKS
+}
+
+pkg_postinst() {
+
+ galeon-config-tool --fix-gconf-permissions
+ galeon-config-tool --pkg-install-schemas
+ scrollkeeper-update
+
+ if [ -z "`use gnome`" ]
+ then
+ einfo "Please remerge libglade with gnome support, or else galeon"
+ einfo "will not be able to start up."
+ einfo
+ einfo 'To do this, type: '
+ einfo 'USE="gnome" emerge libglade'
+ fi
+}
+