summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Nazaroff <naz@gentoo.org>2002-05-31 08:33:58 +0000
committerMichael Nazaroff <naz@gentoo.org>2002-05-31 08:33:58 +0000
commit8020483c5136a558869f1e9412359f92fa67064a (patch)
tree82ce921f35428b2e39a47c0cccc2fd6a22b742f1 /net-www
parentNew package. Fixes #3031 (diff)
downloadgentoo-2-8020483c5136a558869f1e9412359f92fa67064a.tar.gz
gentoo-2-8020483c5136a558869f1e9412359f92fa67064a.tar.bz2
gentoo-2-8020483c5136a558869f1e9412359f92fa67064a.zip
Updated links with patch to hopefully fix libsvga gpm bug
Diffstat (limited to 'net-www')
-rw-r--r--net-www/links/ChangeLog9
-rw-r--r--net-www/links/links-2.0_pre4-r2.ebuild85
2 files changed, 93 insertions, 1 deletions
diff --git a/net-www/links/ChangeLog b/net-www/links/ChangeLog
index c5f81409b9a9..e8f0b5916eed 100644
--- a/net-www/links/ChangeLog
+++ b/net-www/links/ChangeLog
@@ -1,7 +1,14 @@
# ChangeLog for net-www/links
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-www/links/ChangeLog,v 1.4 2002/05/28 01:02:05 ashmodai Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/links/ChangeLog,v 1.5 2002/05/31 08:33:58 naz Exp $
+*links-2.0_pre4-r2 (29 May 2002)
+
+ 29 May 2002: Michael M Nazaroff <naz@gentoo.org> links-2.0_pre4-r2.ebuild :
+
+ Applied patch that hopefully seems to fix the gpm-1.20.0 problem, and also
+ adds some other little features to links.
+
*links-2.0_pre4-r1 (27 May 2002)
27 May 2002; Mike Jones <ashmodai@gentoo.org> links-2.0_pre4-r1.ebuild :
diff --git a/net-www/links/links-2.0_pre4-r2.ebuild b/net-www/links/links-2.0_pre4-r2.ebuild
new file mode 100644
index 000000000000..e8505f7ea9a1
--- /dev/null
+++ b/net-www/links/links-2.0_pre4-r2.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# Author: Defresne Sylvain (keiichi) <kamisama@free.fr>
+# $Header: /var/cvsroot/gentoo-x86/net-www/links/links-2.0_pre4-r2.ebuild,v 1.1 2002/05/31 08:33:58 naz Exp $
+
+DESCRIPTION="links is a fast lightweight text tand graphic web-browser"
+HOMEPAGE="http://atrey.karlin.mff.cuni.cz/~clock/twibright/links/"
+LICENSE="GPL-2"
+
+# To handle pre-version ...
+MYP="${P/_/}"
+S="${WORKDIR}/${MYP}"
+SRC_URI="${HOMEPAGE}/download/${MYP}.tar.bz2
+ http://www.ibiblio.org/gentoo/distfiles/links-2.0pre4-patch.tar.bz2"
+SLOT="0"
+
+DEPEND="virtual/glibc
+ ssl? ( >=dev-libs/openssl-0.9.6c )
+ gpm? ( sys-libs/gpm )
+ java? ( >=sys-devel/flex-2.5.4a )
+ png? ( >=media-libs/libpng-1.2.1 )
+ jpeg? ( >=media-libs/jpeg-6b )
+ tiff? ( >=media-libs/tiff-3.5.7 )
+ svga? ( >=media-libs/svgalib-1.4.3 )
+ X? ( virtual/x11 )"
+
+src_compile ()
+{
+ local myconf
+
+ use X \
+ && myconf="${myconf} --with-x" \
+ || myconf="${myconf} --without-x"
+
+ use png \
+ && myconf="${myconf} --enable-graphics --with-libpng" \
+ || myconf="${myconf} --disable-graphics --without-libpng"
+
+ use jpeg \
+ && myconf="${myconf} --with-libjpeg" \
+ || myconf="${myconf} --without-libjpeg"
+
+ use tiff \
+ && myconf="${myconf} --with-libtiff" \
+ || myconf="${myconf} --without-libtiff"
+
+ use svga \
+ && myconf="${myconf} --with-svgalib" \
+ || myconf="${myconf} --without-svgalib"
+
+ use fbcon \
+ && myconf="${myconf} --with-fb" \
+ || myconf="${myconf} --without-fb"
+
+ use ssl \
+ && myconf="${myconf} --with-ssl" \
+ || myconf="${myconf} --without-ssl"
+
+ use java \
+ && myconf="${myconf} --enable-javascript" \
+ || myconf="${myconf} --disable-javascript"
+
+ # ./configure only support 'gpm' features auto-detection, so if
+ # 'sys-libs/gpm' is compiled on your system, you'll compile links
+ # with gpm support ...
+ # This patch adds support for various little fix's
+ patch -p1 < ${WORKDIR}/links.patch || die
+
+ econf ${myconf} || die
+ emake || die "make failed"
+}
+
+src_install ()
+{
+ einstall || die "make install failed"
+
+ # Only install links icon if X driver was compiled in ...
+ use X && ( \
+ insinto /usr/share/pixmaps
+ doins graphics/links.xpm
+ )
+
+ dodoc AUTHORS BUGS ChangeLog INSTALL NEWS README SITES TODO
+ dohtml doc/links_cal/*
+}