summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrad Laue <brad@gentoo.org>2003-10-17 05:08:29 +0000
committerBrad Laue <brad@gentoo.org>2003-10-17 05:08:29 +0000
commita567479be00e1efbf6bd4943f2727a62e1e12bd1 (patch)
tree54dbc67950046a3e9917deaa043f0389b6728b70 /net-www
parent*** empty log message *** (diff)
downloadgentoo-2-a567479be00e1efbf6bd4943f2727a62e1e12bd1.tar.gz
gentoo-2-a567479be00e1efbf6bd4943f2727a62e1e12bd1.tar.bz2
gentoo-2-a567479be00e1efbf6bd4943f2727a62e1e12bd1.zip
Import of Mozilla Firebird 0.7
Diffstat (limited to 'net-www')
-rw-r--r--net-www/mozilla-firebird/ChangeLog7
-rw-r--r--net-www/mozilla-firebird/Manifest8
-rw-r--r--net-www/mozilla-firebird/files/digest-mozilla-firebird-0.71
-rw-r--r--net-www/mozilla-firebird/mozilla-firebird-0.7.ebuild241
4 files changed, 253 insertions, 4 deletions
diff --git a/net-www/mozilla-firebird/ChangeLog b/net-www/mozilla-firebird/ChangeLog
index 99638a5169df..68300f0d63b7 100644
--- a/net-www/mozilla-firebird/ChangeLog
+++ b/net-www/mozilla-firebird/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-www/mozilla-firebird
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-firebird/ChangeLog,v 1.19 2003/09/12 23:11:09 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-firebird/ChangeLog,v 1.20 2003/10/17 05:08:26 brad Exp $
+
+*mozilla-firebird-0.7 (17 Oct 2003)
+
+ 17 Oct 2003; Brad Laue <brad@gentoo.org> mozilla-firebird-0.7.ebuild:
+ Introducing Mozilla Firebird 0.7 - warm up your compilers!
12 Sep 2003; Luca Barbato <lu_zero@gentoo.org> mozilla-firebird-0.6.1.ebuild:
Added a ppc related fix
diff --git a/net-www/mozilla-firebird/Manifest b/net-www/mozilla-firebird/Manifest
index fdeffdd479f6..fa83f1be2cfd 100644
--- a/net-www/mozilla-firebird/Manifest
+++ b/net-www/mozilla-firebird/Manifest
@@ -1,8 +1,10 @@
-MD5 f83c8755e78fd74930dd06fe58119f70 ChangeLog 3430
+MD5 ce23390351fe8020387d93ee29e09a3d metadata.xml 160
+MD5 6037a98641c0329f978777bec6b506e7 ChangeLog 3598
MD5 2501d008f329dab622fdc45ce9377a65 mozilla-firebird-0.6-r7.ebuild 6759
MD5 ac196a385be977b279e643cfbebab064 mozilla-firebird-0.6.1.ebuild 6881
-MD5 ce23390351fe8020387d93ee29e09a3d metadata.xml 160
+MD5 04c3615033d50f84cb232e0b8897a5ba mozilla-firebird-0.7.ebuild 6770
MD5 6e4352482ed149b3b9aca78d83de1124 files/MozillaFirebird 753
+MD5 23d1fbd03cc6dd346a4e4ce8f2d88ebf files/mozilla-1.3-alpha-stubs.patch 4646
MD5 78b9eef353e1aff29cef379e4de6b9fa files/digest-mozilla-firebird-0.6-r7 81
MD5 49802181a2284102bb2ed6daab129bb5 files/digest-mozilla-firebird-0.6.1 83
-MD5 23d1fbd03cc6dd346a4e4ce8f2d88ebf files/mozilla-1.3-alpha-stubs.patch 4646
+MD5 d6389059d144d92d25b21b5cb3727cb0 files/digest-mozilla-firebird-0.7 80
diff --git a/net-www/mozilla-firebird/files/digest-mozilla-firebird-0.7 b/net-www/mozilla-firebird/files/digest-mozilla-firebird-0.7
new file mode 100644
index 000000000000..76859698194a
--- /dev/null
+++ b/net-www/mozilla-firebird/files/digest-mozilla-firebird-0.7
@@ -0,0 +1 @@
+MD5 35112566a3dca5bdf363972056afc462 MozillaFirebird-source-0.7.tar.gz 38758572
diff --git a/net-www/mozilla-firebird/mozilla-firebird-0.7.ebuild b/net-www/mozilla-firebird/mozilla-firebird-0.7.ebuild
new file mode 100644
index 000000000000..7bc31e9ebf99
--- /dev/null
+++ b/net-www/mozilla-firebird/mozilla-firebird-0.7.ebuild
@@ -0,0 +1,241 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-firebird/mozilla-firebird-0.7.ebuild,v 1.1 2003/10/17 05:08:26 brad Exp $
+
+inherit makeedit flag-o-matic gcc nsplugins eutils
+
+# Added to get MozillaFirebird to compile on sparc.
+replace-sparc64-flags
+if [ "`use ppc`" -a "$(gcc-major-version)" -eq "3" -a "$(gcc-minor-version)" -eq "3" ]
+then
+
+append-flags -fno-strict-aliasing
+
+fi
+
+
+S=${WORKDIR}/mozilla
+
+DESCRIPTION="The Mozilla Firebird Web Browser"
+HOMEPAGE="http://www.mozilla.org/projects/firebird/"
+SRC_URI="http://ftp.mozilla.org/pub/firebird/releases/${PV}/MozillaFirebird-source-${PV}.tar.gz"
+
+KEYWORDS="x86 ppc sparc alpha"
+SLOT="0"
+LICENSE="MPL-1.1 | NPL-1.1"
+IUSE="java gtk2 ipv6 gnome moznoxft"
+
+RDEPEND="virtual/x11
+ >=dev-libs/libIDL-0.8.0
+ >=gnome-base/ORBit-0.5.10-r1
+ virtual/xft
+ >=sys-libs/zlib-1.1.4
+ >=media-libs/jpeg-6b
+ >=media-libs/libmng-1.0.0
+ >=media-libs/libpng-1.2.1
+ >=sys-apps/portage-2.0.36
+ dev-libs/expat
+ app-arch/zip
+ app-arch/unzip
+ ( gtk2? >=x11-libs/gtk+-2.1.1 :
+ =x11-libs/gtk+-1.2* )
+ java? ( virtual/jre )
+ !net-www/mozilla-firebird-bin
+ !net-www/mozilla-firebird-cvs"
+
+DEPEND="${RDEPEND}
+ virtual/glibc
+ dev-lang/perl
+ java? ( >=dev-java/java-config-0.2.0 )"
+
+# needed by src_compile() and src_install()
+export MOZ_PHOENIX=1
+export MOZ_CALENDAR=0
+export MOZ_ENABLE_XFT=1
+
+src_unpack() {
+ unpack MozillaFirebird-source-${PV}.tar.gz
+
+ # alpha stubs patch from lfs project.
+ # <taviso@gentoo.org> (26 Jun 2003)
+ use alpha && epatch ${FILESDIR}/mozilla-1.3-alpha-stubs.patch
+
+}
+
+src_compile() {
+ local myconf="--disable-composer \
+ --with-x \
+ --with-system-jpeg \
+ --with-system-zlib \
+ --with-system-png \
+ --with-system-mng \
+ --disable-mailnews \
+ --disable-calendar \
+ --disable-pedantic \
+ --disable-svg \
+ --enable-mathml \
+ --without-system-nspr \
+ --enable-nspr-autoconf \
+ --enable-xsl \
+ --enable-crypto \
+ --enable-xinerama=no \
+ --with-java-supplement \
+ --with-pthreads \
+ --with-default-mozilla-five-home=/usr/lib/MozillaFirebird \
+ --with-user-appdir=.phoenix \
+ --disable-jsd \
+ --disable-accessibility \
+ --disable-tests \
+ --disable-debug \
+ --disable-dtd-debug \
+ --disable-logging \
+ --enable-reorder \
+ --enable-strip \
+ --enable-strip-libs \
+ --enable-cpp-rtti \
+ --enable-xterm-updates \
+ --enable-optimize=-O2 \
+ --disable-ldap \
+ --disable-toolkit-qt \
+ --disable-toolkit-xlib \
+ --enable-extensions=default,-inspector,-irc,-venkman,-content-packs,-help"
+
+ if [ -n "`use gtk2`" ] ; then
+ myconf="${myconf} --enable-toolkit-gtk2 \
+ --enable-default-toolkit=gtk2 \
+ --disable-toolkit-gtk"
+ else
+ myconf="${myconf} --enable-toolkit-gtk \
+ --enable-default-toolkit=gtk \
+ --disable-toolkit-gtk2"
+ fi
+
+ if [ -z "`use moznoxft`" ]
+ then
+ if [ -n "`use gtk2`" ]
+ then
+ local pango_version=""
+
+ # We need Xft2.0 localy installed
+ if (test -x /usr/bin/pkg-config) && (pkg-config xft)
+ then
+ pango_version="`pkg-config --modversion pango | cut -d. -f1,2`"
+ pango_version="`echo ${pango_version} | sed -e 's:\.::g'`"
+
+ # We also need pango-1.1, else Mozilla links to both
+ # Xft1.1 *and* Xft2.0, and segfault...
+ if [ "${pango_version}" -gt "10" ]
+ then
+ einfo "Building with Xft2.0 (Gtk+-2.0) support!"
+ myconf="${myconf} --enable-xft --disable-freetype2"
+ touch ${WORKDIR}/.xft
+ else
+ ewarn "Building without Xft2.0 support!"
+ myconf="${myconf} --disable-xft `use_enable truetype freetype2`"
+ fi
+ else
+ ewarn "Building without Xft2.0 support!"
+ myconf="${myconf} --disable-xft `use_enable truetype freetype2`"
+ fi
+ else
+ einfo "Building with Xft2.0 (Gtk+-1.0) support!"
+ myconf="${myconf} --enable-xft --disable-freetype2"
+ touch ${WORKDIR}/.xft
+ fi
+ else
+ myconf="${myconf} --disable-xft `use_enable truetype freetype2`"
+ fi
+
+ if [ -n "`use ipv6`" ] ; then
+ myconf="${myconf} --enable-ipv6"
+ fi
+
+ # Crashes on start when compiled with -fomit-frame-pointer
+ filter-flags -fomit-frame-pointer
+ filter-flags -ffast-math
+ append-flags -s -fforce-addr
+
+ if [ "$(gcc-major-version)" -eq "3" ]; then
+ # Currently gcc-3.2 or older do not work well if we specify "-march"
+ # and other optimizations for pentium4.
+ if [ "$(gcc-minor-version)" -lt "3" ]; then
+ replace-flags -march=pentium4 -march=pentium3
+ filter-flags -msse2
+ fi
+
+ # Enable us to use flash, etc plugins compiled with gcc-2.95.3
+ if [ "${ARCH}" = "x86" ]; then
+ myconf="${myconf} --enable-old-abi-compat-wrappers"
+ fi
+ fi
+
+ econf ${myconf} || die
+
+ edit_makefiles
+ emake MOZ_PHOENIX=1 || die
+}
+
+src_install() {
+ # Plugin path creation
+ PLUGIN_DIR="/usr/lib/nsbrowser/plugins"
+ dodir ${PLUGIN_DIR}
+
+ dodir /usr/lib
+ dodir /usr/lib/MozillaFirebird
+ cp -RL --no-preserve=links ${S}/dist/bin/* ${D}/usr/lib/MozillaFirebird
+
+ #fix permissions
+ chown -R root.root ${D}/usr/lib/MozillaFirebird
+
+ # Plugin path setup (rescuing the existent plugins)
+ src_mv_plugins /usr/lib/MozillaFirebird/plugins
+
+ dobin ${FILESDIR}/MozillaFirebird
+
+ # Fix icons to look the same everywhere
+ insinto /usr/lib/MozillaFirebird/icons
+ doins ${S}/build/package/rpm/SOURCES/mozicon16.xpm
+ doins ${S}/build/package/rpm/SOURCES/mozicon50.xpm
+
+ # Install icon and .desktop for menu entry
+ if [ "`use gnome`" ]
+ then
+ insinto /usr/share/pixmaps
+ doins ${S}/build/package/rpm/SOURCES/mozilla-icon.png
+
+ # Fix comment of menu entry
+ cd ${S}/build/package/rpm/SOURCES
+ cp mozilla.desktop mozillafirebird.desktop
+ perl -pi -e 's:Name=Mozilla:Name=Mozilla Firebird:' mozillafirebird.desktop
+ perl -pi -e 's:Comment=Mozilla:Comment=Mozilla Firebird Web Browser:' mozillafirebird.desktop
+ perl -pi -e 's:Exec=/usr/bin/mozilla:Exec=/usr/bin/MozillaFirebird:' mozillafirebird.desktop
+ cd ${S}
+ insinto /usr/share/gnome/apps/Internet
+ doins ${S}/build/package/rpm/SOURCES/mozillafirebird.desktop
+ fi
+}
+
+pkg_preinst() {
+ # Remove the old plugins dir
+ pkg_mv_plugins /usr/lib/MozillaFirebird/plugins
+}
+
+pkg_postinst() {
+
+ export MOZILLA_FIVE_HOME="${ROOT}/usr/lib/MozillaFirebird"
+
+ # Needed to update the run time bindings for REGXPCOM
+ # (do not remove next line!)
+ env-update
+ # Register Components and Chrome
+ einfo "Registering Components and Chrome..."
+ LD_LIBRARY_PATH=/usr/lib/MozillaFirebird ${MOZILLA_FIVE_HOME}/regxpcom
+ LD_LIBRARY_PATH=/usr/lib/MozillaFirebird ${MOZILLA_FIVE_HOME}/regchrome
+ # Fix permissions of component registry
+ chmod 0644 ${MOZILLA_FIVE_HOME}/components/compreg.dat
+ # Fix directory permissions
+ find ${MOZILLA_FIVE_HOME}/ -type d -perm 0700 -exec chmod 0755 {} \; || :
+ # Fix permissions on chrome files
+ find ${MOZILLA_FIVE_HOME}/chrome/ -name '*.rdf' -exec chmod 0644 {} \; || :
+
+}