summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Nigbur <pyrania@gentoo.org>2003-11-01 20:49:30 +0000
committerMarkus Nigbur <pyrania@gentoo.org>2003-11-01 20:49:30 +0000
commitc6eea38340466bd6ea0daf96baa386191074eeb9 (patch)
tree369296088904e743774ca745a9a65bfe435c88a2 /net-www
parentmany changes to handling of useflags and dependencies (diff)
downloadgentoo-2-c6eea38340466bd6ea0daf96baa386191074eeb9.tar.gz
gentoo-2-c6eea38340466bd6ea0daf96baa386191074eeb9.tar.bz2
gentoo-2-c6eea38340466bd6ea0daf96baa386191074eeb9.zip
Version bump. Thanks to Thomas Eckert (#32454).
Diffstat (limited to 'net-www')
-rw-r--r--net-www/pound/ChangeLog8
-rw-r--r--net-www/pound/Manifest6
-rw-r--r--net-www/pound/files/digest-pound-1.51
-rw-r--r--net-www/pound/metadata.xml5
-rw-r--r--net-www/pound/pound-1.5.ebuild60
5 files changed, 77 insertions, 3 deletions
diff --git a/net-www/pound/ChangeLog b/net-www/pound/ChangeLog
index b7ba9139f57e..69c2357b8ed0 100644
--- a/net-www/pound/ChangeLog
+++ b/net-www/pound/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-www/pound
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/pound/ChangeLog,v 1.2 2003/08/03 06:49:53 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/pound/ChangeLog,v 1.3 2003/11/01 20:49:30 pyrania Exp $
+
+*pound-1.5 (01 Nov 2003)
+
+ 01 Nov 2003; Markus Nigbur <pyrania@gentoo.org> metadata.xml,
+ pound-1.5.ebuild:
+ Version bump. Thanks to Thomas Eckert (#32454).
*pound-1.4 (02 Aug 2003)
diff --git a/net-www/pound/Manifest b/net-www/pound/Manifest
index a6a9200df956..02d65fa746db 100644
--- a/net-www/pound/Manifest
+++ b/net-www/pound/Manifest
@@ -1,5 +1,7 @@
-MD5 7e6edb47d6fae33b62516cdaa835c842 ChangeLog 394
+MD5 4ae3fa54844e91ce95b6e63c7792a547 pound-1.5.ebuild 1372
MD5 4ae3fa54844e91ce95b6e63c7792a547 pound-1.4.ebuild 1372
+MD5 7e6edb47d6fae33b62516cdaa835c842 ChangeLog 394
+MD5 2e471aa35129f6523583abbd87084bc5 files/pound.init 633
MD5 ea7096804d2dc2e498de690fa440821d files/digest-pound-1.4 58
+MD5 bc58884d636c60affb0267730438d6d9 files/digest-pound-1.5 58
MD5 4c7b6277bb33061b615ac9059c74cf62 files/pound.cfg 830
-MD5 2e471aa35129f6523583abbd87084bc5 files/pound.init 633
diff --git a/net-www/pound/files/digest-pound-1.5 b/net-www/pound/files/digest-pound-1.5
new file mode 100644
index 000000000000..d825e95482ed
--- /dev/null
+++ b/net-www/pound/files/digest-pound-1.5
@@ -0,0 +1 @@
+MD5 e838381f7fb49136c531895a0e93c31d Pound-1.5.tgz 120219
diff --git a/net-www/pound/metadata.xml b/net-www/pound/metadata.xml
new file mode 100644
index 000000000000..95c06f0095bb
--- /dev/null
+++ b/net-www/pound/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>web-apps</herd>
+</pkgmetadata>
diff --git a/net-www/pound/pound-1.5.ebuild b/net-www/pound/pound-1.5.ebuild
new file mode 100644
index 000000000000..9a10e707e527
--- /dev/null
+++ b/net-www/pound/pound-1.5.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/pound/pound-1.5.ebuild,v 1.1 2003/11/01 20:49:30 pyrania Exp $
+
+MY_P=${P/p/P}
+
+DESCRIPTION="A http/https reverse-proxy and load-balancer."
+SRC_URI="http://www.apsis.ch/pound/${MY_P}.tgz"
+HOMEPAGE="http://www.apsis.ch/pound/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa"
+IUSE="ssl"
+
+DEPEND="virtual/glibc
+ ssl? ( dev-libs/openssl )"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ local myconf
+
+ ## check for ssl-support:
+ if [ "$(use ssl)" ]; then
+ myconf="${myconf} --with-ssl"
+ else
+ myconf="${myconf} --without-ssl"
+ fi
+
+ ## TODO: how to handle the missing "syslog" USE-flag?
+ ## check for syslog-support:
+ #if [ "$(use syslog)" ]; then
+ # myconf="${myconf} --with-log="
+ #else
+ # myconf="${myconf} --without-log"
+ #fi
+
+ econf ${myconf} || die "configure failed"
+ emake || die "compile failed"
+}
+
+src_install() {
+ dosbin pound
+ doman pound.8
+
+ dodoc README
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/pound.init pound
+
+ insinto /etc
+ doins ${FILESDIR}/pound.cfg
+}
+
+pkg_postinst() {
+ einfo "No demo-/sample-configfile is included in the distribution -- read the man-page"
+ einfo "for more info."
+ einfo "A sample (localhost:8888 -> localhost:80) for gentoo is given in \"/etc/pound.cfg\"."
+}