summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2006-12-19 15:24:53 +0000
committerJoseph Jezak <josejx@gentoo.org>2006-12-19 15:24:53 +0000
commitd7f5355248dee833a9c7cb08e0c2c0434312917a (patch)
tree27cca10ed139ca2c41df93945b313b332ff00f83 /net-www
parentAdd the ECW Public Licence (diff)
downloadgentoo-2-d7f5355248dee833a9c7cb08e0c2c0434312917a.tar.gz
gentoo-2-d7f5355248dee833a9c7cb08e0c2c0434312917a.tar.bz2
gentoo-2-d7f5355248dee833a9c7cb08e0c2c0434312917a.zip
Added latest version and patch for building with -gtk.
(Portage version: 2.1.2_rc3-r5)
Diffstat (limited to 'net-www')
-rw-r--r--net-www/mplayerplug-in/ChangeLog8
-rw-r--r--net-www/mplayerplug-in/files/digest-mplayerplug-in-3.353
-rw-r--r--net-www/mplayerplug-in/files/mplayerplug-in-3.35-X.patch12
-rw-r--r--net-www/mplayerplug-in/mplayerplug-in-3.35.ebuild95
4 files changed, 117 insertions, 1 deletions
diff --git a/net-www/mplayerplug-in/ChangeLog b/net-www/mplayerplug-in/ChangeLog
index 8effe2701a35..7a5cdb20709b 100644
--- a/net-www/mplayerplug-in/ChangeLog
+++ b/net-www/mplayerplug-in/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-www/mplayerplug-in
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mplayerplug-in/ChangeLog,v 1.80 2006/11/01 20:07:27 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mplayerplug-in/ChangeLog,v 1.81 2006/12/19 15:24:53 josejx Exp $
+
+*mplayerplug-in-3.35 (19 Dec 2006)
+
+ 19 Dec 2006; Joseph Jezak <josejx@gentoo.org>
+ +files/mplayerplug-in-3.35-X.patch, +mplayerplug-in-3.35.ebuild:
+ Added latest version and patch for building with -gtk.
01 Nov 2006; Joseph Jezak <josejx@gentoo.org>
mplayerplug-in-3.31-r1.ebuild:
diff --git a/net-www/mplayerplug-in/files/digest-mplayerplug-in-3.35 b/net-www/mplayerplug-in/files/digest-mplayerplug-in-3.35
new file mode 100644
index 000000000000..bd1e68c973cf
--- /dev/null
+++ b/net-www/mplayerplug-in/files/digest-mplayerplug-in-3.35
@@ -0,0 +1,3 @@
+MD5 5efa01fa433ee4c7118e534c36198e72 mplayerplug-in-3.35.tar.gz 217776
+RMD160 fea5640a5931af93cc85907b219a3765f79f4a51 mplayerplug-in-3.35.tar.gz 217776
+SHA256 bc91513b874716ee30d73cf48d2571e4537fb6a42498d6ecccc91259ad15ad7f mplayerplug-in-3.35.tar.gz 217776
diff --git a/net-www/mplayerplug-in/files/mplayerplug-in-3.35-X.patch b/net-www/mplayerplug-in/files/mplayerplug-in-3.35-X.patch
new file mode 100644
index 000000000000..a3dade8d8572
--- /dev/null
+++ b/net-www/mplayerplug-in/files/mplayerplug-in-3.35-X.patch
@@ -0,0 +1,12 @@
+--- Source/plugin-threads.cpp.bak 2006-12-19 09:24:36.000000000 -0500
++++ Source/plugin-threads.cpp 2006-12-19 09:25:11.000000000 -0500
+@@ -1068,7 +1068,9 @@
+ if (DEBUG)
+ printf("Volume = %i\n",
+ local_td->instance->volume);
++#ifdef GTK_ENABLED
+ g_idle_add(gtkgui_setvolumetip,local_td->instance);
++#endif
+ }
+
+ pthread_testcancel();
diff --git a/net-www/mplayerplug-in/mplayerplug-in-3.35.ebuild b/net-www/mplayerplug-in/mplayerplug-in-3.35.ebuild
new file mode 100644
index 000000000000..b0946b2f7c6a
--- /dev/null
+++ b/net-www/mplayerplug-in/mplayerplug-in-3.35.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mplayerplug-in/mplayerplug-in-3.35.ebuild,v 1.1 2006/12/19 15:24:53 josejx Exp $
+
+inherit eutils multilib nsplugins
+
+DESCRIPTION="mplayer plug-in for Gecko based browsers"
+HOMEPAGE="http://mplayerplug-in.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 -hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE="gtk divx gmedia realmedia quicktime wmp"
+
+DEPEND=">=media-video/mplayer-1.0_pre5
+ || ( www-client/mozilla-firefox
+ www-client/seamonkey
+ )
+ || ( ( x11-libs/libXpm
+ x11-proto/xextproto
+ )
+ virtual/x11
+ )
+ gtk? (
+ >=x11-libs/gtk+-2.2.0
+ dev-libs/atk
+ >=dev-libs/glib-2.2.0
+ >=x11-libs/pango-1.2.1
+ )
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/3.30-fix-cflags.patch
+ epatch ${FILESDIR}/${PN}-gcc4.patch
+ epatch ${FILESDIR}/${P}-X.patch
+}
+
+src_compile() {
+ local myconf
+
+ # We force gtk2 now because moz only compiles against gtk2
+ if use gtk; then
+ myconf="${myconf} --enable-gtk2"
+ else
+ ewarn "For playback controls, you must enable gtk support."
+ myconf="${myconf} --enable-x"
+ fi
+
+ # Media Playback Support (bug #145517)
+ econf \
+ ${myconf} \
+ $(use_enable divx dvx) \
+ $(use_enable gmedia gmp) \
+ $(use_enable realmedia rm) \
+ $(use_enable quicktime qt) \
+ $(use_enable wmp) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ exeinto /opt/netscape/plugins
+ doexe mplayerplug-in.so || die "plugin failed"
+ inst_plugin /opt/netscape/plugins/mplayerplug-in.so
+
+ insinto /opt/netscape/plugins
+ doins mplayerplug-in.xpt || die "xpt failed"
+ inst_plugin /opt/netscape/plugins/mplayerplug-in.xpt
+
+ PLUGINS="gmp rm qt wmp dvx"
+
+ for plugin in ${PLUGINS}; do
+ if [ -e "mplayerplug-in-${plugin}.so" ]; then
+ ### Install the plugin
+ exeinto /opt/netscape/plugins
+ doexe "mplayerplug-in-${plugin}.so" || die "plugin ${plugin} failed"
+ inst_plugin "/opt/netscape/plugins/mplayerplug-in-${plugin}.so"
+ ### Install the xpt
+ insinto /opt/netscape/plugins
+ doins "mplayerplug-in-${plugin}.xpt" || die "plugin ${plugin} xpt failed"
+ inst_plugin "/opt/netscape/plugins/mplayerplug-in-${plugin}.xpt"
+ fi
+ done
+
+ insinto /etc
+ doins mplayerplug-in.conf
+
+ dodoc ChangeLog INSTALL README DOCS/tech/*.txt
+}