summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Jackson <iggy@gentoo.org>2004-02-11 08:26:34 +0000
committerBrian Jackson <iggy@gentoo.org>2004-02-11 08:26:34 +0000
commitdc9722ada6a02133c6f8255231f884bc408382b4 (patch)
treeb670b29a1bb56f957c9614155c00f5fc3c3fec1d /net-www
parentheader fix; IUSE fix; DEPEND fix; hppa needs deps first (Manifest recommit) (diff)
downloadgentoo-2-dc9722ada6a02133c6f8255231f884bc408382b4.tar.gz
gentoo-2-dc9722ada6a02133c6f8255231f884bc408382b4.tar.bz2
gentoo-2-dc9722ada6a02133c6f8255231f884bc408382b4.zip
version bump
Diffstat (limited to 'net-www')
-rw-r--r--net-www/lynx/ChangeLog7
-rw-r--r--net-www/lynx/files/digest-lynx-2.8.51
-rw-r--r--net-www/lynx/lynx-2.8.5.ebuild74
3 files changed, 81 insertions, 1 deletions
diff --git a/net-www/lynx/ChangeLog b/net-www/lynx/ChangeLog
index 6acdd9814463..b5ca32cdf3b9 100644
--- a/net-www/lynx/ChangeLog
+++ b/net-www/lynx/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-www/lynx
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/lynx/ChangeLog,v 1.26 2004/02/10 15:07:51 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/lynx/ChangeLog,v 1.27 2004/02/11 08:26:18 iggy Exp $
+
+*lynx-2.8.5 (11 Feb 2004)
+
+ 11 Feb 2004; Brian Jackson <iggy@gentoo.org> lynx-2.8.5.ebuild:
+ version bump
10 Feb 2004; Gustavo Zacarias <gustavoz@gentoo.org> lynx-2.8.4.1d-r1.ebuild:
stable on sparc
diff --git a/net-www/lynx/files/digest-lynx-2.8.5 b/net-www/lynx/files/digest-lynx-2.8.5
new file mode 100644
index 000000000000..5508fae56078
--- /dev/null
+++ b/net-www/lynx/files/digest-lynx-2.8.5
@@ -0,0 +1 @@
+MD5 d1e5134e5d175f913c16cb6768bc30eb lynx2.8.5.tar.bz2 2177287
diff --git a/net-www/lynx/lynx-2.8.5.ebuild b/net-www/lynx/lynx-2.8.5.ebuild
new file mode 100644
index 000000000000..05eb47ddb7a0
--- /dev/null
+++ b/net-www/lynx/lynx-2.8.5.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/lynx/lynx-2.8.5.ebuild,v 1.1 2004/02/11 08:26:20 iggy Exp $
+
+IUSE="ssl nls ipv6"
+
+#MY_PV=${PV/.1d/rel.1}
+S=${WORKDIR}/${PN}${PV//./-}
+DESCRIPTION="An excellent console-based web browser with ssl support"
+HOMEPAGE="http://lynx.browser.org/"
+SRC_URI="ftp://lynx.isc.org/lynx/${PN}2.8.5/${PN}${PV}.tar.bz2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~mips ~ia64 ~amd64"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND=">=sys-libs/ncurses-5.1
+ >=sys-libs/zlib-1.1.3
+ nls? ( sys-devel/gettext )
+ ssl? ( >=dev-libs/openssl-0.9.6 )"
+
+PROVIDE="virtual/textbrowser"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # GCC3.1 support -- check if it's really needed in
+ # future. Some users report complete success with -r3 --
+ # credit to lostlogix and carpaski. Resolves #3172
+# epatch ${FILESDIR}/${P}-gentoo.patch
+}
+
+src_compile() {
+ local myconf
+ use nls && myconf="${myconf} --enable-nls"
+ use ssl && myconf="${myconf} --with-ssl=yes"
+ use ipv6 && myconf="${myconf} --enable-ipv6"
+
+ CFLAGS="${CFLAGS} -DANSI_VARARGS"
+
+ econf \
+ --libdir=/etc/lynx \
+ --enable-cgi-links \
+ --enable-prettysrc \
+ --enable-nsl-fork \
+ --enable-file-upload \
+ --enable-read-eta \
+ --enable-libjs \
+ --enable-color-style \
+ --enable-scrollbar \
+ --enable-included-msgs \
+ --with-zlib \
+ ${myconf} || die
+
+ emake || die "compile problem"
+}
+
+src_install() {
+ make prefix=${D}/usr datadir=${D}/usr/share mandir=${D}/usr/share/man \
+ libdir=${D}/etc/lynx install || die
+
+ dosed "s|^HELPFILE.*$|HELPFILE:file://localhost/usr/share/doc/${PF}/lynx_help/lynx_help/lynx_help_main.html|" \
+ /etc/lynx/lynx.cfg
+ dodoc CHANGES COPYHEADER COPYING INSTALLATION PROBLEMS README
+ docinto docs
+ dodoc docs/*
+ docinto lynx_help
+ dodoc lynx_help/*.txt
+ dohtml -r lynx_help
+
+ # small little manpage glitch
+ rm ${D}/usr/share/man/lynx.1
+ newman lynx.man lynx.1
+}