summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrad Laue <brad@gentoo.org>2005-03-23 07:33:49 +0000
committerBrad Laue <brad@gentoo.org>2005-03-23 07:33:49 +0000
commitdfacb05d1ff7fb85dd16554061eafe2665c0525e (patch)
treef99a44cb4ab64c404cb688b9cf470b6a45154c01 /net-www
parentmark stable (diff)
downloadgentoo-2-dfacb05d1ff7fb85dd16554061eafe2665c0525e.tar.gz
gentoo-2-dfacb05d1ff7fb85dd16554061eafe2665c0525e.tar.bz2
gentoo-2-dfacb05d1ff7fb85dd16554061eafe2665c0525e.zip
Renaming stackgrowth patch
Diffstat (limited to 'net-www')
-rw-r--r--net-www/mozilla/ChangeLog6
-rw-r--r--net-www/mozilla/files/mozilla-stackgrowth.patch37
-rw-r--r--net-www/mozilla/mozilla-1.7.5-r1.ebuild4
-rw-r--r--net-www/mozilla/mozilla-1.7.5.ebuild4
4 files changed, 46 insertions, 5 deletions
diff --git a/net-www/mozilla/ChangeLog b/net-www/mozilla/ChangeLog
index ce1622cb1871..0f3884ec38c9 100644
--- a/net-www/mozilla/ChangeLog
+++ b/net-www/mozilla/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-www/mozilla
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/ChangeLog,v 1.225 2005/03/16 06:27:44 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/ChangeLog,v 1.226 2005/03/23 07:33:49 brad Exp $
+
+ 23 Mar 2005; Brad Laue <brad@gentoo.org> +files/mozilla-stackgrowth.patch,
+ mozilla-1.7.5-r1.ebuild, mozilla-1.7.5.ebuild:
+ Change patchname of stackgrowth-patch for simplicity.
16 Mar 2005; Jeremy Huddleston <eradicator@gentoo.org>
mozilla-1.7.5-r1.ebuild:
diff --git a/net-www/mozilla/files/mozilla-stackgrowth.patch b/net-www/mozilla/files/mozilla-stackgrowth.patch
new file mode 100644
index 000000000000..af226b28ed9c
--- /dev/null
+++ b/net-www/mozilla/files/mozilla-stackgrowth.patch
@@ -0,0 +1,37 @@
+--- js/src/jscpucfg.c 15 Nov 2003 00:10:56 -0000 3.21
++++ js/src/jscpucfg.c 22 Oct 2004 05:45:36 -0000
+@@ -153,19 +153,34 @@ static int Log2(unsigned int n)
+ */
+ static void BitsPerByte(void)
+ {
+ bpb = 8;
+ }
+
++#ifdef __GNUC__
++#if (__GNUC__ > 2)
++__attribute__((noinline))
++#endif
++static int StackGrowthDirection(int *dummy1addr)
++{
++ int *dummy2 = alloca (sizeof (int));
++
++ return (dummy2 < dummy1addr) ? -1 : 1;
++}
++
++#else /* __GNUC__ */
++
+ static int StackGrowthDirection(int *dummy1addr)
+ {
+ int dummy2;
+
+ return (&dummy2 < dummy1addr) ? -1 : 1;
+ }
+
++#endif /* __GNUC__ */
++
+ int main(int argc, char **argv)
+ {
+ int sizeof_char, sizeof_short, sizeof_int, sizeof_int64, sizeof_long,
+ sizeof_float, sizeof_double, sizeof_word, sizeof_dword;
+ int bits_per_int64_log2, align_of_short, align_of_int, align_of_long,
+ align_of_int64, align_of_float, align_of_double, align_of_pointer,
diff --git a/net-www/mozilla/mozilla-1.7.5-r1.ebuild b/net-www/mozilla/mozilla-1.7.5-r1.ebuild
index 2b920cf4d596..0f30b24aaf9b 100644
--- a/net-www/mozilla/mozilla-1.7.5-r1.ebuild
+++ b/net-www/mozilla/mozilla-1.7.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/mozilla-1.7.5-r1.ebuild,v 1.3 2005/03/16 06:27:44 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/mozilla-1.7.5-r1.ebuild,v 1.4 2005/03/23 07:33:49 brad Exp $
unset ALLOWED_FLAGS # stupid extra-functions.sh ... bug 49179
inherit flag-o-matic gcc eutils nsplugins mozilla-launcher mozconfig makeedit multilib
@@ -57,7 +57,7 @@ src_unpack() {
fi
# Fix stack growth logic
- epatch ${FILESDIR}/${P}-stackgrowth.patch
+ epatch ${FILESDIR}/${PN}-stackgrowth.patch
# Fix logic error when using RAW target
# <azarah@gentoo.org> (23 Feb 2003)
diff --git a/net-www/mozilla/mozilla-1.7.5.ebuild b/net-www/mozilla/mozilla-1.7.5.ebuild
index 7da30ac6d091..dcf156f1b7cf 100644
--- a/net-www/mozilla/mozilla-1.7.5.ebuild
+++ b/net-www/mozilla/mozilla-1.7.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/mozilla-1.7.5.ebuild,v 1.12 2005/02/27 09:15:55 brad Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/mozilla-1.7.5.ebuild,v 1.13 2005/03/23 07:33:49 brad Exp $
unset ALLOWED_FLAGS # stupid extra-functions.sh ... bug 49179
inherit flag-o-matic gcc eutils nsplugins mozilla-launcher mozconfig makeedit
@@ -56,7 +56,7 @@ src_unpack() {
fi
# Fix stack growth logic
- epatch ${FILESDIR}/${P}-stackgrowth.patch
+ epatch ${FILESDIR}/${PN}-stackgrowth.patch
# Fix logic error when using RAW target
# <azarah@gentoo.org> (23 Feb 2003)