summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2007-02-27 03:51:30 +0000
committerJoseph Jezak <josejx@gentoo.org>2007-02-27 03:51:30 +0000
commiteb1a1c76db24a33bc146af684c08edef41193a80 (patch)
tree9962fb12c3b8b2f03e1634a344ad233e9fc980ac /net-www
parentamd64 stable, security bug 167643 (diff)
downloadgentoo-2-eb1a1c76db24a33bc146af684c08edef41193a80.tar.gz
gentoo-2-eb1a1c76db24a33bc146af684c08edef41193a80.tar.bz2
gentoo-2-eb1a1c76db24a33bc146af684c08edef41193a80.zip
Marked 3.35 ppc stable and aded a compile fix for firefox (bug #168275).
(Portage version: 2.1.2-r11)
Diffstat (limited to 'net-www')
-rw-r--r--net-www/mplayerplug-in/ChangeLog8
-rw-r--r--net-www/mplayerplug-in/files/mplayerplug-in-3.31-firefox.patch57
-rw-r--r--net-www/mplayerplug-in/files/mplayerplug-in-3.35-firefox.patch57
-rw-r--r--net-www/mplayerplug-in/mplayerplug-in-3.31-r1.ebuild5
-rw-r--r--net-www/mplayerplug-in/mplayerplug-in-3.35.ebuild5
5 files changed, 127 insertions, 5 deletions
diff --git a/net-www/mplayerplug-in/ChangeLog b/net-www/mplayerplug-in/ChangeLog
index 6b89654f37e3..f84292a1d5f8 100644
--- a/net-www/mplayerplug-in/ChangeLog
+++ b/net-www/mplayerplug-in/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-www/mplayerplug-in
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mplayerplug-in/ChangeLog,v 1.82 2007/01/22 19:12:40 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mplayerplug-in/ChangeLog,v 1.83 2007/02/27 03:51:30 josejx Exp $
+
+ 27 Feb 2007; Joseph Jezak <josejx@gentoo.org>
+ +files/mplayerplug-in-3.31-firefox.patch,
+ +files/mplayerplug-in-3.35-firefox.patch, mplayerplug-in-3.31-r1.ebuild,
+ mplayerplug-in-3.35.ebuild:
+ Marked 3.35 ppc stable and added a compile fix for firefox (bug #168275).
22 Jan 2007; Gustavo Zacarias <gustavoz@gentoo.org>
mplayerplug-in-3.35.ebuild:
diff --git a/net-www/mplayerplug-in/files/mplayerplug-in-3.31-firefox.patch b/net-www/mplayerplug-in/files/mplayerplug-in-3.31-firefox.patch
new file mode 100644
index 000000000000..4f94b5760d2d
--- /dev/null
+++ b/net-www/mplayerplug-in/files/mplayerplug-in-3.31-firefox.patch
@@ -0,0 +1,57 @@
+--- configure.in.bak 2007-02-26 22:38:04.000000000 -0500
++++ configure.in 2007-02-26 22:37:16.000000000 -0500
+@@ -44,7 +44,7 @@
+ PKG_CHECK_MODULES(MOZPLUG,[mozilla-plugin],[AC_SUBST(MOZPLUG_CFLAGS) MOZPLUG_CFLAGS="${MOZPLUG_CFLAGS} -I`$PKG_CONFIG --variable=includedir mozilla-plugin`"],[AC_MSG_WARN([mozilla-plugin not found])])
+
+ if test "$MOZPLUG_CFLAGS" = ""; then
+- PKG_CHECK_MODULES(MOZPLUG,[firefox-plugin],[AC_SUBST(MOZPLUG_CFLAGS) MOZPLUG_CFLAGS="${MOZPLUG_CFLAGS} -I`$PKG_CONFIG --variable=includedir firefox-plugin`"],[AC_MSG_WARN([firefox-plugin not found])])
++ PKG_CHECK_MODULES(MOZPLUG,[firefox-plugin firefox-xpcom],[AC_SUBST(MOZPLUG_CFLAGS) MOZPLUG_CFLAGS="${MOZPLUG_CFLAGS} -I`$PKG_CONFIG --variable=includedir firefox-plugin`"],[AC_MSG_WARN([firefox-plugin not found])])
+ fi
+ if test "$MOZPLUG_CFLAGS" = ""; then
+ PKG_CHECK_MODULES(MOZPLUG,[seamonkey-plugin],[AC_SUBST(MOZPLUG_CFLAGS) MOZPLUG_CFLAGS="${MOZPLUG_CFLAGS} -I`$PKG_CONFIG --variable=includedir seamonkey-plugin`"],[AC_MSG_WARN([seamonkey-plugin not found])])
+--- configure.bak 2006-08-27 15:26:34.000000000 -0400
++++ configure 2007-02-26 22:37:16.000000000 -0500
+@@ -3076,12 +3076,12 @@
+ pkg_cv_MOZPLUG_CFLAGS="$MOZPLUG_CFLAGS"
+ else
+ if test -n "$PKG_CONFIG" && \
+- { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"firefox-plugin\"") >&5
+- ($PKG_CONFIG --exists --print-errors "firefox-plugin") 2>&5
++ { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"firefox-plugin firefox-xpcom\"") >&5
++ ($PKG_CONFIG --exists --print-errors "firefox-plugin firefox-xpcom") 2>&5
+ ac_status=$?
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); }; then
+- pkg_cv_MOZPLUG_CFLAGS=`$PKG_CONFIG --cflags "firefox-plugin" 2>/dev/null`
++ pkg_cv_MOZPLUG_CFLAGS=`$PKG_CONFIG --cflags "firefox-plugin firefox-xpcom" 2>/dev/null`
+ else
+ pkg_failed=yes
+ fi
+@@ -3094,12 +3094,12 @@
+ pkg_cv_MOZPLUG_LIBS="$MOZPLUG_LIBS"
+ else
+ if test -n "$PKG_CONFIG" && \
+- { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"firefox-plugin\"") >&5
+- ($PKG_CONFIG --exists --print-errors "firefox-plugin") 2>&5
++ { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"firefox-plugin firefox-xpcom\"") >&5
++ ($PKG_CONFIG --exists --print-errors "firefox-plugin firefox-xpcom") 2>&5
+ ac_status=$?
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); }; then
+- pkg_cv_MOZPLUG_LIBS=`$PKG_CONFIG --libs "firefox-plugin" 2>/dev/null`
++ pkg_cv_MOZPLUG_LIBS=`$PKG_CONFIG --libs "firefox-plugin firefox-xpcom" 2>/dev/null`
+ else
+ pkg_failed=yes
+ fi
+@@ -3118,9 +3118,9 @@
+ _pkg_short_errors_supported=no
+ fi
+ if test $_pkg_short_errors_supported = yes; then
+- MOZPLUG_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors "firefox-plugin"`
++ MOZPLUG_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors "firefox-plugin firefox-xpcom"`
+ else
+- MOZPLUG_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "firefox-plugin"`
++ MOZPLUG_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "firefox-plugin firefox-xpcom"`
+ fi
+ # Put the nasty error message in config.log where it belongs
+ echo "$MOZPLUG_PKG_ERRORS" >&5
diff --git a/net-www/mplayerplug-in/files/mplayerplug-in-3.35-firefox.patch b/net-www/mplayerplug-in/files/mplayerplug-in-3.35-firefox.patch
new file mode 100644
index 000000000000..77152e893710
--- /dev/null
+++ b/net-www/mplayerplug-in/files/mplayerplug-in-3.35-firefox.patch
@@ -0,0 +1,57 @@
+--- configure.in 2007/01/28 14:24:25 1.75
++++ configure.in 2007/02/26 18:28:41 1.76
+@@ -59,7 +59,7 @@
+ ],[AC_MSG_WARN([mozilla-plugin not found])])
+
+ if test "$MOZPLUG_CFLAGS" = ""; then
+- PKG_CHECK_MODULES(MOZPLUG,[firefox-plugin],[AC_SUBST(MOZPLUG_CFLAGS) MOZPLUG_CFLAGS="${MOZPLUG_CFLAGS} -I`$PKG_CONFIG --variable=includedir firefox-plugin`"
++ PKG_CHECK_MODULES(MOZPLUG,[firefox-plugin firefox-xpcom],[AC_SUBST(MOZPLUG_CFLAGS) MOZPLUG_CFLAGS="${MOZPLUG_CFLAGS} -I`$PKG_CONFIG --variable=includedir firefox-plugin`"
+ MOZILLA_HOME=`$PKG_CONFIG --variable=libdir firefox-plugin`
+ ],[AC_MSG_WARN([firefox-plugin not found])])
+ fi
+--- configure 2007/01/28 14:24:24 1.76
++++ configure 2007/02/26 18:28:37 1.77
+@@ -3128,12 +3128,12 @@
+ pkg_cv_MOZPLUG_CFLAGS="$MOZPLUG_CFLAGS"
+ else
+ if test -n "$PKG_CONFIG" && \
+- { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"firefox-plugin\"") >&5
+- ($PKG_CONFIG --exists --print-errors "firefox-plugin") 2>&5
++ { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"firefox-plugin firefox-xpcom\"") >&5
++ ($PKG_CONFIG --exists --print-errors "firefox-plugin firefox-xpcom") 2>&5
+ ac_status=$?
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); }; then
+- pkg_cv_MOZPLUG_CFLAGS=`$PKG_CONFIG --cflags "firefox-plugin" 2>/dev/null`
++ pkg_cv_MOZPLUG_CFLAGS=`$PKG_CONFIG --cflags "firefox-plugin firefox-xpcom" 2>/dev/null`
+ else
+ pkg_failed=yes
+ fi
+@@ -3146,12 +3146,12 @@
+ pkg_cv_MOZPLUG_LIBS="$MOZPLUG_LIBS"
+ else
+ if test -n "$PKG_CONFIG" && \
+- { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"firefox-plugin\"") >&5
+- ($PKG_CONFIG --exists --print-errors "firefox-plugin") 2>&5
++ { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"firefox-plugin firefox-xpcom\"") >&5
++ ($PKG_CONFIG --exists --print-errors "firefox-plugin firefox-xpcom") 2>&5
+ ac_status=$?
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); }; then
+- pkg_cv_MOZPLUG_LIBS=`$PKG_CONFIG --libs "firefox-plugin" 2>/dev/null`
++ pkg_cv_MOZPLUG_LIBS=`$PKG_CONFIG --libs "firefox-plugin firefox-xpcom" 2>/dev/null`
+ else
+ pkg_failed=yes
+ fi
+@@ -3170,9 +3170,9 @@
+ _pkg_short_errors_supported=no
+ fi
+ if test $_pkg_short_errors_supported = yes; then
+- MOZPLUG_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors "firefox-plugin"`
++ MOZPLUG_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors "firefox-plugin firefox-xpcom"`
+ else
+- MOZPLUG_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "firefox-plugin"`
++ MOZPLUG_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "firefox-plugin firefox-xpcom"`
+ fi
+ # Put the nasty error message in config.log where it belongs
+ echo "$MOZPLUG_PKG_ERRORS" >&5
diff --git a/net-www/mplayerplug-in/mplayerplug-in-3.31-r1.ebuild b/net-www/mplayerplug-in/mplayerplug-in-3.31-r1.ebuild
index 801e378919f8..97003308fc2a 100644
--- a/net-www/mplayerplug-in/mplayerplug-in-3.31-r1.ebuild
+++ b/net-www/mplayerplug-in/mplayerplug-in-3.31-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mplayerplug-in/mplayerplug-in-3.31-r1.ebuild,v 1.8 2006/11/01 20:07:27 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mplayerplug-in/mplayerplug-in-3.31-r1.ebuild,v 1.9 2007/02/27 03:51:30 josejx Exp $
inherit eutils multilib nsplugins
@@ -37,6 +37,7 @@ src_unpack() {
cd ${S}
epatch ${FILESDIR}/3.30-fix-cflags.patch
epatch ${FILESDIR}/${PN}-gcc4.patch
+ epatch ${FILESDIR}/${P}-firefox.patch
}
src_compile() {
diff --git a/net-www/mplayerplug-in/mplayerplug-in-3.35.ebuild b/net-www/mplayerplug-in/mplayerplug-in-3.35.ebuild
index cca2f8e6711c..9719ee24b6c4 100644
--- a/net-www/mplayerplug-in/mplayerplug-in-3.35.ebuild
+++ b/net-www/mplayerplug-in/mplayerplug-in-3.35.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mplayerplug-in/mplayerplug-in-3.35.ebuild,v 1.2 2007/01/22 19:12:40 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mplayerplug-in/mplayerplug-in-3.35.ebuild,v 1.3 2007/02/27 03:51:30 josejx Exp $
inherit eutils multilib nsplugins
@@ -10,7 +10,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 -hppa ~ia64 ~ppc sparc ~x86"
+KEYWORDS="~alpha ~amd64 -hppa ~ia64 ppc sparc ~x86"
IUSE="gtk divx gmedia realmedia quicktime wmp"
DEPEND=">=media-video/mplayer-1.0_pre5
@@ -38,6 +38,7 @@ src_unpack() {
epatch ${FILESDIR}/3.30-fix-cflags.patch
epatch ${FILESDIR}/${PN}-gcc4.patch
epatch ${FILESDIR}/${P}-X.patch
+ epatch ${FILESDIR}/${P}-firefox.patch
}
src_compile() {