summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Heim <phreak@gentoo.org>2007-01-25 16:43:19 +0000
committerChristian Heim <phreak@gentoo.org>2007-01-25 16:43:19 +0000
commiteda173799e93c81622fed21d44fec461e8c2d812 (patch)
tree1d2b4bf62f1382addd21d43339fdacbe212c5b40 /net-www
parentblock banshee-official-plugins since it isn't needed for this release. (diff)
downloadgentoo-2-eda173799e93c81622fed21d44fec461e8c2d812.tar.gz
gentoo-2-eda173799e93c81622fed21d44fec461e8c2d812.tar.bz2
gentoo-2-eda173799e93c81622fed21d44fec461e8c2d812.zip
Version bump (thanks to Momsen Reincke <mreincke at gmx.net> in 163499), fixing the compile time bug when dev-libs/apr{,util} is being compiled with LDFLAGS="-Wl,--as-needed".
(Portage version: 2.1.2-r4)
Diffstat (limited to 'net-www')
-rw-r--r--net-www/mod_ftpd/ChangeLog9
-rw-r--r--net-www/mod_ftpd/files/digest-mod_ftpd-0.13.13
-rw-r--r--net-www/mod_ftpd/mod_ftpd-0.13.1.ebuild36
3 files changed, 47 insertions, 1 deletions
diff --git a/net-www/mod_ftpd/ChangeLog b/net-www/mod_ftpd/ChangeLog
index f4fa79d6ce44..3a98b6382427 100644
--- a/net-www/mod_ftpd/ChangeLog
+++ b/net-www/mod_ftpd/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-www/mod_ftpd
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_ftpd/ChangeLog,v 1.10 2007/01/14 16:43:50 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_ftpd/ChangeLog,v 1.11 2007/01/25 16:43:19 phreak Exp $
+
+*mod_ftpd-0.13.1 (25 Jan 2007)
+
+ 25 Jan 2007; Christian Heim <phreak@gentoo.org> +mod_ftpd-0.13.1.ebuild:
+ Version bump (thanks to Momsen Reincke <mreincke at gmx.net> in 163499),
+ fixing the compile time bug when dev-libs/apr{,util} is being compiled with
+ LDFLAGS="-Wl,--as-needed".
14 Jan 2007; Luca Longinotti <chtekk@gentoo.org>
-files/0.12.3-mod_ftpd-ipv6.patch, -files/mod_ftpd.conf,
diff --git a/net-www/mod_ftpd/files/digest-mod_ftpd-0.13.1 b/net-www/mod_ftpd/files/digest-mod_ftpd-0.13.1
new file mode 100644
index 000000000000..a5ab90c8f3a9
--- /dev/null
+++ b/net-www/mod_ftpd/files/digest-mod_ftpd-0.13.1
@@ -0,0 +1,3 @@
+MD5 236bbacd61d434069d71493de916609f mod_ftpd-0.13.1.tar.bz2 325493
+RMD160 43bda3c1932a7cdc1a98da99ee314a94d88d8757 mod_ftpd-0.13.1.tar.bz2 325493
+SHA256 780d0de38a865c0dbb44df49dfc675d769c90b14dd60600858137f0cf21059a6 mod_ftpd-0.13.1.tar.bz2 325493
diff --git a/net-www/mod_ftpd/mod_ftpd-0.13.1.ebuild b/net-www/mod_ftpd/mod_ftpd-0.13.1.ebuild
new file mode 100644
index 000000000000..12ced2b6cd74
--- /dev/null
+++ b/net-www/mod_ftpd/mod_ftpd-0.13.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_ftpd/mod_ftpd-0.13.1.ebuild,v 1.1 2007/01/25 16:43:19 phreak Exp $
+
+inherit eutils apache-module
+
+DESCRIPTION="Apache2 protocol module which provides an FTP server"
+HOMEPAGE="http://www.outoforder.cc/projects/apache/mod_ftpd/"
+SRC_URI="http://www.outoforder.cc/downloads/${PN}/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE="dbi gdbm"
+
+DEPEND="gdbm? ( >=sys-libs/gdbm-1.8.0-r5 )"
+RDEPEND="${DEPEND}"
+
+APACHE2_EXECFILES="providers/*/.libs/*.so"
+APACHE2_MOD_CONF="45_${PN}"
+APACHE2_MOD_DEFINE="FTPD"
+
+DOCFILES="docs/manual.html AUTHORS ChangeLog NOTICE README TODO"
+
+need_apache2
+
+src_compile() {
+ local providers="default fail"
+
+ use gdbm && providers="dbm ${providers}"
+ use dbi && providers="dbi ${providers}"
+
+ econf --with-apxs=${APXS2} \
+ --enable-providers="${providers}" || die "econf failed!"
+ emake || die "emake failed!"
+}