summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-09-29 17:54:40 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-09-29 17:54:40 +0000
commit6291a6f5d38264c18eb8aa1a000fb5ab3b7e585e (patch)
tree7a8ffd44aa4da06b814dea1e088ffffc24f5fe64 /net-zope/tempstorage/tempstorage-2.12.1.ebuild
parentDelete older ebuild. (diff)
downloadgentoo-2-6291a6f5d38264c18eb8aa1a000fb5ab3b7e585e.tar.gz
gentoo-2-6291a6f5d38264c18eb8aa1a000fb5ab3b7e585e.tar.bz2
gentoo-2-6291a6f5d38264c18eb8aa1a000fb5ab3b7e585e.zip
Version bump.
(Portage version: 2.2_rc88_p38/cvs/Linux x86_64)
Diffstat (limited to 'net-zope/tempstorage/tempstorage-2.12.1.ebuild')
-rw-r--r--net-zope/tempstorage/tempstorage-2.12.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-zope/tempstorage/tempstorage-2.12.1.ebuild b/net-zope/tempstorage/tempstorage-2.12.1.ebuild
new file mode 100644
index 000000000000..bc158617482a
--- /dev/null
+++ b/net-zope/tempstorage/tempstorage-2.12.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/tempstorage/tempstorage-2.12.1.ebuild,v 1.1 2010/09/29 17:54:40 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils
+
+DESCRIPTION="A RAM-based storage for ZODB"
+HOMEPAGE="http://pypi.python.org/pypi/tempstorage"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="test"
+
+RDEPEND=">=net-zope/zodb-3.9.0"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-python/setuptools"
+
+DOCS="CHANGES.txt README.txt"
+
+src_install() {
+ distutils_src_install
+
+ delete_tests() {
+ rm -fr "${ED}$(python_get_sitedir)/tempstorage/tests"
+ }
+ python_execute_function -q delete_tests
+}