summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2009-03-13 09:11:25 +0000
committerAlfredo Tupone <tupone@gentoo.org>2009-03-13 09:11:25 +0000
commit6c13d970e83f189e352c84ff4438832e59eb1ef5 (patch)
treeba5d0573d403be9941e989e82444a0ba4498af7f /net-zope/zcbuildout
parentclean up (diff)
downloadgentoo-2-6c13d970e83f189e352c84ff4438832e59eb1ef5.tar.gz
gentoo-2-6c13d970e83f189e352c84ff4438832e59eb1ef5.tar.bz2
gentoo-2-6c13d970e83f189e352c84ff4438832e59eb1ef5.zip
System for managing development buildouts.
(Portage version: 2.1.6.7/cvs/Linux x86_64)
Diffstat (limited to 'net-zope/zcbuildout')
-rw-r--r--net-zope/zcbuildout/ChangeLog10
-rw-r--r--net-zope/zcbuildout/metadata.xml22
-rw-r--r--net-zope/zcbuildout/zcbuildout-1.1.1.ebuild23
3 files changed, 55 insertions, 0 deletions
diff --git a/net-zope/zcbuildout/ChangeLog b/net-zope/zcbuildout/ChangeLog
new file mode 100644
index 000000000000..ee5c2be9c1ac
--- /dev/null
+++ b/net-zope/zcbuildout/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-zope/zcbuildout
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zcbuildout/ChangeLog,v 1.1 2009/03/13 09:11:25 tupone Exp $
+
+*zcbuildout-1.1.1 (13 Mar 2009)
+
+ 13 Mar 2009; Alfredo Tupone <tupone@gentoo.org> +metadata.xml,
+ +zcbuildout-1.1.1.ebuild:
+ System for managing development buildouts.
+
diff --git a/net-zope/zcbuildout/metadata.xml b/net-zope/zcbuildout/metadata.xml
new file mode 100644
index 000000000000..93d60c5c9928
--- /dev/null
+++ b/net-zope/zcbuildout/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-zope</herd>
+<maintainer>
+<email>tupone@gentoo.org</email>
+<name>Alfredo Tupone</name>
+</maintainer>
+<longdescription lang="en">
+Buildout is a system for managing development buildouts. While often identified as a Zope project,
+and indeed licensed under the ZPL by Zope creator Jim Fulton, buildout is useful for configurations
+beyond Zope, and even, in rare cases, a few that have nothing to do with Python.
+The Buildout project provides support for creating applications, especially Python applications. It
+provides tools for assembling applications from multiple parts, Python or otherwise. An application
+may actually contain multiple programs, processes, and configuration settings.
+The word .buildout. refers to a description of a set of parts and the software to create and assemble
+them. It is often used informally to refer to an installed system based on a buildout definition. For
+example, if we are creating an application named .Foo., then .the Foo buildout. is the collection of
+configuration and application-specific software that allows an instance of the application to be
+created. We may refer to such an instance of the application informally as .a Foo buildout..
+</longdescription>
+</pkgmetadata>
diff --git a/net-zope/zcbuildout/zcbuildout-1.1.1.ebuild b/net-zope/zcbuildout/zcbuildout-1.1.1.ebuild
new file mode 100644
index 000000000000..4bd19cf803e0
--- /dev/null
+++ b/net-zope/zcbuildout/zcbuildout-1.1.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zcbuildout/zcbuildout-1.1.1.ebuild,v 1.1 2009/03/13 09:11:25 tupone Exp $
+
+inherit distutils
+
+MY_PN="zc.buildout"
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="System for managing development buildouts"
+HOMEPAGE="http://buildout.zope.org/"
+SRC_URI="http://pypi.python.org/packages/source/z/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+S="${WORKDIR}"/${MY_P}