summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-07 00:09:09 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-07 00:09:09 +0000
commit2d46555769959c1fe651729c10dfe004da37c0b9 (patch)
treee787e9725450037799354d604a82a7517b8b4ee8 /net-zope/zope-exceptions
parentDelete older ebuild. (diff)
downloadgentoo-2-2d46555769959c1fe651729c10dfe004da37c0b9.tar.gz
gentoo-2-2d46555769959c1fe651729c10dfe004da37c0b9.tar.bz2
gentoo-2-2d46555769959c1fe651729c10dfe004da37c0b9.zip
Version bump. Fixed tests with Python 2.7 and Python 3.2 (bug #318807).
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'net-zope/zope-exceptions')
-rw-r--r--net-zope/zope-exceptions/ChangeLog8
-rw-r--r--net-zope/zope-exceptions/zope-exceptions-3.6.1.ebuild33
2 files changed, 40 insertions, 1 deletions
diff --git a/net-zope/zope-exceptions/ChangeLog b/net-zope/zope-exceptions/ChangeLog
index 6dad5bd80223..137a087ec077 100644
--- a/net-zope/zope-exceptions/ChangeLog
+++ b/net-zope/zope-exceptions/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-zope/zope-exceptions
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-zope/zope-exceptions/ChangeLog,v 1.5 2010/05/07 00:23:33 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope-exceptions/ChangeLog,v 1.6 2010/07/07 00:09:09 arfrever Exp $
+
+*zope-exceptions-3.6.1 (07 Jul 2010)
+
+ 07 Jul 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -zope-exceptions-3.6.0.ebuild, +zope-exceptions-3.6.1.ebuild:
+ Version bump. Fixed tests with Python 2.7 and Python 3.2 (bug #318807).
*zope-exceptions-3.6.0 (07 May 2010)
diff --git a/net-zope/zope-exceptions/zope-exceptions-3.6.1.ebuild b/net-zope/zope-exceptions/zope-exceptions-3.6.1.ebuild
new file mode 100644
index 000000000000..aad9b1923d7c
--- /dev/null
+++ b/net-zope/zope-exceptions/zope-exceptions-3.6.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope-exceptions/zope-exceptions-3.6.1.ebuild,v 1.1 2010/07/07 00:09:09 arfrever Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+DISTUTILS_SRC_TEST="setup.py"
+
+inherit distutils
+
+MY_PN="${PN/-/.}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Zope Exceptions"
+HOMEPAGE="http://pypi.python.org/pypi/zope.exceptions"
+SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="net-zope/zope-interface"
+# net-zope/zope-fixers is required for building with Python 3.
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-python/setuptools
+ net-zope/zope-fixers"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="CHANGES.txt README.txt"
+PYTHON_MODNAME="${PN/-//}"