summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRadoslaw Stachowiak <radek@gentoo.org>2006-10-03 11:53:33 +0000
committerRadoslaw Stachowiak <radek@gentoo.org>2006-10-03 11:53:33 +0000
commit50992812726c23f3504801390711f0efa8045a7b (patch)
tree4b3466bc4001e8882ed4c517e7668eac31ef4f92 /net-zope
parentBump to 3.5.5 (pre-release). (diff)
downloadgentoo-2-50992812726c23f3504801390711f0efa8045a7b.tar.gz
gentoo-2-50992812726c23f3504801390711f0efa8045a7b.tar.bz2
gentoo-2-50992812726c23f3504801390711f0efa8045a7b.zip
version bump
(Portage version: 2.1.2_pre2-r1)
Diffstat (limited to 'net-zope')
-rw-r--r--net-zope/zope/ChangeLog8
-rw-r--r--net-zope/zope/files/digest-zope-2.10.03
-rw-r--r--net-zope/zope/zope-2.10.0.ebuild79
-rw-r--r--net-zope/zope/zope-2.9.4.ebuild4
-rw-r--r--net-zope/zope/zope-2.9.5.ebuild6
5 files changed, 91 insertions, 9 deletions
diff --git a/net-zope/zope/ChangeLog b/net-zope/zope/ChangeLog
index c40fad5e65c6..94c072c28689 100644
--- a/net-zope/zope/ChangeLog
+++ b/net-zope/zope/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-zope/zope
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-zope/zope/ChangeLog,v 1.114 2006/10/02 16:27:21 radek Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope/ChangeLog,v 1.115 2006/10/03 11:53:33 radek Exp $
+
+*zope-2.10.0 (03 Oct 2006)
+
+ 03 Oct 2006; Radoslaw Stachowiak <radek@gentoo.org> zope-2.9.4.ebuild,
+ zope-2.9.5.ebuild, +zope-2.10.0.ebuild:
+ version bump
*zope-3.2.2 (02 Oct 2006)
*zope-2.9.5 (02 Oct 2006)
diff --git a/net-zope/zope/files/digest-zope-2.10.0 b/net-zope/zope/files/digest-zope-2.10.0
new file mode 100644
index 000000000000..da2811332345
--- /dev/null
+++ b/net-zope/zope/files/digest-zope-2.10.0
@@ -0,0 +1,3 @@
+MD5 4ff264d6a002e51a7853a096e72aa6d1 Zope-2.10.0-final.tgz 7123131
+RMD160 f3dd52d72d512057f722b822f4f6bfd578229d86 Zope-2.10.0-final.tgz 7123131
+SHA256 4a9f8649390942d7faad3a90c128b4f36c3cbcdce5f06a2d13ab367add458f30 Zope-2.10.0-final.tgz 7123131
diff --git a/net-zope/zope/zope-2.10.0.ebuild b/net-zope/zope/zope-2.10.0.ebuild
new file mode 100644
index 000000000000..6cbe102402b7
--- /dev/null
+++ b/net-zope/zope/zope-2.10.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope/zope-2.10.0.ebuild,v 1.1 2006/10/03 11:53:33 radek Exp $
+
+inherit eutils multilib
+
+DESCRIPTION="Zope is a web application platform used for building high-performance, dynamic web sites"
+HOMEPAGE="http://www.zope.org"
+SRC_URI="http://www.zope.org/Products/Zope/${PV}/Zope-${PV}-final.tgz"
+
+LICENSE="ZPL"
+SLOT="${PV}"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="=dev-lang/python-2.4*"
+
+DEPEND="${RDEPEND}
+virtual/libc
+>=sys-apps/sed-4.0.5"
+
+S="${WORKDIR}/Zope-${PV}-final"
+ZUID=zope
+ZGID=zope
+ZS_DIR=${ROOT%/}/usr/$(get_libdir)
+ZSERVDIR=${ZS_DIR}/${P}
+
+# Narrow the scope of ownership/permissions.
+# Security plan:
+# * ZUID is the superuser for all zope instances.
+# * ZGID is for a single instance's administration.
+# * Other' should not have any access to ${ZSERVDIR},
+# because they can work through the Zope web interface.
+# This should protect our code/data better.
+#
+# UPDATE: ${ZSERVDIR} is a lib directory and should be world readable
+# like e.g /usr/lib/python we do not store any user data there,
+# currently removed all custom permission stuff, for ${ZSERVDIR}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+}
+
+src_compile() {
+ ./configure --prefix="${D}${ZSERVDIR}" --with-python=/usr/bin/python2.4 || die "Failed to execute ./configure ..."
+ emake || die "Failed to compile."
+}
+
+src_install() {
+ dodoc README.txt
+ dodoc Zope/doc/*.txt
+ docinto PLATFORMS ; dodoc Zope/doc/PLATFORMS/*
+ docinto ZEO ; dodoc Zope/doc/ZEO/*
+
+ make install prefix=${D}${ZSERVDIR} || die "Failed to install into ${D}${ZSERVDIR}"
+ rm -rf ${D}${ZSERVDIR}/doc
+ dosym ../../share/doc/${PF} ${ZSERVDIR}/doc
+
+ # copy the init script skeleton to skel directory of our installation
+ cp ${FILESDIR}/zope.initd ${D}/${ZSERVDIR}/skel/zope.initd
+}
+
+pkg_postinst() {
+ # create the zope user and group for backward compatibility
+ enewgroup ${ZGID} 261
+ usermod -g ${ZGID} ${ZUID} 2>&1 >/dev/null || \
+ enewuser ${ZUID} 261 -1 /var/$(get_libdir)/zope ${ZGID}
+
+ einfo "Be warned that you need at least one zope instance to run zope."
+ einfo "Please emerge zope-config for futher instance management."
+}
+
+pkg_prerm() {
+
+ #need to remove this symlink because portage keeps links to
+ #existing targets
+ rm ${ZSERVDIR}/bin/python
+}
diff --git a/net-zope/zope/zope-2.9.4.ebuild b/net-zope/zope/zope-2.9.4.ebuild
index e0eaaf0e7abe..9759e7466535 100644
--- a/net-zope/zope/zope-2.9.4.ebuild
+++ b/net-zope/zope/zope-2.9.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-zope/zope/zope-2.9.4.ebuild,v 1.2 2006/08/27 16:59:37 radek Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope/zope-2.9.4.ebuild,v 1.3 2006/10/03 11:53:33 radek Exp $
inherit eutils multilib
@@ -61,8 +61,6 @@ src_install() {
cp ${FILESDIR}/zope.initd ${D}/${ZSERVDIR}/skel/zope.initd
epatch ${FILESDIR}/2.9/${P}_logerror.patch
- pwd
- sleep 15
}
pkg_postinst() {
diff --git a/net-zope/zope/zope-2.9.5.ebuild b/net-zope/zope/zope-2.9.5.ebuild
index 82c166574816..0fbb6a8c09ad 100644
--- a/net-zope/zope/zope-2.9.5.ebuild
+++ b/net-zope/zope/zope-2.9.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-zope/zope/zope-2.9.5.ebuild,v 1.1 2006/10/02 16:27:21 radek Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope/zope-2.9.5.ebuild,v 1.2 2006/10/03 11:53:33 radek Exp $
inherit eutils multilib
@@ -59,10 +59,6 @@ src_install() {
# copy the init script skeleton to skel directory of our installation
cp ${FILESDIR}/zope.initd ${D}/${ZSERVDIR}/skel/zope.initd
-
- epatch ${FILESDIR}/2.9/${P}_logerror.patch
- pwd
- sleep 15
}
pkg_postinst() {